Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Barry Troxtell

2005 Polaris Sportsman 500 Instrument Cluster Issues

Recommended Posts

I have a 2005 Sportsman 500, Instrument cluster will not illuminate, hi/lo beams work though.  Any tips or troubleshooting info is greatly appreciated!

Share this post


Link to post
Share on other sites


Hey Barry, welcome to Quadcrazy! 
The cluster on the dash should have nothing to do with the high/low beams. 
If the cluster is working properly aside from the illuminating portion then there may be a problem internally with the cluster. I would move some wires around going into the cluster and see if it comes on like a loose connection.  I am not 100% sure but my guess would be if the cluster has power and shows the diagnostic portion (mph/rpm) of the atv and  the illumination portion should work as well.   

Share this post


Link to post
Share on other sites

Hey Frank! Thanks for the reply!  Sorry I didn't state there is no illumination on the cluster at all, no diagnostic display at all.  Just assuming the key turned on allowing the lights to turn on means I'm getting power to the pod? ]

 

I moved this unit from one garage bay to the another garage this morning it was fine, went back in an hour or so to move it back and it did this.  I can't grasp what the issue is.....possibly a ground issue?   

Share this post


Link to post
Share on other sites

It could be a ground issue or a corroded fuse. I would go get some dielectric grease and start taking plugs and fuses apart, clean all areas and apply the grease and reconnect.    Some plugs may be tough to get to since they are located under the front plastic right where that cluster is located so you may have to pull that plastic off.   

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

  • Similar Tagged Content

    • By David Miller
      Does anyone know how to access the check engine codes on a 2018 450 sportsman. Just changed battery and spark plug . It runs fine but the light is on and I need this to plow snow and need it reliable. Any ideas . Thanks
    • By marek porowski
      Hi, I got a check engine light and a diagnostic code 520194 2 and i know it has something to do with throttle voltage out of range
      I'd like to know if thats something that can be adjusted ? Or does anybody know what should i test  ?  I just bought this atv and I'm fixing it as its been in an accident. 
      I also changed throttle leaver as original one was broken and I noticed inside the 4x4 selector assembly there are 2 contacts but I'm not sure if they're suppose to make contact at idle. I found some info online but some are saying they're suppose to touch and some say they're not. I think id depends of the year of the machine but I'm not sure. I'd really appreciate any help that i can get with this
      Thanks 
    • By Christian Brindle
      I have a 2000 Polaris Sportsman 500. The Speedometer got water inside of it and it sat for a long time. So now that speedometer is trashed to say the least and i need to find a replacement. I don't want to put up the cash for an oem one so i was wondering if anyone knew any good speedometers out there i could use. I've found many speedometers i like but don't know how i'd wire it up without the same connection points. Thanks, any input is appreciated
    • By Eddie Rahm
      whats up fellas....the white wire going from the throttle body came unplugged from the circuit  board and im not sure where it plugs back in to ? i see where the red wire goes but im not sure where the white wire goes...im not even sure what those wires do..any help would be appreciated..thanks. 1996 polaris sportsman 500 4x4 push button awd.
    • By Matt Schuldt
      Looking at a 2004 Polaris Sportsman 600, with new winch, new 48” plow, 2200 miles and clean.   Serviced 200 miles ago, new battery.  Selling for $3100....yay or nay.  Color is yellow🤓
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...