Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

marek porowski

2017 Polaris Sportsman 570sp code 520194 2

Recommended Posts

Hi, I got a check engine light and a diagnostic code 520194 2 and i know it has something to do with throttle voltage out of range

I'd like to know if thats something that can be adjusted ? Or does anybody know what should i test  ?  I just bought this atv and I'm fixing it as its been in an accident. 

I also changed throttle leaver as original one was broken and I noticed inside the 4x4 selector assembly there are 2 contacts but I'm not sure if they're suppose to make contact at idle. I found some info online but some are saying they're suppose to touch and some say they're not. I think id depends of the year of the machine but I'm not sure. I'd really appreciate any help that i can get with this

Thanks 

  • Like 1

Share this post


Link to post
Share on other sites


thanks for the reply

Yes I did see it  and I checked that connector and everything looked Clean and was plugged in tight. 
I finally got my parts yesterday and assembled the suspension on it so I’ll be able to take it for a ride this weekend I hope and I’ll see if the code clears or it it is affecting how it’s running 
 

  • Like 1

Share this post


Link to post
Share on other sites

I was looking around and found some chatter on this code. Here’s a page of some possible solutions from I think a Polaris dealer.  
 

B0C057EA-6C14-4248-B8A7-7428B2F50807.jpeg

  • Like 1

Share this post


Link to post
Share on other sites


I checked the resistance on pins 1 and 2 and it does change when I press the throttle. It was around 2150 ohms when I press the throttle it jumps to over 6000 ohms so I’m guessing the switch is working correctly.

 When I started it up the code was gone and didn’t come back yet so either it was the connection or something else.

Thank you guys for your help 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Scott Sirr
      I need to figure out how to clean/fix or replace my neutral switch assembly On my 2008 Yamaha big bear 400 as generally the neutral light doesn’t come on when it is in neutral. To get it to come on I have to wiggle the foot shifter and hold it in just the right spot.
      I have googled it and can’t find much on the 400’s. I can’t find a service manual online and the parts manual is super vague.
      I think it is in the right side engine cover area, but not certain. 
       Any help would be great. thanks
      Scott
    • By David Miller
      Does anyone know how to access the check engine codes on a 2018 450 sportsman. Just changed battery and spark plug . It runs fine but the light is on and I need this to plow snow and need it reliable. Any ideas . Thanks
    • By Juan Gutierrez
      hello all. i have a suzuki lt230e engine. hopefully i can get it to drive some wheels soon.
    • By Eddie Rahm
      whats up fellas....the white wire going from the throttle body came unplugged from the circuit  board and im not sure where it plugs back in to ? i see where the red wire goes but im not sure where the white wire goes...im not even sure what those wires do..any help would be appreciated..thanks. 1996 polaris sportsman 500 4x4 push button awd.
    • By zont
      Hi, I have just purchased a 2002 Yamaha Kodiak 400 I think, the vin has worn off and I have located an engine number I think it is J312E-004674, could anyone tell me where the engine number might be please
  • Similar Tagged Content

    • By David Miller
      Does anyone know how to access the check engine codes on a 2018 450 sportsman. Just changed battery and spark plug . It runs fine but the light is on and I need this to plow snow and need it reliable. Any ideas . Thanks
    • By Barry Troxtell
      I have a 2005 Sportsman 500, Instrument cluster will not illuminate, hi/lo beams work though.  Any tips or troubleshooting info is greatly appreciated!
    • By Christian Brindle
      I have a 2000 Polaris Sportsman 500. The Speedometer got water inside of it and it sat for a long time. So now that speedometer is trashed to say the least and i need to find a replacement. I don't want to put up the cash for an oem one so i was wondering if anyone knew any good speedometers out there i could use. I've found many speedometers i like but don't know how i'd wire it up without the same connection points. Thanks, any input is appreciated
    • By Eddie Rahm
      whats up fellas....the white wire going from the throttle body came unplugged from the circuit  board and im not sure where it plugs back in to ? i see where the red wire goes but im not sure where the white wire goes...im not even sure what those wires do..any help would be appreciated..thanks. 1996 polaris sportsman 500 4x4 push button awd.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...