Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

David Miller

Polaris 2018 sportsman check engine light

Recommended Posts

Does anyone know how to access the check engine codes on a 2018 450 sportsman. Just changed battery and spark plug . It runs fine but the light is on and I need this to plow snow and need it reliable. Any ideas . Thanks

Share this post


Link to post
Share on other sites


For my 2018 570 (may be it's the same ), i have to press and hold "Mode" button to see "Diagcode" on the display.

  • Like 2

Share this post


Link to post
Share on other sites

Helpful info here, I have an 07 sportsman 800 and it was different for the older models.  @David Miller, did this help you resolve your issues?  What was the code for?

Share this post


Link to post
Share on other sites

Anyone know where I can find service manuals for Polaris Sportsman? Specifically 2014 550.

My Sportsman 550 has code = 520269-4

I can't find any info on it. Does anyone know what this code means?

Share this post


Link to post
Share on other sites


On 2/13/2020 at 3:04 PM, Powder Coater said:

Anyone know where I can find service manuals for Polaris Sportsman? Specifically 2014 550.

My Sportsman 550 has code = 520269-4

I can't find any info on it. Does anyone know what this code means?

The only 550 manual we have in the downloads section are:

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Kayla Frieswick
      2001 Yamaha Wolverine new coil new solenoid switch new battery no spark
    • By bren7176
      Doeas any have the actual electrical diagram for the distirbution block  for this atv > I had a few wire not worky worky so needed to replace ends plus dam thiing is dirty so needs to clean all the contacts ..
      Want to make shure I get eveything back in right place .... I have the repair manual but as we know it no help really .....
       
      Brendan
    • By JacobSlabach
      Hey I have a 97 bayou 300 2x4 (klf300b) that i bought for 1000 last June and sunk another 1000 into it already.  When i went to look at it, the seller had warmed it up before hand (he was riding it when I got there).  it ran good so i bought it and took it home that evening... next morning it wouldn't hardly start.  I discovered the carb was clogged, there was chunks of rust in the fuel valve, the choke lever was missing and other things.  I have since cleaned the carb and replaced the fuel valve and gas lines and cleaned out the gas tank and cap.  
      Enough background on it, the problem is this:  It floods if i push it past half throttle in 4th and 5th gear even going downhill and shifting correctly.  It also has to idle and warm up when you first start it which is really annoying now that its cold...  It also smokes blue smoke for about 15 seconds when started cold-  does not smoke at all once warm but the exhaust still smells like burnt metal.  A friend told me that it didn't have enough compression.  I also found out that the valves are a common cause for low compression on Kawasakis..  I have never adjusted valves before-  the most I've ever got into a engine was a head gasket on a riding mower so I'm new to this.  My goal is to get this bike running and starting cold like a top-  should i tear down and rebuild the top end?  What should i try first?  I tore the carb apart and rebuilt it and fiddled with the air screw and nothing changed.  I also ordered a compression test kit that should be coming in soon.

      Ive also considered just selling it for like $500 and taking the hit-  Id rather not sink too much more into this machine..  lol
    • By Matt John
      Charging issue?
      I have a 2017 Polaris Sportsman 570 EFI. Yesterday, I start the machine and it says low power (10.6-10.8). This machine is on its second battery. This is a new AGM battery with 50cca more than stock.
      Should I look at the regulator or stator?
      Thanks!!!
  • Similar Tagged Content

    • By dany desbiens
      Hello i have a Polaris 2003 sportsman 600 Polaris Sportsman OEM Gauge Speedo Speedometer Display Dash Cluster 3280425 the speedo is not working no 4*4 i can find nothing can i put a speedo 2004Speedometer Gauge Speedo
      3280431 04-08 Sportsman if it will work
    • By turner_clint77
      Just have a couple questions 
      first does anyone else have an issue with the right hand tie rods coming loose 
      second does anyone else’s power steering making a weird sound at times 
    • By marek porowski
      Hi, I got a check engine light and a diagnostic code 520194 2 and i know it has something to do with throttle voltage out of range
      I'd like to know if thats something that can be adjusted ? Or does anybody know what should i test  ?  I just bought this atv and I'm fixing it as its been in an accident. 
      I also changed throttle leaver as original one was broken and I noticed inside the 4x4 selector assembly there are 2 contacts but I'm not sure if they're suppose to make contact at idle. I found some info online but some are saying they're suppose to touch and some say they're not. I think id depends of the year of the machine but I'm not sure. I'd really appreciate any help that i can get with this
      Thanks 
    • By Barry Troxtell
      I have a 2005 Sportsman 500, Instrument cluster will not illuminate, hi/lo beams work though.  Any tips or troubleshooting info is greatly appreciated!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...