Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

BrotherRockeye

Hello from Saskatchewan

Recommended Posts

I've been reading threads here for a while now and figured it was about time I signed up and gave back a bit.

My kids are gone from home now so I sold their Honda's off last fall

I still have a few Polaris machines on the place to get around on.

I use my quads for chore horses around the ranch so they get used but not abused if I can help it...which of course I can't...all the time...

Well, thanks for havin me folks, Ima hava look around ;)

 

  • Like 1

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By dany desbiens
      Hello i have a Polaris 2003 sportsman 600 Polaris Sportsman OEM Gauge Speedo Speedometer Display Dash Cluster 3280425 the speedo is not working no 4*4 i can find nothing can i put a speedo 2004Speedometer Gauge Speedo
      3280431 04-08 Sportsman if it will work
    • By Aaron Drost
      Hello bought my 2000 polaris sportsman 500 last week bike seems to work pretty good untill yesterday, when in reverse the bike seems to start bogging out? How come? 
    • By Arizona
      So few months ago I acquired a 01 Explorer 4x4 (think its a 350 but not sure) 
      Anyway the owner said it started reving very high, shut the key off and still kept running 
      until finally he shut off fuel and it finally died. During the run away he said the exhaust got 
      red hot and has melted plastics to prove it. Said some thing flew out the tail pipe, I kinda figured
      it was the top of the piston. Anyway finally got around to looking at it (have a lot of other projects in the works)
      and checked the compression, Shows about 40 psi. Can hear air coming out the carb while rotating the motor over. 
      Gonna pull it apart eventually, don't hear any noises or binding in the stroke, You think the piston came apart? 
      any horror stories of these and is it worth my effort and money? Don't really have any money in it yet. Thoughts? Az


    • By bodon
      I have a 2011 850 Sportsman.  Has been absolutely trouble free except for 1 thing. I am on my 4th. ignition switch. I don't know if it's that they are all chinese junk or what.  It gets to a point  when you turn the key and it will act like the battery is going bad. Cranks real slow or not at all. Put a new switch in and its fine. New one will last 1 1/2 - 2 years and its junk. I've had the Polaris brand and after market. As a matter of fact the original one lasted the lest amount of time.  Other than that it's been a perfect machine . No electrical problems. No battery problems. Just curious if anyone else has had the same issue.
    • By technofarmer
      Well its finally happened, its time to replace the belt on my 2011 Polaris Sportsman 500 H.O.   Is there anything specific i need to know before getting into it? Is there one brand of belt i should get over another?   I'm still on my first Polaris and plan to keep it at least another 8 years.   
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...