Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Ssg

2019 Can-Am Outlander 850 XMR CVT Clutch Kit Questions

Recommended Posts

Hello! This is my first bike with a cvt it's a 19 Outlander 850 xmr. I use the 30" cryptid tires that come with the bike during hunting season since I hunt in a louisiana swamp and I have some 27" interco reptiles during the summer trail rides. So this past hunting season I got stuck and squealed the belt do i looking at cluch kits /adjustments to help with the low end but I dont want to mess with my summer riding so I'm looking for advice 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Julio Cano
      The tires which I bought on ebay cannot be balanced, it’s out of round.Tried riding and had wobble. 
      It was mounted in shop and they also put it on a rim they had sitting in the shop and same issue to confirm it.
      Are they defective ?
      They have brand new high quality tires for my  old suzuki gsxr750 and want about $600 for two tires.
      Is it worth it to pay that much or buy another set of front rear tires like Hexautoparts which has good reviews on trustpilot.com?
      Any recommendations ?
      Thank you.
    • By Hondasher
      I have a 2004 Polaris Trail Boss 330 and I want to eventually fix it up if possible, but the thing is the transmission or Gearbox that allows you to shift into forward and reverse and such isn't connect to the engine at all, it isn't even bolted into the frame. Anyways the Secondary Driven clutch is missing. The ignition was busted so I switched it out and tried to hook up power to it and the lights wouldn't light up and it wouldn't try to let me start it with the electric starter. 
       
      So I bridged the connectors on the starter solenoid and it cranks the motor. I was wondering if anyone knew why the dash lights don't work or any of the buttons. I did find a cable disconnected I have a picture of maybe someone can tell me what it's supposed to be connected to. It has 3 wires going to the connect Green Purple Red. I'll enclose a picture of it and where it is connected on the wiring harness. 
       


    • By Rich1028
      Hitting the Trail in the Morning.
       
      Heading out to Leota Trails 
      It's the Wife's Birthday Weekend,and I asked Her what,or where she wanted to go,she said  she wanted to go riding trails!
       
       
    • By marek porowski
      It’s kind of ATV related question as I need new trailer tires to tow my 4 wheeler. 
      Does anybody have any experience with loadstar 12” trailer tires ? 
      There is not to many choices for trailer tires here in Ontario and I was wandering if somebody can recommend me something. 
    • By Frank Angerano
      Not sure how many of you will remember this or give a crap about it but back in 2016 I picked up my first old atv to rebuild. Yamaha bear tracker 250. I picked it up in NJ while I was out looking for a quad for my little guy since he started this atv thing after seeing a few old pictures of me in my hay day riding. 
       
      The person I was getting the 50cc quad had this one laying around and asked if I was interested in it.  It was beat up and hadn’t ran in a few years.  No spark the guy said and he left it to sit.  I wound up taking both bikes. 
      I wish I had pics but I deleted the original post on Quadcrazy and lost the old ones on my phone when I upgraded. 
      This was the atv that caused me to stumble upon Quadcrazy since I needed a little help with the spark issue.  So needless to say I fixed it, did some cosmetic work and she was good to go. I took it upstate and used the shit out of it for just about everything under the sun. This atv made it through some deep snow, mud etc. I decided to leave it up there and use it as a back up since it’s been about 50 atv’s later and I have newer machines now. But unfortunately it sat for some time and it’s a little beat up so I brought it back home and going to clean it up. Amazing how one year sitting has done so much damage. 
      This was the first atv that I owned in over 30 years! It’s the atv that brought me here to Quadcrazy where now I endlessly check the site to see what’s going on, who’s talking about what and who can we help with there problem or can help me with mine as well as the on slot of what I do today as a hobby with atv’s. It’s been a great pass time for me and my son with the projects we have gotten and get into. He’s learned how to ride so well it scares me a little watching him. He’s learned how to fix, maintain and upgrade atv’s. He’s insanely good with carburetors as well. 
      It’s a good thing when a kid wants to play in the garage over his X Box!!
      The funny thing about this bike is that when we finished it we thought it was the best thing! We were missing a rack on the front and didn’t care since it looked ok, had no clue where to get parts or how to fix plastics. I was so new to this again since I was staring all over again and now had to remember things and also teach my son!  
      So we will be tearing into the bear tracker to get her up and running again as well as maybe a few new cosmetic changes and hang on to her for a while since I love this bike.  The last two pics are the bike the day we finished putting it all back together and when it was upstate for the first week. 
       
      Had no intention of this post going so long. 🤷🏻‍♂️







  • Similar Tagged Content

    • By Bruce Sawyer
      1987 YFM350FWTB 350 4x4 Big Bear when going uphill will sometimes act like the clutch realeases then re-engauge all at once.
      Seems to maybe be little more often if the engine is at about 1/2 throttle instead of at lower rpms.
      I have the Factory Service manual and checked the external clutch adjustment screw as ok and the H/L/reverse shifter lever linkage as adjusted correctly. It appears to be maybe a internal (inside the case) clutch issue or ??
      This is the type Big Bear that has the manual shift lever on the left front fender and has the manual foot shifter lever with 5 speeds forward.
      Can someone tell me how the primary and secondary clutch operates? 
      I assume one is mechanical and one is centrifugal. (what I'm asking is one clutch for the higher rpms and one for the lower rpms or ???. (the clutch appears to only momentarily release at the higher rpms is why I ask. The cycle has about 3000 miles of low speed through the brush hunting and has been well maintained, oil changed, etc and no deep water or mud useage.
      Anyone been into a similar issue with the big Bear ATV????
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By Tyler Autry
      Recently started shifting hard from neutral to first causing it to stall. I'm able to lift up on the shifter and throttle up and slowly let off the shifter, like driving a standard. That is the only way to get it In gear and stay running. Also if I come to a stop and keep it in gear it wants to continue moving, eventually stalling out. I don't have much experience with the bottom end or clutches. I just now replaced friction and steel plates and that made no difference. Don't know what to do now.
    • By Brian T. Aichinger
      I have a 2017 can am 570 outlander max that is having issues with the powersteering going out and the speedo quits working. anyone else having or heard of these issues?  everything else on the display cluster is working and I hear no noises as far as the powersteering unit, the dealer did change the steering unit because of the recall.
    • By Ulf Löfstedt
      I just bought a Yamaha Big Bear 350 from 1992. The previous owner has run it on regular engine oil and I have problems with the clutch slipping. I think that's the reason.
      So what should I do?
      - Just change oil and it will be OK?
      - Clean engine/clutch + new oil?
      - Or do I need a new clutch?

      It is guessing the centrifugal clutch that slips. It has two clutches , it also has a "regular" clutch .
      Anyone who has any experience of using wrong type of oil?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...