Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

I have a Sportsman 450 HO and almost killed my self when loading it on my truck with ramps.  It rolled off the top of the ramps and tailgate and nearly landed on me.  I now want to winch the ATV in to the truck.  My question is are the front side bed tiedowns in my 2011 RAM strong enough to winch to without distorting the hooks or sides of the bed?

Share this post


Link to post
Share on other sites


Man that's scary. Good to hear you didn't get hurt.  If the hooks are factory I would think they  are strong enough to pull the atv up especially if its in neutral and going up with the winch.  
I'll tell you this, i load plenty of atvs in the bed of my truck and still to this day get a nervy feeling when doing so.  I have a trailer but sometimes need to hop in the truck and go  when i find a good deal. Never gets old going up the ramps.  I do however strap my ramps so they don't move.   But i actually though of installing a winch in the bed of the truck so its there all the time.   

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Roy Routon
      Where can I find a fan relay for this atv.
       
    • By Dan Tressler
      I have a 2018 Sportsman 570 SP Hunters Edition. I bought the quad new in August of 2018 and put around 20 miles on it with no issues. In early January of this year the quad was acting as if it had a bad battery even though it had been plugged into a tender. I checked the battery and it tested well so I took it to the dealership for warranty service. They had it for almost a month. They determined the quad had a bad EPS unit and swapped it out. Then they told me that the wire for the EPS needed to be updated as they could not program the new unit with the old wire. After the wire came in dealership told me they were still having troubles programming. After another week and a half they told me that they had consulted several times with engineers from Polaris and found a workaround and that the quad was ready for pickup. I contacted Polaris to inquire about the warranty being extended as it was in the shop for a month. They extended the 6 month factory warranty for an additional 3 months. I picked the quad up and the dealership said that the 2018 SP editions were known to have issue a with the EPS units but believed that they had fixed mine. I had it back for around a month and took it out a couple times for short rides and everything seemed fine. I parked it again for a few days and when I went to start it same issues (acting like the battery is no good and won’t start, when I jump start no power steering). Took it back to dealership and waiting to hear what the diagnosis is this time as well as their plan to fix this permanently. Just wondering if anyone else has had issues similar to mine or can give me some advice. Thanks in advance!
    • By bren7176
      Doeas any have the actual electrical diagram for the distirbution block  for this atv > I had a few wire not worky worky so needed to replace ends plus dam thiing is dirty so needs to clean all the contacts ..
      Want to make shure I get eveything back in right place .... I have the repair manual but as we know it no help really .....
       
      Brendan
    • By Matt John
      Charging issue?
      I have a 2017 Polaris Sportsman 570 EFI. Yesterday, I start the machine and it says low power (10.6-10.8). This machine is on its second battery. This is a new AGM battery with 50cca more than stock.
      Should I look at the regulator or stator?
      Thanks!!!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...