Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
StolenATV

STOLEN ATV: 2003 Yamaha Warrior Stolen

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Ajmboy
      Disconnected the plow yesterday on my 2004 Yamaha Grizzly 660 and am getting ready to do some riding yesterday and the battery went weak, Starter cranked a few times but week. Put my trickle charger on that I bought and went to the garage today to start it up, but the starter is just spinning and not engaging. The solenoid is clicking. The pull start sucks and is hard to pull (never use it and need to look into that). Quick video of the starter spinning. Could it be the starter or  the starter clutch one-way bearing? I guess I need to take the cover off to see what's going on.

      2004 Yamaha Grizzly 660 Starter Spinning.mp4
    • By Orangejbird
      My Dad's 03 Manual Vinson has milky oil. He changed oil and ran it everyday for a week being sure to keep it running for an hour each time. Fresh oil is getting milky again..
      Thinking it's the water pump seal. Has anyone here successfully changed the seal or even replaced the whole pump assembly?
    • By Kayla Frieswick
      2001 Yamaha Wolverine new coil new solenoid switch new battery no spark
    • By Brewster
      Being confined to the farm with the corona virus pandemic, I have started working on long abandoned projects.  I have a 95 Yamaha Moto 4 350 and the CDI box went bad (I think).  Finally broke down and spent the money for a new one.  It had the same part number as the old one, but the old box as 2 extra wires on the pig tail and not all the wire colors with the new box match the old box, so I'm not sure how to hook it up.  Have searched the internet on and off for some time but can't seem to find anyone who can help.  Does anyone out there know enough that they would try to help me?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...