Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

hornythrony

2005 Suzuki Quadsport 50 Regulate Throttle

Recommended Posts

Does anyone know ways to regulate the speed etc other then the throttle screw? I have turn it almost all the way and it won't move on hills but keeps getting faster on flat gravel roads. I have a Chinese quad that's bigger but is a 3 gear so I just put it in first and let my kids go nuts cuz it might rattle it self to S... but it only goes so fast

Share this post


Link to post
Share on other sites


Topic title updated to include full ATV info and issue. 

Share this post


Link to post
Share on other sites

The thumb throttle adjustment is the only "legit" way to limit speed.  Yes, it does get faster on flat ground, up to the speed corresponding to thumb position and it may even go beyond that down hill.  I would think even if there were an adjustable rev limiter in the CDI it would still behave the same uphill and flat ground.  The only way that i see to not have it slow uphill and fast downhill would be a speedometer limited throttle like a modern vehicle so that it will only do say 15mph uphill and 15mph downhill/flat ground.

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By John conway
      My quad will start sometimes than just die well it’s running than won’t start again for a day , put in new battery same problem and it seems to drain battery any help would be great
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Trent Finnessey
      So I have a 2000 Honda 400ex, and it won’t start when it’s in gear obviously when I pull the clutch in..... it’s very annoying!! And idk if this is like a safety feature or something.....🤷‍♂️ If anyone know why this is lmk plz, thanks 
    • By raybob
      looking to buy good used carb for suz 500 quad master, I got one from china it is junk let me know if you have one and price. thanks Raybob
    • By Rock Ledge Homestead
      I bought this four-wheeler used for my son's birthday last week. It wasn't running when I got it but after a new battery and some tinkering it has been running for 5 days probably 8-10 hours of run time. 
       
      Today after 1 hour  My son wanted to wash it, I showed him how to be careful not getting water near the engine. We were careful but after we washed it and let it dry the motor starts but the transmission slips and won't really go forward.  Even if I pick the back of the four wheeler up the wheels only go forward a tiny bit. It's as if something is slipping inside.   But it worked fine right before the wash.
       
      Not sure what brand. I was told it was 90 cc's the VIN is attached.  Is it 90 or 110ccs?
      No air filter came with it. Using a some old stockings until I figure out what air filter to order.
      My son is so bummed so I want to get it back up to speed but also teach him how to work on it.
       
      20200620_184911.mp4

  • Similar Tagged Content

    • By Dean Walton
      Hi guys and thanks for taking the time to read this... 
      I've took my sons quad apart to tidy it up and replace the carb.
      Replaced carb sprayed exhaust etc.. And when I reconnect the battery I get no starter?? 
      I tried charging the battery and replacing it again to no avail.. On the battery ground wire there are two wires that seem to be pressed into the same connector. 
      I have read about a reset button under the wheel arch but can't seem to get it to work. 
       
      Here's a screenshot of the two wires that I think have been fused together circled on a diagram. 
       
      Thanks in advance. 
      Dean. 
       
       

    • By oxidized_black
      2004 Suzuki 250 LTZ QuadSport Service Manual
      View File 2004 Suzuki 250 LTZ QuadSport Service Manual
      Submitter oxidized_black Submitted 12/14/2016 Category Suzuki ATV  
    • By oxidized_black
      2004 Suzuki 250 LTZ QuadSport Service Manual
    • By Jerryd68
      Anyone have any thoughts on the early Quad Sports?  My very first ATV was a 1985 LT230S,  me and a buddy purchased them brand new in 1985, rode those little bikes till the wheels fell off,  I would like to find one to restore for nostalgic reasons and to teach my 14 yo son to ride.  Nice meeting you all!
    • By 87tecate4
      View File Suzuki QuadSport LT-Z400 2003
      Suzuki QuadSport LT-Z400  2003 Service Manual
      Submitter 87tecate4 Submitted 07/13/2018 Category Suzuki ATV  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...