Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Looking really good. The color scheme you have is awesome. That is really cool how much work you put into detail too. Damn I need a GF like you. You got a sister? LOL. My ex GF wouldnt touch her quad except to ride. And my last GF wouldnt even get on a quad unless it was on the back with me. And that gets old real fast. Plus its dangerous. She was afraid of them. So, the 10:25 piston? Was that stock or is that your new one? 10:25 isnt very high. You can go as high as 12 or maybe 12:25 and still run pump gas.

Share this post


Link to post
Share on other sites


Looking really good. The color scheme you have is awesome. That is really cool how much work you put into detail too. Damn I need a GF like you. You got a sister? LOL. My ex GF wouldnt touch her quad except to ride. And my last GF wouldnt even get on a quad unless it was on the back with me. And that gets old real fast. Plus its dangerous. She was afraid of them. So, the 10:25 piston? Was that stock or is that your new one? 10:25 isnt very high. You can go as high as 12 or maybe 12:25 and still run pump gas.

LOL no sister, just a couple brothers. The new piston is 10:25. didnt want to go too much higher cuz then i would need a stroker kit and cant afford all that right now, just wanna ride :cute:

Share this post


Link to post
Share on other sites
LOL no sister, just a couple brothers. The new piston is 10:25. didnt want to go too much higher cuz then i would need a stroker kit and cant afford all that right now, just wanna ride :cute:

I hear ya. I go nuts after a couple weeks without ridin.

Share this post


Link to post
Share on other sites

ALright guys here is a lil update on my quad. Should be all together and ready to ride by next weekend. Just got the head and cylinder back from the machine shop. They got the stuck bolts out of the head and put new ones in. They also got my cylinder bored out.My piston came in and a few misc nuts and bolts we ordered should be here monday. So now alls we have to do is paint the motor and let it cure for a week, put it in the quad and im ready. No more pictures until the final project. I CANT WAIT!!!!!!!!!!!!!!!!!! Gonna customize a few graphics as well. U all are gonna love it. Stay tuned :yes:

Share this post


Link to post
Share on other sites


You are really making good progress. I can't wait to see the finished product. It is looking really good.

Share this post


Link to post
Share on other sites

UPDATE: SOOOOOOO here is a lil update on my ongoing warrior project. We were expecting to have it ready to ride by yesturday. We got the motor painted, after putting it back together. Got the engine in the quad. Hooked up the wire harness and it componants. All of which worked fine when we took the thing apart. The drum role.......turned the key, pulled in the clutch, hit the start button.....NOTHING!!!!!!!!!! So after fiddling and such we decided we are gonna have to go through each componant electrically and see what the problem is. SOOOOO we decided that we still wanted to hear it run. We jump started it from the soleniod to the battery....the thing started up no problem, sounded great , didnt even hesitate. We shut it down and started it again without the choke...started right up. We shut it down topped off the oil, went to jump start it again.....NOTHING!!!!!! :aargh::aargh::aargh::aargh: The engine turns over but NOW WE HAVE NO SPARK!!!!!!!!!!!!!!!!!!!! What the hell??????????????????? We didnt foul the plug its brand new and looks fine. We checked the fuses and some other things, We found that the neutral switch is bad. But that shouldnt affect jump starting it. I AM SO FRUSTERATED WITH THIS THING RIGHT NOW. ALLS I WANNA DO IS RIDE.

We think it may be a bad stator. But not totally sure about it yet. Still running some tests. We do knwo that we need new relay switches as well, they are pretty beat up, so we started with one problem- electric start not workin......now we have two problems- DAMN THING HAS NO SPARK.

I will keep you all posted ..:mad::aargh::no::mad::aargh::no:

If any one has ne insite please share :frown:

Share this post


Link to post
Share on other sites
Guest

No insight...but got my fingers, legs and eyes crossed for ya!!!!!

-TD

Share this post


Link to post
Share on other sites


yeahhh me too!! i can't wait to see pics, glad it's running now...when you taking it out for a nice day long spin????

Share this post


Link to post
Share on other sites


THE QUAD IS DONE ...4 now...haha it was dark when we finished so not the best pics...we will get better ones tomorrow...

warrior_61_.jpg

warrior_63_.jpg

warrior_9_1.jpg

warrior_60_.jpg

warrior2.jpg

warrior_58_.jpg

Fabbed the indicator lights into the gas tank cover...

warrior_55_.jpg

warrior_52_.jpg

warrior_8_1.jpg

warrior_1_2.jpg

Polished them up after takin the paint off...

warrior_48_.jpg

Zac fabbed the clutch perch to remove e brake...

warrior_47_.jpg

My nerfs

warrior_43_.jpg

Share this post


Link to post
Share on other sites

warrior_39_.jpg

Polished the crappy paint off the FMF logo on the pipe....loos good now ...

warrior_35_.jpg

warrior_34_.jpg

We costumized this on the computer for my logo...had to make it a lil girly...THANKS CASEY AT TRUCK AND AUTOWARES FOR PRINTING THEM!!! :thumbsup

warrior_26_.jpg

warrior_23_.jpg

My shock resevoir pimped out ...

warrior_22_.jpg

New CDI, and new relays....

warrior_19_.jpg

Hes beautiful.....

warrior_16_.jpg

warrior_10_1.jpg

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • 2012 king Quad EPS issue

      I have a 2012 Suzuki king quad 750 with EPS I do believe the power steering is not working, I have a plow on it and have to pull very hard on the bars to move the front tires when not moving!! When Moving it is OK, have only been around a Polaris and sitting in the garage I could move the bars with my pinky finger only.  Not the case on my king quad. Fuse is Good,  EPS light comes on when started but shuts off after few seconds, I believe this is normal I have a black and a green wire coming out of bottom of the handlebars, under the headlight,  Not sure when theses are they are not hooked up to anything
      Would love any insight on where to check or what to do Next Matt

      By MFD2012KQ, in Suzuki ATV Forum

        
      • 3 replies
      • 66 views
    • 2005 Polaris Trail Blazer 250 won't start

      Hi guys, trying to get a quad running again. It was running fine but the electric start did not work. My uncle was using it and the pull start snapped. So I replaced the pull start and electric starter motor. Now it just cranks and cranks but will not start. I have spark, I have fuel to the carb, I know this is a 2 stroke with a separate oil tank, what else should i check?

      By TheJester517, in Polaris ATV Forum

      • 5 replies
      • 142 views
    • The Official Good morning thread!

      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Let's see if we can make this a daily event.

      By BuckBilly, in General Talk - Anything Goes!

        
      • 3,436 replies
      • 168,832 views
    • 2005 Suzuki King Quad 700 - Fan Replacement

      The saga of the fan continues. The Pin attempt in the fan shaft failed.  I then moved on to trying to weld the fan hub to the fan shaft.  I took it for a run the weld broke.  Now it was truly F'ed.  To recap the dealer price, they want $400 + CND for a replacement fan assembly. I searched all sorts of after market places and no one carried one.  Ebay had some used ones but they were $120 USD + Conversion rate for something as old as what I have.  I went to Amazon and eventually settled on this.   amazon link   What I found... and was amazed... was that the fan mounted to the Suzuki fan assembly bracket.  I was prepared to manufacture my own mount conversions...  It also came with "Harpoon mounts" (nylon zip tie like things that go straight through the rad.   Anyways it mounted to the original bracket. It fit perfectly.  Cut the electrical plug off replaced it with the Suzuki... all good.  Let the quad heat up, thermo coupler kicked in the fan circuit, polarity was right... all was good....  Fan is under the circuit fuse rating.     so I finally have a solid fan solution.  $34 CND vs $400+ CND

      By LMI, in Suzuki ATV Forum

        
      • 1 reply
      • 54 views
    • 1999 Suzuki King Quad lt-F300F Hard to start

      Hello Just signed up, as I've had a recurring problem, and need some help. To start the bike I have to put the choke on all the way and 4 squeezes on the gas, Then as I push the start, I slow squeeze the throttle about half way for it to catch....If I miss it, then it will take 5 mins of slowly finding the sweetspot on the choke in unison with some throttle squeezes. Then I have to to hold the throttle to keep the bike going, using the choke will stall it out. after about 3 mins of holding the throttle, I then can let it go, and it idles fine, and runs fine. If it sits for a few hours it's only slightly hard to start, but a few days of sitting, and it's a lot more work. Had the bike serviced they couldn't figure it out. They swapped peticock, plug, new gas, all new lines, new throttle, and cable. Said the carb was fine, and clean. New air filter, said fuel pump was fine, no leaks around carb boots, new battery, new rectifier. Ran some sea foam through it....Runs Great.....Just such a pain to start... Thanks

      By RichUncleSkeleton, in Suzuki ATV Forum

        
      • 4 replies
      • 1,821 views
  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By skgw1
      Feul pump went out. Replaced. At times quad cuts out like its not getting gas. Saw article on new pump needs to be calibrated. Told how to go into a service mode. Does not tell how to calibrate after going into mode. Can anyone shed light on this procedure.
    • By katasha2
      I took apart the carburator to clean out and I can't remember exactly where the springs that are inside the float are supposed to go I've tried to look up schematics but I think I am missing a spring maybe need helpt:confused::confused:
    • By superdude811
      Can you put tracks on manual atvs? would it be effective? is 280cc enough to even move them? thoughts/suggestions?
    • By Bwdeaton
      I recently picked up a king quad 700 that doesn't run in the hopes of getting it running by spring. It had been previously taken apart some and a few pieces are missing in the engine, but the frame is complete and in good condition. The motor will need a piston, rings, cylinder, cams, and a few misc parts that are missing. Also the cases will need to be split to remove the pieces of piston that are in the crankcase. The piston blew up at high rpm and did a number on the cylinder so I'm trying to find out if it would be worth rebuilding this motor it buying another engine to swap in. There may be more damage to this engine that I can see so I was wondering how bad the insides of it could be considering it destroyed the piston. I have found a motor for 1200 plus 200 shipping, the only problem is I don't have that much now and I would have to save up a while before being able to afford it. Any suggestions appreciated.
  • Recently Browsing   0 members

    No registered users viewing this page.


×