Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Need help electrical problems


Recommended Posts





Check to see if there  is power  getting to the input side of the solenoid  and  out when  you  press the starter. If there is both power to  the solenoid and to  its output then  the problem  is  between the output  and the starter.  If  no  power on the output  then  it  is between the battery  and  input. If you  have power on solenoid  output,  check the wiring  from there to  starter.

Have  you checked to see if there is power  going to the starter when  you  press the starter?  If there  is , it  is an internal  starter problem; most likely  worn  out  brushes. 

You can get  brush  kits  if  that is the problem.  They're not too  hard to  install and are a  lot  cheaper than  buying a new starter.

Link to comment
Share on other sites



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • eManualOnline
  • Similar Topics

    • By ProblemChild
      Just got over the weekend and can't even get a sputter from it starter clutch missing the top idler so it's pull rope only. Seems to have plenty of compression and it has spark when checked with plug out 
      I've spray starting fluid directly in carburetor and while manually opening up the choke still nothing not even trying to start. Changed the plug as well. I'm going to order the starter clutch idler and anything else bad or missing but I want to at least hear it stumble or something but I tear apart. Carburetor was nasty and I'm getting cleaned up nice. I have fuel, spark, and compression. Even tried to spray in cylinder then stick the plug back in.
      With all that in mind what else can stop it from even trying
    • By DrtyGrlKristin
      Just thought I'd start a new thread for newbies to the site!
      If you're new here, tell us who you are, where you're from and what you ride!!!
      Lets get to know each other a little better shall we?
      I'm not new to the site, obviously, but...
      I'm Kristin from Denver!!! I ride a 2008 Yamaha Rhino. She's my muddy baby!!!!!! Several aftermarket parts on her. She's good to me! We try and ride every weekend. This weekend we're off to MOAB! :woot:
    • By Otter9099
      What battery type is best wet cell, agm or lithium? Who makes the most reliable battery for atv's? I need to replace a battery on my qtv. It had a wet cell lead acid. What doe you recomend for a replacement battery that is not a fortune and that is reliable?
    • By Okiechoctaw
      Just wanting to see if any one has dealt with this before. I belive its losing spark after its been shut down from running for awhile ive got to wait about an hr an it will fire back up. I'm in the process of trouble shooting now. 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...