Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Hey I'm looking at purchasing a 2006 Arctic Cat 650 H1 SE but don't know much about Arctic cats, how reliable are they and will it make a good Mudder/work horse?

 

Here is a link to the one I'm looking at

https://www.kijiji.ca/v-atv/edmonton/2006-arctic-cat-650-h1-se/1507897599?utm_source=com.atomczak.notepat&utm_medium=social&utm_campaign=socialbuttons&utm_content=app_android

 

Sent from my LM-Q910 using Tapatalk

 

 

Share this post


Link to post
Share on other sites


Normally good machines but on this listing I would be concerned about Cluster display and speedo not working

Share this post


Link to post
Share on other sites

From what I've read online it should be an easy fix the only thing that bothers me is I don't know how many miles are on it.

Sent from my LM-Q910 using Tapatalk

Share this post


Link to post
Share on other sites

Arctic Cat has been a really good workhorse historically, but they're not ideal for a mud machine.  If you want to submarine it and throw it into the bounty hole, stick with Honda 300's or at least a 420.  Arctic Cat is a great bike but there's no user community to support them as mud bikes.  They're great for trails or farm use.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By chadh
      I have had this ATV since new, and no work done on the system before. It has an intermittent issue with starting for years but getting worse. Cranks but no start or have to cycle power. No Codes. There are times it starts right up and then times it will not start at all.
      What I have done, new plug, new battery, new coil. Also, the manual I have has spec info for the H1 & H2, but when I check ohms & AC voltage & wire color, it is more in line with the H2 than H1.  
      Ok here is what I have done.
      1. new plug then new battery.
      2. checked and replaced the coil- primary was 5ohms and secondary was 20.4K ohms. Since my book said for the H1 the Primary should be less than 1ohm I replaced (new one had the same 5ohms, confused! H2 says 4.8ohms). Book says secondary should be 12k-20k ohms and it was 20K ohms. New coil did not correct the issue.
      3. Stator, AC output while running was good, about 75 volts AC no load between the three yellow wires (but mine are gray wires like the H2). Ohms were also less than 1 ohm.
      4. Crankshaft position Sensor. Again, H1 should have Blue & White but I have Blue & Green like the H2. I have 180 ohms across the Blue & Green wires, so this is good. But when cranking I have 2 volts AC. For the H1 book says 5 volts AC. But H2 says 2 volts AC.
      So, is my position sensor putting out low voltage or do I have the stator assy for an H2 in my H1 ATV from new?  Stator & position sensor are one assy. Has this ever been an issue that was noted? New Stator is $$$ so I don’t want to just shotgun a part. 
      Any help would be great!
      Thanks
      Chad
       



    • By Corky L Leazier
      One day went to start and nothing, the fan comes on cause its straight wired ,but no lights and no all the fuses show no power with the switch on. Changed starter relay nothing changed thinking maybe switch next and how can I test it.
    • By Bigobuck
      Hello,
      Wondering what other years and/or models my 2006 Polaris 330 Trail boss shares a transmission with, I need to replace mine, thanks!
    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
    • By Steve Howard
      Hey I was thinking about buying this 400 cheap The way it's smoking I think the cylinder will need bored? can this bored or re sleeved
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...