Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dwight Williams
      Ok, so I bought this scream of a deal the other day - a 94 King Quad 300 for $40.00.  It's been sitting outside with no carburetor on it for about a year.  Its rusty, missing some parts, wiring is all cut up and spliced etc.  No seat, no racks but the plastic is all there minus the headlight housing.  Anyway, who can pass up a $40.00 quad right?  I get it home and looked at the sight glass for oil level, it's about 1/2 oil and 1/2 water.  I drain it, refill it and turn the motor by hand (recoil starter is missing) and it turns over just fine.  I worked on the wiring for about an hour and got it to turn over with the electric starter and got enough of it sorted out to get a spark.  Did a quick compression test, 70 lbs.  Wet test bumped it up to 90.  Ok, so rings and cylinder washed out with water for a year, not too surprised.  I thought 'what the hell' and sprayed some starting fluid in it and it ran for about 2 seconds - enough to show  it's got life.  Since then the compression has gotten worse, I can't get enough pressure to activate the carb diaphragm, therefore no fuel pump either.  The compression is now around 60.
        Anyway, my question is....is it worth it to try to get this thing going?  I tore the top end down today and the cam and one of the rockers is pretty worn.  I figured a top end job would be about $100 or so, depending on the condition of the cylinder but I'll probably have to put a cam and rockers in it as well.  Doing some research on ebay I figure I'll have to spend about $500-$700 to make the whole machine right again.  Much less just to make it run and use as-is but I won't really like it until it's right.  I don't mind doing the work, I actually enjoy it but I'm concerned about what all that water did to the rest of the internals, I can't really test it all out until I can make it run.
      I know it's a basket case but I'm not into it much at all, even if I do the top end and find something else wrong I'm still not out much.  I'm leaning toward ordering the top end parts and going from there unless you can convince me otherwise - any way to check the rest of the internals without tearing it down?  I plan on flushing the oil cooler before I do another oil change, I've drained it twice now and it gets milky almost immediately just turning the starter - I suspect the oil cooler is polluted badly.
       
      I'll get some pictures today if anyone want to see them.
       
      thanks!
    • By StolenATV
      On Wednesday, September 18, our ATV was stolen from in front of our house after the locks were cut. This was around 2-3:15 AM.
      We realize the likelihood of ever finding the four-wheeler again is slim to none, but we had to try and put the word out there. We have put countless hours in to restoring this Banshee. It was more than just a passion project, it also was our investment for a down payment for our future house. We are devastated and beyond heart-broken. If you see any suspicious postings on Facebook Marketplace, Letgo, Craigslist, etc., or have any other information, please contact us or the Prince William County PD.
      *Update* We received a tip last night that it was possibly posted on Facebook Marketplace around 8AM yesterday morning with only pictures of the front and of the back of the ATV. The description only said: PM for more details. This came up in someone’s FB Marketplace feed that has it set for a 50 mile radius from Hartwood, VA. She also has her feed set to automatically translate everything into Spanish, so It could also possibly be posted in Spanish.
      WHAT WAS STOLEN:
      2004 Yamaha Banshee YFZ 350
      White plastics with bright green and pink graphics/stickers
      STOLEN FROM:
      Prince William County, Triangle, Virginia
      $500 REWARD FOR INFORMATION LEADING TO RECOVERY. BONUS FOR CONVICTION.
      The post Stolen From Our Front Porch – 2004 Yamaha Banshee YFZ 350 appeared first on STOLEN 911.
      View the full article
    • By Mudrecon
      with the right growing environment my 95 KingQuad blossomed into this fine looking 2010 KingQuad 500 AXI. (really!) Patience pays off. Now to grow a set of tracks ;)
       


    • By Anthony Sherman
      Looking to buy a banshee this Saturday. Guy has a sweet deal on one 3 hours from me. Bike sounds a bit rough to me but I’m not a 2 stroke or atv guy. This will be my first 2 stroke Any help would be much appreciated. I attached a video of the bike running. Please let me know if this a good deal at 3k. 
      B8207E87-DE09-4932-8176-23214F9FC3EF.mov
    • By David Cameron
      The small waterline insert for the hose that goes from the water pump cover to the thermostat housing has corroded off. I only need the insert on top and behind the thermostat housing that the hose goes over and can't find just the insert. It looks like it may be pressed in. I've have been told the entire motor housing needs to be replaced. The pic with the red line indicates where the hose and insert would be and the insert looks like the pic of the water pump  Any ideas would be really appreciated.
       
       



  • Similar Tagged Content

    • By quadmaniac
      Does anyone own or has owned a Yamaha Banshee ATV? I saw a few posted for sale and decided to start a thread and would like to hear the good, the bad, the ugly...
      There are some nice modded ones I've seen online (pictures below). Post a pic if you own one. 
       





    • By cherpe
      I have 2002 450 foreman & the temp lite started to come on as I was riding; It would be intermittent at times. Changed the temp sensor, but lite still is intermittently on & off. Installed a switch for the fan so I could manually turn fan on & off as needed. The lite is still coming on & staying on . Any ideas on what else I could try? Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...