Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Naterenfo

Helloooo FROM MINNESOTA! =D

Recommended Posts

Hey peeps!:wink:

My Name is Nate, im a pretty new rider from suburbia MN. I have been obsessed with ATVs since before I was born, and finnaly got my very first one. Its a used Suzuki Twinpeaks 700 4x4 came with 800 miles on it, I Have only had the chance to ride it for like 3 days, but I threw on a good 150 miles.:biggrin: I would love to learn more about the mechanical parts of fourwheelers, and how to repair/modify them. So if I ask a really dumb question, I Apologize in advance ;]. I read dirtwheels magazine, and am a big fan and I think thats pretty much all i have to say! Thanks for creating such an amazing site!

~Nate

Share this post


Link to post
Share on other sites


Hey peeps!:wink:

So if I ask a really dumb question, I Apologize in advance ;]. I read dirtwheels magazine, and am a big fan and I think thats pretty much all i have to say! Thanks for creating such an amazing site!

Welcome aboard Nate! There's no dumb questions...we're all here to help each other and share the one thing in common...ATVs! What year is that Twin Peaks? A 700 is a big first quad! Kudos to you for starting on that one.. I started with a Bayou 220, then Kawasaki 450, then King Quad 700...:biggrin:

Got any pics of the machine?

Share this post


Link to post
Share on other sites

Welcome to the site. Please ask anything you are curious about. Someone will get you some info. Congrats on the new ride.

Share this post


Link to post
Share on other sites

hey thanks everyone! the twin peaks is a 2004, it has a few extras that we got when we purchased it

it has:

Moose hand guards (sooo handyyy! if you don't have hand guards, i recommend them)

Moose ignition system

Warn 2500lb front winch

aluminum skid plates

ITP C-series wheels

MUDLITE tires

im also considering buying a lift kit for the atv, im having a lil trouble finding one though.

anyhow, heres a few pics

l_f650c9af2679b6229514d18c440f39b2.jpg

l_b5170129d0e183fc28331cd9f4bc6e99.jpg

those are the only two that I have with me ATM, but i will be sure to get more this fourth of july week! im going to my cabin to finish repairing the ATV, and to start riding again!

Share this post


Link to post
Share on other sites


Welcome to the site. Glad you made it here. I have family in Minnesota, St. Paul area.

Share this post


Link to post
Share on other sites

WELCOME!

Glad to see another 4x4 owner on here. If you have any utility-quad related questions, feel free to ask me! I'd be glad to help, or at least to steer you in the right direction.

Share this post


Link to post
Share on other sites

:laugh:Welcome Nate, those are great pictures. I hope to ride in the snow someday. Good job on your first quad. That is a mean looking machine.

Share this post


Link to post
Share on other sites


hey thanks everyone! the twin peaks is a 2004, it has a few extras that we got when we purchased it

it has:

Moose hand guards (sooo handyyy! if you don't have hand guards, i recommend them)

Moose ignition system

Warn 2500lb front winch

aluminum skid plates

ITP C-series wheels

MUDLITE tires

im also considering buying a lift kit for the atv, im having a lil trouble finding one though.

anyhow, heres a few pics

l_f650c9af2679b6229514d18c440f39b2.jpg

l_b5170129d0e183fc28331cd9f4bc6e99.jpg

those are the only two that I have with me ATM, but i will be sure to get more this fourth of july week! im going to my cabin to finish repairing the ATV, and to start riding again!

LOL, SNOW NUTS ARE FUN:yes::rolleyes:

Share this post


Link to post
Share on other sites

hey everyone, thanks again for the warm welcomes =] just got back from my cabin, sorry its been so long. i put over 800 miles in this past two weeks, it was fun as hell. we fixed the rear end on the ATV and it was just amazing... ill put pics up sometime soon!

UTILITY ATVS RULE.

Share this post


Link to post
Share on other sites
hey everyone, thanks again for the warm welcomes =] just got back from my cabin, sorry its been so long. i put over 800 miles in this past two weeks, it was fun as hell. we fixed the rear end on the ATV and it was just amazing... ill put pics up sometime soon!

UTILITY ATVS RULE.

Welcome back, sounds like you had a blast. Can't wait to see some pics.

Share this post


Link to post
Share on other sites


150 Miles Sounds Fun!!1

ya too bad there is no where to really ride in western mass, plus western mass has no quad people!!!!

Share this post


Link to post
Share on other sites
ya too bad there is no where to really ride in western mass, plus western mass has no quad people!!!![/QUO

here in indiana theres BADLANDS and HASPIN ACRES theres 2 good riding places by me:yes:

Share this post


Link to post
Share on other sites
ya too bad there is no where to really ride in western mass, plus western mass has no quad people!!!![/QUO

here in indiana theres BADLANDS and HASPIN ACRES theres 2 good riding places by me:yes:

for me its my back yard and the trails in the woods behind my yard and then im pending on riding some powerline trails

Share this post


Link to post
Share on other sites


for me its my back yard and the trails in the woods behind my yard and then im pending on riding some powerline trails

POWER LINE TRAILS?????????:huh:

Share this post


Link to post
Share on other sites

that sounds a little shocking pal:laugh::laugh:

good one!:laugh::laugh::laugh: but i still need to talk to the guy before i ride there

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Mike Johnson
      Hello again guys ,. I have a Quadmaster that has a very bad lean to my passenger side wheel. I replaced the a arm bushings with no change in the lean,  I see no bent parts and no adjustments available. It's always been there since I got it but became really noticeable when I put the lift kit on it. I'm going to add a picture of the problem if allowed.

    • By StolenATV
      Trailer loaded with four wheelers attached to truck in front of our house, . They pulled receiver out spun it around and left.. Came home no trailer or 4 wheelers.
      The post 2 ATVs and trailer stolen appeared first on STOLEN 911.
      View the full article
    • By jake Stillman
      Hello I am new to this forum and lt80s I have an 87 that has burned up 3 coil/cdi combos my question is can I out the newer set up on it and if so how do I do it I know they have different number of wires going to the cdi mine only has 2 please help
    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...