Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

ddogg

400 cc roketa 4X4 carb problems

Recommended Posts

I have a 400 cc roketa 4X4 that the cvk carb runs gas out the aircleaner . I have reset the float and put a new carb on but it still overflows. It has an electronic plunger on the top of the carb that I don't know anything about so if anyone has had this problem or knows how to repair it ???????

Share this post


Link to post
Share on other sites


the carb has no choke, just a enricher pump lever and the overflow starts after just a couple of minutes of running.

Share this post


Link to post
Share on other sites

The float is empty and I can see no holes and like I said I put a new carb on the machine and it still does the same thing. There is a electric plunger of some type on the top of the carb that is new to me.

Share this post


Link to post
Share on other sites


Does that machine have an electric fuel pump?If it does there might be an issue with the bypass/regulator;causing it to overfill the fuel bowl.That would also explain why it's still doing it after the new carb was installed...Have you checked all the carb vent hoses for blockage?That could also be a cause(I think)

Share this post


Link to post
Share on other sites

no fuel pump--gravity feed straight from the tank. I have played with carb for a long time but I don't know anything about the electronic needle on the top. I will try running with plunger unpluged and see what it does.

Share this post


Link to post
Share on other sites

I sent it to an independant shop, thinking maybe valve problems but they look good so I don't have a clue yet...will post when I get it fixed.

Share this post


Link to post
Share on other sites


i have the answer!!!

DONT BUY CHEAP CHINESE QUADS!!!!!!!!!!

i have one and all it does is break:aargh::aargh::aargh:

Share this post


Link to post
Share on other sites
wats wrong with the carb i can prob tell u ghow to fix it :)

1st post Pg 1:wink:

I have a 400 cc roketa 4X4 that the cvk carb runs gas out the aircleaner . I have reset the float and put a new carb on but it still overflows. It has an electronic plunger on the top of the carb that I don't know anything about so if anyone has had this problem or knows how to repair it ???????

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By MarkinAR
      What is the opinion on carb kits? What's one of the better brands of aftermarket? OEM is always preferred but not practical, chinese cheapie is never a good option. 
      Thoughts ?
    • By raybob
      replacing carb,, the bigger line on right side top of carb does it just vent to the air,, cant find where to hook it up to also I want to check the oil and gear oil I checked the oil in motor and the rear end my question is looks like allen plug on left side of motor if you are setting on the 4 wheller, ps it hs a oli leak any help would be great. Ray in kentucky
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By dbconn55
      Hi guys I have a 2003 Arctic 250 4X4 it starts idles and runs great for about 10 min. then it spits and sputters and dies but it starts right up like nothing happened idles good till you give gas and it does it again let off the gas and it's idling great again this goes on for about 15 to 20 min. and then it takes off runs good all day like nothing was wrong.
      I cleaned the carburetor it looked like a new one inside found a little gunk in one orifice, new air filter no crimped lines air line to tank good I did put a meter on the battery idling it said 16.5 V that's high I think would a voltage regulator cause this?
      Suzuki shop wanted to sale me a stator for $556.00 but said it could be something else also thought I'd see what you guys say about it
      Thanks
    • By raybob
      I have it all but can find where the vacuum line on the carb goes its a 2000 suzuki 500 quadmaster I know where the two vent lines go but not the bigger vacuum line goes it has vacuum on this line. need help. Ray
       
  • Similar Tagged Content

    • By Wali
      I was riding my 400ex one day and when i shut it off to put it in the garage i tried to start it put again to drive it into the garge and it wouldnt start.I put a compression tester on it and its like 30 psi with out throttle and 0 psi WITH THROTTLE.
      when i put my finger over the hole it fell likes its pulling my finger in more then its pushing it out 
       
      Has good spark.When i took it into the shop the said it had 1oz of oil in it and a tiny pit of metal shaving(TINY BIT LIKE 30 flakes)
      When i try to pull start (push start/roll start) it made a not normal sound  and wouldnt stay running.
      If my bottom end is blow why would it still turn over fine,
      Are my valves siezed or not working properly 
      or is my timing off causeing valves to not open in correct order with fire 
      PLEASE HELP all help is appreciated 
    • By Hunter Aldridge
      Some times I get spark some times not can ride then it just dies and wont get spark it has new cdi box and stator but I don't know if it has the pickup coil I'm at a loss
    • By William Sims
      I have a 400 4by4 ,2005 green model,
      wounding how many different CDI boxes will work on it
       
    • By jerry houston
      Eiger 400 Suzuki runs fine Cook-Out joke face off the handlebars put it back on and will not start now will crank no no spark
    • By colin james
      View File 2012-2014 Polaris Sportsman 400 HD Service Manual
      This the factory service manual for the 2012- 2014 sportsman 400 hd service manual 
      Submitter colin james Submitted 02/08/2019 Category Polaris ATV  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...