Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

TheJaspMan

Sponsor Me! A New Editorial at ATV Exposed Magazine

Recommended Posts

It's that time of year again, everyone is seeking new sponsors. But have you ever really sat down and thought about the basics? Well Jorge Cuartas took the time to put together a quick article on this issue.

Check it out!

aemlogo400.jpg

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Squirrel
      Several months ago, I finally got around to fixing the bayou. Rebuilt the carb, replaced the fuel selector switch, hoses and fuel filter, and she ran great. Only had 2 minor issues since then where, at higher speeds, it acted like it was choking out when I let off the throttle.
      Lately I've noticed if I let it go for more than a week, it almost drains the battery dead trying to start. I initially thought battery, but after inspecting I found very little if not any fuel flow through the line until it starts and runs.
      I'm a little baffled and don't have much time to mess with it as most my free time right now is spent on getting my rv up and ready for hunting season in the next 3 weeks. So any help on quick diagnosis checks would be helpful. Otherwise I'll just keep starting it every 3-4 days to keep things primed until I'm done hunting.
       
      Oh, and another question on a different topic. Does anybody know what the mounting brackets on the front rack are for? I'm referring to the 2 angled metal tabs with threaded holes that are located on the left, near your knee when sitting on the quad?
       
      Sent from my SM-G950U using Tapatalk
       
       
    • By northern
      Just picked this up at a yard sale, runs and drives..color coded wires for battery were backwards, Meaning a red wire was used for negative and a black for positive....
       
      Upon bringing it home decided to boost the battery and walked away giving it a small charge prior to starting it..came back to find battery slightly smoking and my Green light for power (neutral) was no longer lit up...Still starts when i pull start it with key on.
      Turn key on and no starter spin up, no lights
      Id like to get my Electric start working, What could be the problem, Where does one start.
    • By Tahj
      I am looking to see why my 2005 Grizzly  660 won't crank. I have set the valves but suspect a loose timing chain.
      When working to remove the valve cover I found a "cap tensioner case" - parts #25  - #299 on Babbitts site.
      The  cover seems to bridge the valve cover and the cylinder head. What the hell is it and what surprises will I  find if I remove it?
      Uncharted territory for me.
    • By Romain Catinaud
      Salut! J'ai acheté un quad 450 wolverine de 2006 mais je ne trouve pas le circuit coupé au guidon n'existe pas sur 2006? Merci les gars
    • By Tahj
      I bought a "project" Grizzly 660, I think it has been a few people's project. The PO had it for a while and did not have time to work on it. He said the battery was good, but I don't know how he knew because the display was blank, no lights and won't crank or run. 
      I found a nest under the front cover, by the CVT inlet, a chewed thru wire and a few more without insulation. Rewired those from the connector (black 3 wire to the display) and replaced the fuse as suggested by a search from this site. That got the display working and power to other circuits. 
      I replaced the aftermarket start switch with a used OEM switch from eBay. Then it would crank a little, and started once for a few seconds. 
      I'm a small engine mechanic - mowers, snow blowers, etc. In my small engine work I have had a number of rider mowers that would crank about a half turn and then stop. The owners have suspected a bad battery and changed it with no improvement. Setting the valves to spec usually fixed this.

      I set the valves on the Grizzly without solving the crank problem. I wonder if the timing chain could be off - slipped a tooth. 
      I don't know any way to check for this without pulling the head and looking at the timing marks on the cam gear. 
      Is there another way to check for proper timing?
       
  • Similar Tagged Content

    • By Arizona
      Went shopping on Saturday, picked up another Kawasaki Bayou 220 and a Yamaha Timber Wolf 250
      I really should sell some of these but they are a lot of fun to find, fix and ride
      Of course neither of them run but that's part of the fun!  Az



    • By oxidized_black
      these are what i have in my collection ... always looking for more
      Linhai (german)
      http://rapidshare.com/files/3880403675/Linhai%20(german).rar
      Linhai 250 - 360 Service Manual
      http://rapidshare.com/files/582921063/Linhai%20250%20-%20360%20Service%20Manual.pdf
      Linhai 260 - 300 Parts Manual
      http://rapidshare.com/files/1587211864/Linhai%20260%20-%20300%20Parts%20Manual.pdf
      Linhai 260 - 300 Service Manual
      http://rapidshare.com/files/3400427719/Linhai%20260%20-%20300%20Service%20Manual.pdf
      Linhai 300 Parts Manual
      http://rapidshare.com/files/1938660329/Linhai%20300%20Parts%20Manual.pdf
      Linhai 260 Service Manual
      http://rapidshare.com/files/218261873/Linhai%20ATV%20Service%20Manual.pdf
      Linhai Bighorn CUV Service Manual
      http://rapidshare.com/files/2459140573/Linhai%20Bighorn%20CUV%20Service%20Manual.pdf
    • By Zacharia Maisonneuve
      i have a 1993 timberwolf yamaha and the compression is good and lights work but for some reason the electricity is not going to the spark plug(s)! i got a friend to check it out and they said its no use but im not giving up! please help with this!
    • By Connor Tuftin
      I have a 1988 300 Honda FourTrax, All wheel drive.
      My brother and I were fixing up this quad. We put a brand new battery and fuses in and it was running fine until we put the quad into reverse. As soon as it was put into reverse all of the electrical cut out and power wasn't making it to the head unit anymore and both of the brand new fuses popped. We figured there might have been a short from the starter or solenoids, but they are all working properly. At this point we don't know where to start looking for where the short could be. I'm just wondering if anybody has had the same issue or knows of similar issues that could cause these electrical shorts?
    • By Resurgence Small Engine Inc.
      Not satisfied with the commercially available versions, Jonathan recently built an ATV spring compressor.
      In this video, he demonstrates using it to remove & re-install the spring on an ATV coil-over shock absorber.
      Mistake in video - the coil-over shock is not quite a McPherson strut.
      If you are inspired to build your own spring compressor, feel welcome to use any ideas from this video.
      Thanks for watching! Resurgence Small Engine Inc.
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...