Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

who all here are going to run the wpsa series and what classes.

I will be running the whole circuit in the 250 B class

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By lanow
      Hi Everyone,
      I am new to this forum and hope that someone out there can help me, I have an early Suzuki King Quad 300 (280cc) which starts intstantly every time but at about half revs or there abouts it starts spluttering and will not rev any higher, this fault is present whether choke is applied or not, some one suggested that silencer maybe be clogged so removed baffle but no improvement have removed carb and stripped 3 times but still no joy.
      Any ideas would be most welcome.
      Cheers Rob
    • By ATVNetwork
      When it comes to adding more power to your ATV, the first thing that usually comes to mind is bolting on a slip-on exhaust. However, that usually means you are also bolting on a lot more noise. HMF do...
      More...
    • By w_r_e
      Just picked an '03 Bayou 300 2WD.  It runs ok, needs a little help though. Maybe someone can answer some questions for me.
      1. The choke "off" position is the lever all the way right, correct?
      2. The choke seems mechanically... funky. It has a little valve clamp around the rubber boot where it goes into the carb, seems kind of janky, I don't think there's typically a valve clamp on that part? The engine seems like its running really rich, smoking a bit, so I wonder if I can just completely remove the choke cable to see if that's part of the issue? But I don't fully understand the choke needle setup. Is "choked" when the needle is being pushed in, or pulled out? Like it I chopped the cable just outside the rubber boot by the carb, would I be permanently choking it or permanently unchoking it.
      3. I've read that I can tweak the air/fuel screw and maybe fix the rich mix. Where is that even located, and if it's behind a cap that I have to drill out... where is that?
      Thanks for any tips
    • By Shook
      Hi I have a 2000 big bear 400 and i just put a new carburetor on it and it idles fine but when you try to accelerate it sounds like it is going to die, so when it sounds like it is going to die I will give it more throttle then it will go just fine.
    • By Lank Firdmont
      I have seen other posts and I'm not ableto download resources.
      I was gifted a Yamaha TerraPro and can find 0 online for help getting this running.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...