Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

utvboard

Jagged X bring home another first place at the Henderson Fabtech Desert Classic

Recommended Posts

The Henderson Fabtech Desert Classic was held December 6, 2008.

First place in the UTV class went to Jagged X in their Polaris RZR.

PolarisRZR-BITD-1-787119.jpg

Third place went to Mike Lasher in his Pro Armor Kawasaki Teryx.

ProArmorTeryx-1-704122.jpg

The race consisted of three laps around a 46 mile loop.

More...

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ryann Racho
      So Id say about 2 years back I bought a 2013 Polaris Sportsman 500 H.O. off of my uncle. It ran perfectly, nothing wrong at all. I usually go mudding with it or just ride trails with buddies. So as you would assume, the quad is quite dirty from sitting for a few weeks.
       
      STUTTERING PROBLEM: I noticed one day out of nowhere that in high gear at 15-20 MPH, I was already maxed out at 4500-5000 RPM  It would get to 15-20 mph, max out on rpms and start sputtering. It sounded like it was basically acting like it couldn’t go any faster than this.
       
      IDLING PROBLEM: I was fucking with the carberator the other day maybe thinking that is causing my sputtering, and now my idle will shoot up to 2600 on start usually, then I will turn the throttle adjustment down to the normal 1400. The rpms with then fluctuate 10-30 rpms back and forth repeatedly, it will then run for about another 30-60 seconds and the RPMs will slowly drop to about 900-1000 RPM and stall out. I replaced the carburetor and everything seems to be working perfect on that, no leaks and what not but it’s still acting strange. Also, I’ve noticed that when looking into the Electronic Throttle Control that two plates that aren’t supposed to touch have to be WAY past touching to even try to fire up. Even when set at a wide open throttle like that, I still have to give it some throttle to get it to fire up.
       
      Here is what I have done so far: 
      Checked the belt and clutch
      Changed out spark plug (Last one was covered in carbon)
      Cleaned the intake and air box
      Replaced the carburetor
      Replaced the inline fuel filter
      Checked that all lines on carburetor are connected into the right spots
      Checked If intake boot was cracked (Not from what I can see)
      Unhooked and reattached new carburetor (About 4-5 times)
      Cleaned battery terminals and battery off
      Shut on and off Gas Line Cutoff Valve
       
       
       
      My next thoughts are that maybe the TPS is fucked up or maybe the Spark Arrestor is plugged with mud. I was thinking tomorrow to purge the exhaust and also check the ohms output on the TPS.
       
      ANY HELP IS GREATLY APPRECIATED. I HAVE BEEN BATTLING THIS FOR WEEK AND REALLY WANT TO GO RIDING. THANK YOU!
    • By stinky
      I have an Outlaw 110 that will struggle to turn the engine over. Jump starting doesn't help other than the battery will drain LONG before the bike eventually starts, so is required. If you keep messing with it long enough it will eventually magically begin to crank fine and sometimes finally start. Once we finally get the bike to start and warm it up thoroughly, it will turn over and start just fine the rest of the day like nothing ever happened... next day it won't turn over again.  Internet research has found lots of people saying they replaced starters, starter clutch, wiring, etc. but with only about 50/50 success rate for their particular problems... and I never found anybody describing a problem like mine, so I'm looking for advice/experience. Would rather not just start blindly throwing parts at it. Does anybody have any thoughts/ideas?
    • By 79davecampbell
      just bought a 2000 polaris 325. was told i vould pull start and ride but needed new battery for electric start. so bought new bat and charged it but nothing. while spraying with a hose after a ride it all came on. neutral light cooling fan and then quit. checked those things in the black bag and power at both ends. starter will roll when i jump solenoid. power to the ignition switch jumped that but still nothing. maybe switch for headlight and starter? NEED HELP PLEASE. 
    • By mike costa
      Motor starts right up, but when I open it up past quarter throttle it bogs way down while ridding, the longer it runs the worse it gets. If I just leave it in neutral and  give it full throttle it revs up and down. 
      Back history:
      Bike sat for 3 years,
      Installed new plug, cleaned the fuel tank, took it to a shop and had the carburetor gone though.
      Picked up from shop, motor bogged down first day and barely got me back to the truck an 1 mph.
      Took back to shop after a month I was told it had a bad plug, I told him I just replaced it.
      Got quad home and it is doing the same thing!!!!!!!!! 
       
      Thanks in advance for your support!
       
      The carburetor has recently been gone through by a shop
    • By gpenberthy
      My ranger crew 700 is hard to shift and gets locked into forward. When trying to shift into reverse we have to shut engine off. Shift then restart. Checked linkage and gears are fine. The RPMs arent really that high but did notice a little improvement when we lowered it. Did notice the throttle cable looks damaged. Could this be the issue? 
       
  • Similar Tagged Content

    • By Malaysiaflower
      Mother’s Day is a special day not only for mothers throughout the world but even their offspring since it provides them with the opportunity to express their love for the special lady in their lives. Every kid wants to make it a day to remember for the woman who gave birth to them and raised them with so much love and care. It is all for a worthy and memorable occasion. Make your mother feel special on this day every year. Send Mother's Day Flowers to Malaysia and show your warm love and affection http://www.flowerstomalaysia24x7.com/Mothers-Day-Malaysia.asp
    • By johnnoko98
      For Sale New ATV's Polaris and Can-Am For Sale
      !!! Interested buyer should mail us direct for inquiry !!!
      Email: [email protected] OR [email protected]
      Skype: john.anders01
      2015 Polaris RZR 1000 EPS Desert Edition
      2015 Polaris RZR xp 1000 EPS Highlifter
      2014 Polaris RZR xp 1000 EPS 4x4 Side By Side
      2014 Polaris 850 XP Sportsman
      2014 Can-Am Maverick 1000r X mr DPS
      2014 Can-Am Outlander MAX 800R EFI LTD
      !!! Interested buyer should mail us direct for inquiry !!!
      Email: [email protected] OR [email protected]
      Skype: john.anders01


    • By thuds4evr
      Has any one seen or made or have an idea for an unusual accessorie , a radio mount or a gun mount other the the regular market stuff. Have you come up with any idea that you would care to share ?
      Example: a local surveyor here mtd an old antenna on the front of his front carrier rack. It keeps the spider webs out of his face.
      Another guy rigged up a light on a swivel that the base of screws into the rear view mirror mount on the left handle bar. He uses the light for things like fence repair at night or when he need a lite held on something around the farm.
      Anybody want to share any other ideas ?
      Or are you like me, I want a car radio or a scanner that will run off an Aux battery mtd some where on the ATV and charged when the ATV is running. Do not want to run it off the main battery. (ATV to heavy to push)
    • By pmnova
      My sons 2005 Brute Force 705i needs a new belt and im looking for recommendations for good places to buy a cvt belt from also is there any special tols needed?
    • By Huntingman2706217
      Ive got 3... ive owned 19 XJ's 4 MJ's 1 ZJ and 1 WK2 in my life... all those within the last two years except for the ZJ...
      I just got the WK2 in Dec... its a Overland edition... all the goodies but didnt get 4x4... didnt ever see going offroad in a $50k vehicle when i got a rock crawler and a 4x4 DD... lol...
      96 Cherokees on 2006 F250 axles... 5.38 gears... saving for full hydro steering... caged... 4.5in lift with SYE... 40in gumbo mudders... H1 two piece steel wheels recentered to 8x170 and rock rings...
      my 90 comanche i blew the rear main seal in last month so i have the motor out and did a head gasket and every other little gasket while its out... pressure washed and painted... new clutch, floor pan, oil pan... all kinds of stuff... painted the engine bay and pull the harness that im going to go through and recover everything and fix anything wrong... also sealing it all up water right... doing a external slave bellhousing swap on it as well... tons of time and money... oh and a 97+ cherokee front end conversion... its just my DD and im restoring it like new basically... itll get painted probly next year...
      ill try and get some pics up... i moderate over at cherokeeforum.com as huntingman2706217 so if anyone else drives cherokees we got a lot of info and tips!









  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...