Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

quadcrazy

February 2009 ATV Photo Contest!

Recommended Posts

February 2009 ATV Photo Contest

Theme: "Best Dressed Rider" with your ATV, 3 wheeler, or UTV.

Prize: ATV Illustrated Magazine Subscription & QUADCRAZY Embroidered Hat

*Magazine subscriptions can only be sent to US and Canadian residents.

atvillustrated.logo.png

Rules: Submit your "Best Dressed Rider" with your ATV, 3 wheeler, or UTV photo by entering it with a post, into this thread. (If you are not familiar with how to do this, visit the Learning Center) One photo per member allowed, so make sure it's a winner. You may submit photos that have not won past contests. Photos can be of yourself or taken by you. You may not submit photos that you do not have ownership of or permission to use. Any violation of these terms will result in disqualification.

NOTE: You MUST have a minimum post count of 10 to enter into the contest! We would like to see participation in our forums from all members who enter the contest.

Last day to enter a photo is February 24th.

Voting will take place for the last 4 days of February to determine the winner.

Voting will end February 28th and the winner will be announced!

View Past Contest Winners

Good Luck!

Share this post


Link to post
Share on other sites




THIS IS NOT A ENTRY. Anyway, i'm posting it so u all can see.

sirdal_1211021622.jpg

Source of picture Dagbladet newspaper

I don't know who this is. it's a picture i took at Bonanza outside Buena Vista Colorado @ fall color tour 2008

THIS IS MY ENTRY

dog1.jpg

Just to prove

dog2.jpg

Edited by Shortcut
posting more pictures

Share this post


Link to post
Share on other sites


This is the image in my sig - It was freezing this day....my wife an I....

Full body suits, ski jackets, gloves, boots, and helmets with plug in defrosters.

684.jpg

Share this post


Link to post
Share on other sites
Riding up at Camuesa....Cam on self timer, turned out pretty good, I'd say.

l_b2e88b45089362214c92ffb59b2e98b7.jpg

Goodness Joe!!!! I had almost forgotten how Freakin Ugly you are!!!!! Thanks for the Update on that!!!! LMFAO!!!!! Thats a pretty Cool pic Brotha!!!!

Share this post


Link to post
Share on other sites

My wife got me this jersey. I know she loves me cuz she pays enough attention to my quad to have matched this shirt with it perfectly.

4595.jpg

Edited by Stoopidbot1

Share this post


Link to post
Share on other sites


oh man if she got a green shirt i'd laugh, i remember my brother went riding with us for the first time and bought a lime green shirt hahaha all we have is red quads.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dwight Williams
      Ok, so I bought this scream of a deal the other day - a 94 King Quad 300 for $40.00.  It's been sitting outside with no carburetor on it for about a year.  Its rusty, missing some parts, wiring is all cut up and spliced etc.  No seat, no racks but the plastic is all there minus the headlight housing.  Anyway, who can pass up a $40.00 quad right?  I get it home and looked at the sight glass for oil level, it's about 1/2 oil and 1/2 water.  I drain it, refill it and turn the motor by hand (recoil starter is missing) and it turns over just fine.  I worked on the wiring for about an hour and got it to turn over with the electric starter and got enough of it sorted out to get a spark.  Did a quick compression test, 70 lbs.  Wet test bumped it up to 90.  Ok, so rings and cylinder washed out with water for a year, not too surprised.  I thought 'what the hell' and sprayed some starting fluid in it and it ran for about 2 seconds - enough to show  it's got life.  Since then the compression has gotten worse, I can't get enough pressure to activate the carb diaphragm, therefore no fuel pump either.  The compression is now around 60.
        Anyway, my question is....is it worth it to try to get this thing going?  I tore the top end down today and the cam and one of the rockers is pretty worn.  I figured a top end job would be about $100 or so, depending on the condition of the cylinder but I'll probably have to put a cam and rockers in it as well.  Doing some research on ebay I figure I'll have to spend about $500-$700 to make the whole machine right again.  Much less just to make it run and use as-is but I won't really like it until it's right.  I don't mind doing the work, I actually enjoy it but I'm concerned about what all that water did to the rest of the internals, I can't really test it all out until I can make it run.
      I know it's a basket case but I'm not into it much at all, even if I do the top end and find something else wrong I'm still not out much.  I'm leaning toward ordering the top end parts and going from there unless you can convince me otherwise - any way to check the rest of the internals without tearing it down?  I plan on flushing the oil cooler before I do another oil change, I've drained it twice now and it gets milky almost immediately just turning the starter - I suspect the oil cooler is polluted badly.
       
      I'll get some pictures today if anyone want to see them.
       
      thanks!
    • By John Dunn III
      Just bought a LT 230 anything I should watch for. It runs and drive good. Just don't want no surprises 
    • By Skhot K
      Hello! I picked up a YFM400 and I would love to talk shop with knowledgeable co-owners, and I'd love input about the machine from anyone here who clearly knows more than I do! Cheers from NY
    • By Mike8623
      OK guys, Ive got a 1996 suzuki king quad 300. Just where and how do you get to the CDI unit on these? Is there a way to check these if you dont have the suzuki tool or meter?
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...