Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Ajmboy

Polaris ATV Tie Rod Maintenance Check

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Tim Orr
      Installed new battery was told that’s what was wrong when hit start button I hear 1 click then nothing?  Can the battery just not have enough amps to crank the starter the first time ? I trickle charged it overnight thought it was enough!
    • By Reece Bowen
      x   just bought this expedition 425 and the Speedo needle does not work. The lights work for the shift indcator. So is this an electronic Speedo or cable? Is there a way to fix it or will I have to replace the unit? Thanks for any help you can provide.
    • By marcus23934
      I just bought a 99 sportsman 335. did some work to it got it running good my question is when I put a battery in it the atv starts and idles great once I give it gas it just spits and cuts out and will not ever clear up  thing is if I take the battery terminal off while its running it runs fine and no problem at all  could anyone help me out with what the deal is 
    • By Flipper Tiffany Roper Jones
      All I have been through everything. Bought brand new.
      Throttle safety switch 
      Cam and rockers
      ECM
      Carborator
      Stator
      Fuel safety switch 
      Battery
      Everything every forum has spoken of I've bought sealed airbox completely tight unplugged black wire on trans. I have literally done everything in the book.Checked oil today full of gas anyone no anything what might b wrong. Next I'm taking head off and making sure valves seat any ideas.
    • By Barry Troxtell
      I have a 2005 Sportsman 500, Instrument cluster will not illuminate, hi/lo beams work though.  Any tips or troubleshooting info is greatly appreciated!
  • Similar Tagged Content

    • By Sombeech
      I shot this footage last weekend. We ran a Honda Foreman along the beach and had a great time wakeboarding.
      Helmetcam footage.
      There is also a download link for the YouTube Challenged employees at work.
    • By Arizona
      Went shopping on Saturday, picked up another Kawasaki Bayou 220 and a Yamaha Timber Wolf 250
      I really should sell some of these but they are a lot of fun to find, fix and ride
      Of course neither of them run but that's part of the fun!  Az



    • By oxidized_black
      these are what i have in my collection ... always looking for more
      Linhai (german)
      http://rapidshare.com/files/3880403675/Linhai%20(german).rar
      Linhai 250 - 360 Service Manual
      http://rapidshare.com/files/582921063/Linhai%20250%20-%20360%20Service%20Manual.pdf
      Linhai 260 - 300 Parts Manual
      http://rapidshare.com/files/1587211864/Linhai%20260%20-%20300%20Parts%20Manual.pdf
      Linhai 260 - 300 Service Manual
      http://rapidshare.com/files/3400427719/Linhai%20260%20-%20300%20Service%20Manual.pdf
      Linhai 300 Parts Manual
      http://rapidshare.com/files/1938660329/Linhai%20300%20Parts%20Manual.pdf
      Linhai 260 Service Manual
      http://rapidshare.com/files/218261873/Linhai%20ATV%20Service%20Manual.pdf
      Linhai Bighorn CUV Service Manual
      http://rapidshare.com/files/2459140573/Linhai%20Bighorn%20CUV%20Service%20Manual.pdf
    • By Zacharia Maisonneuve
      i have a 1993 timberwolf yamaha and the compression is good and lights work but for some reason the electricity is not going to the spark plug(s)! i got a friend to check it out and they said its no use but im not giving up! please help with this!
    • By Connor Tuftin
      I have a 1988 300 Honda FourTrax, All wheel drive.
      My brother and I were fixing up this quad. We put a brand new battery and fuses in and it was running fine until we put the quad into reverse. As soon as it was put into reverse all of the electrical cut out and power wasn't making it to the head unit anymore and both of the brand new fuses popped. We figured there might have been a short from the starter or solenoids, but they are all working properly. At this point we don't know where to start looking for where the short could be. I'm just wondering if anybody has had the same issue or knows of similar issues that could cause these electrical shorts?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...