Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

z250grl

Later z250 Predator 500 here i come

Recommended Posts

hey everyone here is my new quad 03 predator 500..now lets see if i can learn to ride it haha

2rf96cl.jpg

Share this post


Link to post
Share on other sites


hahaha you wont even ride my z400 and now your going to try and learn this.... im going to have my hamds full with this one..

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Mo Salem
      So my front hub broke, I’d like to put aftermarket on. Hard to find new oe ones. Please help. I’m new to all of this, I have some car knowledge and try to apply it
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By lanow
      Hi Everyone,
      I am new to this forum and hope that someone out there can help me, I have an early Suzuki King Quad 300 (280cc) which starts intstantly every time but at about half revs or there abouts it starts spluttering and will not rev any higher, this fault is present whether choke is applied or not, some one suggested that silencer maybe be clogged so removed baffle but no improvement have removed carb and stripped 3 times but still no joy.
      Any ideas would be most welcome.
      Cheers Rob
    • By StolenATV
      1987 Suzuki LT 80 and 2007 Honda CRF 50 dirt bike stolen out of my driveway on July 4th. Anyone with info that recovers them will get $400 no questions asked.
      Thanks
      The post Suzuki LT 80 Quad And Honda Dirt Bike appeared first on STOLEN 911.
      View the full article
    • By Trevor B
      Hello. I got this fourwheeler to fix for my buddy. It wasnt starting at all when I got it so I opened the valve cover up and checked the timing and the timing was way off. I set the timing bolted all back together and it started. It only stays running with very little throttle applied. There is a weird noise coming from the engine and it smells like its burning and also smokes from the headers. I posted a video idk how helpful it will be but I need some advice on the next step. I want to say it's the piston and rings, but I'm not too sure was also thinking something was up with the valves. Thought I would get some advice before trying anything. Thanks!
       
       
  • Similar Tagged Content

    • By Alois Specht
      Hi there , have a KAZUMA 500 JAGUAR the rear diff is permanently locked , how can I get it out of lock just about tried everything I think, ?? .  Thank you your help is appreciated.
       
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By colin james
      View File 1996-2000 Polaris Sportsman 335/500 Service Manual
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
      Submitter colin james Submitted 10/19/2018 Category Polaris ATV  
    • By colin james
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...