Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

garyp53161

2008 Kawasaki KFX450r Battery Dies Electrical Troubles

Recommended Posts

I have a kfx450r which keeps frying batteries.

I have replaced the battery 3 times already and they will work for 2-3 hours then the next day i go to use the atv i get a FAST Ckick noise in the nose of the atv.

Seems like might be a shorted Voltage Regulator or a bad Stator..?

Is there an test I can do or does anyone have an electronic manual to trouble shoot this.?

This Quad only has like 20 hours on it max....Strangestuff

ATV has ProCircuit Exhaust, Aftermarket Computer.

Edited by garyp53161
adding info.

Share this post


Link to post
Share on other sites


When it's clicking, do you check the voltage on the battery? If you hook up a charger, will it start?

Is it a condition where the battery is discharging after 2-3 hours? If the battery will not keep a charge, check your regulator/rectifier. If the battery is frying...you will need to do some troubleshooting to see if you have wires that are shorted or a bad connections somewhere.

* Changed your thread title to include more details

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Gilbey
      Hey yo quadsters, I have a question regarding CCA in batteries. My ATV is cold natured and it will start with my generic battery that's in it, (don't ask me now what battery I have in it cuz I'm at work,) but when I hook up an external battery storage unit (Beatit 1200Amps QDSP 1200A Peak 16500mAh 12V Portable Car Lithium Jump Starter) for quick jumps it fires so much faster.  Which by the way is a bad ass accessory to have around. I keep the battery in the quad fully charged all the time. My question to the pros is how much difference does the CCA of a battery contribute to the quicker start?  
    • By jrhoads23
      I picked up a 2017 Polaris Sportsman 850. The previous owner rarely rode it and it only had 53 miles on it (10 hours). I believe the Polaris break in period is something like 250 miles / 50 hours or something like that at which point they suggest doing the first oil and fluid change. My question is should I do it sooner than that? I believe this was manufactured in fall of 2016 so that means the fluids in there are 3 years old. Maybe that isnt a big deal and it is still fine to wait until 50 hours, but just wanted to check
    • By Jay Reddick
      Hey guys, need some help with my 2016 Yamaha Kodiak 700 4x4.  Was riding and it started smoking below the air box and then Caught fire.  We got the fire put out quickly with a fire extinguisher.  Many of the wires below the air box got damaged.   I purchased a new wiring harness for the atv and replaced that as well as any other damaged cables or parts that burned up where the fire was.  I also replaced the regulator, the ECU, and the starter solenoid. I also replaced the stater since some of the cables that went to the regulator were damaged.  It acts like it will crank but it won’t turn over.   The fuel pump initialized when I turn the key so it’s working.  I’ve spend $1500 on parts and no luck yet.  Any suggestions?  
    • By Reece Bowen
      x   just bought this expedition 425 and the Speedo needle does not work. The lights work for the shift indcator. So is this an electronic Speedo or cable? Is there a way to fix it or will I have to replace the unit? Thanks for any help you can provide.
    • By Mike Johnson
      Does anyone know what the 3rd item is behind the battery on this ATV ? I know 1 is the,  solenoid1 is the CDI box, what is the 3rd.
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...