Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
utvboard

San Diego Off-Road Coalition Announces Yamaha Rhino Giveaway

Recommended Posts

The San Diego Off-Road Coalition is raffling off a 2008 Yamaha Rhino 700 FI at this year’s Off-Road Expo at the Pomona Fairplex in Southern California, October 9-11. The winner of the raffle will be chosen at the show on October 11, and all proceeds will go to the SDORC.The Rhino to be given away is an 4×4 automatic that features a 686cc liquid-cooled four-stroke engine with fuel injection,

More...

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By J Printz
      i have a 2004 Yamaha Kodiak 450 and it is losing oil but does not smoke what is it
    • By Chase Cook
      I have a 2001 yamaha yfm350x and it has a brand new top end, new carburetor (stopped the leaking problem and is now getting gas to it), new CDI box, new stator, handlebar switches work, off-and-on switch works, new starter solenoid (works), new neutral relay (works), ordered a new Rectifier on its way, good strong blue spark. Has compression, valves are right. Timings is right and is TDC. When I try to start it it just makes a loud popping noise like its backfiring but it's not because its not running when I push the throttle all the way and when i barly push the throttle it try to start but won't, so I'm trying to figure out what could be the problem not starting now, Getting very fustrated with this thing and put some work and money into it and it's not still not working. This is the only atv I ever had that I can not figure out the problem to get running. Need help please..
    • By Chase Cook
      I have a Yamaha 350 in at once to try to fire up but won't. It's getting gas fire air and it has a lot of compression but still struggles to start check the timing it's top dead center valves are good valves are adjusted everything's working but won't fire I put my hand over the carb suck in gas and it tries to but it makes a lot of black smoke. Also when I put my hand over do you carb and tried to start it there's black black nasty stuff in the gas. So I don't know if it's trying to burn too much or what it is the gas tank clean and it anything to do with the gas it's with it firing. Took the spark plug out and it's pure black. What is dried up black not nasty corroded wet looking. Need help to solve the issue
    • By Colby Calk
      I recently got a 98 warrior 350 that 'needed the carb adjusted' but the reality is it has no spark. I have a new spark plug, plug wire, ignition coil, battery, and cdi box. I checked continuity and took apart and inspected the starter/kill/light switch on the handle bar, and it all looks brand new and checked out. The key switch seems to be working properly, as when off, nothing works, but when switched on, lights and electric starter button work. It turns over fine, and as I just stated, all the lights work. I took all the plastics off and traced all the wires, and only one had a small cut in it, but it was only through the rubber sheathing, not the wire itself (the blue one coming from the stator). I cleaned some grounds, made sure both relays work, and still nothing. I pulled the stator cover and looked at the stator itself, and it looks great. No broken wires or connectors or anything. Still, no spark. I'm at a loss. Where do I go next? Any help is appreciated.
    • By mrfartsalot
      i have a 1986 yamaha moto 4 200 and was wondering if i could put a 350 or 300 jug and piston on it to bump up the cc?
  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By alexcross324
      Hi all, I try to find this manual in the threads but you have a lot of stock here
      Cannot find this particular manual.
      I found it for YFM200 but not sure if they are the same.
      Thanks if you could help me with that.
      Im new here so if I did something wrong, please tell me.
    • By dyyjrr9
      I just got a 1991 Yamaha Moto 4 for my son and I am looking for a service repair manual. I know that the timing chain needs replaced.
    • By Srx_Man
      Hey I own stock why Yfz 450 and I'm just looking to slap a turbocharger on it.. I was just wondering if they're pretty compatible with these machines it is the carburetored version Yfz 450. I have all the piping hook ups / kit that's threw HURON SPEED an i also have turbo lined up for it gt 12.. I was just wondering what else I need to make this work? I know i would need to up the Jets and stuff for starter but Is it just that simple or do I need blow off valves and like some time on regulator on it or so forth? Trying get ideal what i would need
    • By M0BJT
      Hi Everyone
      This is my first post and I was wondering if there is anyone who can help me solve a problem I have with my Yamaha Kodiak 400 4x4 Fitted with a Mikuni Carburetor . The year of the quad is around 1998, the reason I am not sure of the date is, there wasn't any paperwork and no details on the frame either.
      The quad had a bad leak from the carb overflow which indicated that the float needle valve was blocked or passing so I replaced this and put everything back together. The quad ran really well until I took it onto some rough ground to have a ride around, a few hours later the engine started to run really rough as if the engine was flooding. I have removed the carb again and cleaned the needle valve out and the whole of the carb just in case there where any dirt behind it. Engine now runs fine again but fuel has started to run out the carb overflow again.
      I have tried everything to try and stop the fuel leaking out the overflow but its still happening. My last thoughts where to adjust the float level and its still happening.
      Has anyone got any thoughts on the problem or could suggest whats causing the fuel leaking out the overflow.
      Thanks for reading
      Kevin
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...