Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

  • 3 weeks later...


  • Replies 43
  • Created
  • Last Reply

Top Posters In This Topic

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By Michael Aiken
      Where can I find a wiring diagram for my 2005 450 Kodiak. Thanks.
    • By Kristpj
      I know this tooic has been addressed by many, I’ve looked through many forums and pages. I did not find anything like the problem i have.
      I have a 2007 Kingquad 450. I have a new fully charged battery. When i turn the key, the dash flashes and seems to struggle before getting fully lite. We can hear a small relay near the computer clicking, i think it is the fuel pump relay. When i turn off the engine kill switch and press the starting button relays click and all the power shuts off, i turn the key off, engine kill switch then start over, power is there. Atv will start with pull start, but not elextricly. if i try to use my winch, all power cuts and engine dies. 
       
      Can anyone tell me what it may be? or has anyone fsced an issue like this before?
    • By chuckufarlie
      I have a 2018 Kodiak 450 EPS that just this past Sunday I ran through a bit of water.
      After the puddle the belt was slipping, so I pulled over and drained the ultramatic housing and the slipping problem went away. This was all in L and everything seemed to work fine. Later when I got on a road, I put it in H, but it still rode like it was in low... i.e. I had to rev it up a lot just to get to 30mph.
      When at home I pulled the ultramatic cover off to inspect, and it looked okay in there. Not much dirt, belt and everything are clean, but when I rev up the engine (with cage in place, of course), the belt doesn't get to the top of the clutch (maxes out about an inch or 1.5" from top of clutch, so maybe it is normal).. I put it back together but same thing... H seems like L still.
      Do you think the clutch needs to be further dissected for cleaning, or could this be an issue with the gear selector?
       
    • By Steven Alter
      I have a 2018 450 and the digital gause has started flashing on an off while driving. The backlit also goes on and off. It is worse when I hit the gas. The battery died a few weeks ago and I jumped it but its been fine until last night. Called the dealer and showed them a vid and they recommend replacing the gauge and its like 600 bucks. The machine has less than 100 hours on it. I would really hate to have to change it out. also the unit sometimes has trouble starting. Any ideas?
    • By Admin
      View File 2014 Arctic Cat 450 ATV Service Manual
      2014 Arctic Cat 450 ATV Service Manual
      Submitter Admin Submitted 02/08/2019 Category Arctic Cat ATV  
  • Similar Topics

    • By Cramer88
      out of the blue my vinson wouldn't shift into park and when I am in H or L and go past a slow pace (maybe in 2nd gear) it grinds and Low grinds even louder. It sounds as though it may be in the rear diff. I have not tore into the rear end or anything yet. I was looking for advice before tearing it apart. Reverse has no grinding at all and H gear doesn't grind until you get moving past a walking pace. L grinds as soon as it moves. It shifts into gear smoothly and 4wd works just fine. There was no issues leading up to this. Any advice is appreciated thanks.
    • By GlennMcl
      1998 Arctic Cat 300 4x4 Red
      This quad formerly ran fine but started to run poorly as it wouldn't idle or rev easily.  The current problem is as specified below.
      Starts and idles fine when cold.  Will rev to mid range when cold.  As it warms up it will not rev and idles poorly as it gets warmer.  I thought might be a problem with the ignition coil so I replaced it with a new one, no improvement.  It doesn't backfire or stutter.  It just falls on its face when the throttle opened.  Also no smoke out exhaust.
      I changed the carb to a new Mikuni VM32 which is a common swap. Fuel tank was cleaned, a new shutoff valve, new fuel filter, new fuel line installed.  Air filter, ignition coil are new.  CDI was recently replaced with an aftermarket unit.
      I verified fuel is flowing from tank to carb.  Fuel tank vent is not clogged.
      Still no improvement.
      Possible valve adjustment problem?
      Any advice would be appreciated.
    • By Muskyjim
      I recently purchased a 99 big bear 350 2x4 that was sitting for a while got it running and went to take it for a ride after about 10 minutes into the ride it stalled and wouldn't let me shift down into neutral tried rocking it back and forth but will not go into neutral...can anyone point me in the right direction on where to start?
    • By ScottCarl
      Finally got some time to drag it up out of the weekds and do a little work on it. What I thought was a stuck-in-gear issue turned out to be a stuck-in-brake issue LOL. Just needs some TLC. Thinking of replacing fenders and such with some custom aluminum diamond plate panels. Salvaged a bunch from a pickup tool box I acquired. 



    • eManualOnline
    • By Admin
      We would like to wish everyone a Fantastic Memorial Day Weekend!
      SUPPORT OUR TROOPS!
       
  • Recently Browsing   0 members

    No registered users viewing this page.





×
×
  • Create New...