Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
utvboard

New Charge Alert Battery Status LED from Rigid Industries

Recommended Posts

MESA, AZ – September 11, 2009 – The latest release from Rigid Industries is here. A simple 5 minute install of 2 wires and one surface mount LED bulb lets you know the status of your charging system.A simple yet ingenious way to monitor your vehicle Battery Status. Install two supplied wires(one to ground, one to switched power) on any 12v wire in your vehicle, mount the led bulb anywhere in

More...

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Ben Mann
      Rincon was stuck in 4x4 so we cleaned the sludge out of the diff, put fresh oil in and all is well.
    • By Ben Cramp
      I am hoping one of you knowledgable people can answer this for me. I have a yfm200 moto 4 engine I want to put in an off road go kart. I would like to mount a sproket where the drive exits the case before the u joint so that I can get rid of drive shaft and make engine bay compact. To do this I would mount engine 90° to axle but would also need to tilt it forward 15° to account for the angle the drive exists rear of casing. Would that be ok? Would oil pump etc still work. Any advice greatly recieved.

    • By Matt John
      Charging issue?
      I have a 2017 Polaris Sportsman 570 EFI. Yesterday, I start the machine and it says low power (10.6-10.8). This machine is on its second battery. This is a new AGM battery with 50cca more than stock.
      Should I look at the regulator or stator?
      Thanks!!!
    • By Gilbey
      Just got 2018 Suzuki King 400 ASI, getting ready to install winch on it. Noticed the wire loom up front on top of frame to pass wires through but not quite sure where the loom comes out at. I am assuming by the battery but it is not visible........would you guys just wire direct to battery as I had on previous quad or is there a better spot to wire to? I had noticed a wire junction on top of driver rear wheel with nothing connected to it and was curious if my leads could bee run to that? May have to go to dealer to see if a mechanic there can give me some insight to this process. Thoughts and ideas greatly appreciated.
  • Similar Tagged Content

    • By data89
      2005 Arctic Cat LE 500cc. This last year the led readout has basically faded to where you can barely see it. This cat is always covered or inside, when not riding, so it's not due to sunlight fadeout I don't believe. Where does it get its' power from Is it from ECU under the seat?
    • By toonces
      Is there such a thing as a battery blanket made for ATV sized batteries? I've also heard of a battery 'plate' which I assume would be put directly under the battery. If someone could point the way to either of these much obliged.
      Also, maybe any other ideas on how to keep your batt warm that would go directly in the battery compartment? Trying to avoid just throwing a tarp over and putting a space heater under. Need an option with lower wattage consumption.
      thanks
    • By Photo72
      Arctic Cat 2006 ATV 500. The battery is dead overnight. Recharges fine with 1 amp charger. I disconnected the negative cable from the battery and put a meter between that post and the cable with everything turned off. It read a 10 volt draw. I pulled each fuse one at a time. The power draw went to zero when I pulled the ACC fuse and no others. The engine starts and runs without the fuse but the display panel keeps starting to show then goes off briefly. The display works fine with the fuse in place.
      What is the most likely culprit? How do I get to it? How do I fix it.
    • By bodatiouskid
      :aargh:I have a 02 Kaw.Prairie 650 with around 2300mi. & 280hrs. on it.After alot of start&stop riding this weekend,the LED gauges stopped working.Still have neutral&reverse lights,but no odo,clock,speedometer,& fuel gauge.
      What do you think went wrong & how can I fix?
    • By eorc1313
      I dont know what size the factory battery was. The kart is out of town and i cant measure it.The battery i have is bad and its smaller than the factory size. i looked it up on Kazuma parts.com and lots of places but they dont list them model specific
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...