Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Tazman6789

very unhappy with first test trial of 07 vinson 500

Recommended Posts

ok so i bought a 07 suzuki vinson brand new from the dealer. i currently have 120 miles on it thats all. Took my atv out so Tionesta, PA this weekend about a 2 1/2 hour trip. It rained on sat for about an hour, mean time my atv sat under a tree wating for the cold rain to go away. So rain stops wipe the very little amount of water off the atv. go to fire it up gauges come on push start button. Hear the starter relay hum and no start... ok maybe just battery low. pull start and go on my way. get 2 seconds down the trail. Hit my brakes and my gauge cluster shuts off and flickers and goes crazy. let off the brakes it comes back on... continues doing this for about 8 hours. night time rolls around go for a night ride. same ordeal no elec start and gauges not working but now my headlights are barely on and flickering... i thought atvs were suppose to take a beating and keep on rolling. this gets a lil rain on it and goes haywire. Isnt the cluster suppose to be waterproof or at least water resistant? any suggestions what to do with this thing? im very unhappy with it right now. Should i just take back to dealer and shove it down his throat for selling me this or what? i have what the dealer called a 6 month bumper to bumper warranty? any suggestions would be great. Thanks for any help

Share this post


Link to post
Share on other sites


Take it back and have them check it out. My wifes KingQuad is AWSOME! It has been through deeeeep mud, rain storms and power washing with out a single issue. All makes have a problem now and then, let them make it right.

Share this post


Link to post
Share on other sites


now that its dried out for a day it acts like nothing happened making me think its a wire short some place all gauges work starts fine works great... even before the trip i noticed after i let the atv sit for a week or so it wouldn't elec start it would just make the relay hum like the battery was almost dead. Thought nothing of it till this weekend when it wouldnt stop doing that. Guess ill get it wet and take it back to dealer even tho the dealer i got it from was a bunch of idiots in the first place. guy didnt even know to check the coolant level before they send out a brand new machine...

Share this post


Link to post
Share on other sites

If you weren't from Mentor I would have guessed you bought it from Park Honda in Canton. There service department really sucks!! What dealer did you buy from?

Share this post


Link to post
Share on other sites
all ohio motorsports on aurora road in cleveland

My buddy bought 2 Polaris quads from there and doesn't like there service either.

Share this post


Link to post
Share on other sites

if you read my old post you will see i already had one crappy run in with the service center there so im dreading taking this thing back there cause its a 40 min drive from my house and have a feeling theyre gonna try to get out of it.

Share this post


Link to post
Share on other sites


glad to see some riders here in ohio! im from canton and hate park honda/HARDINGS they suck i go to action in alliance oh.

Share this post


Link to post
Share on other sites
glad to see some riders here in ohio! im from canton and hate park honda/HARDINGS they suck i go to action in alliance oh.

Action is great! But they are almost an hour away from my house. I have had good luck with Roush Motor Sports in Medina as well.

Share this post


Link to post
Share on other sites
ok so i bought a 07 suzuki vinson brand new from the dealer. i currently have 120 miles on it thats all. Took my atv out so Tionesta, PA this weekend about a 2 1/2 hour trip. It rained on sat for about an hour, mean time my atv sat under a tree wating for the cold rain to go away. So rain stops wipe the very little amount of water off the atv. go to fire it up gauges come on push start button. Hear the starter relay hum and no start... ok maybe just battery low. pull start and go on my way. get 2 seconds down the trail. Hit my brakes and my gauge cluster shuts off and flickers and goes crazy. let off the brakes it comes back on... continues doing this for about 8 hours. night time rolls around go for a night ride. same ordeal no elec start and gauges not working but now my headlights are barely on and flickering... i thought atvs were suppose to take a beating and keep on rolling. this gets a lil rain on it and goes haywire. Isnt the cluster suppose to be waterproof or at least water resistant? any suggestions what to do with this thing? im very unhappy with it right now. Should i just take back to dealer and shove it down his throat for selling me this or what? i have what the dealer called a 6 month bumper to bumper warranty? any suggestions would be great. Thanks for any help

Did you get this problem worked out? I just bought the same quad, brand new and zero probs out of mine...I assume yours was a leftover from 2007 like mine.

Share this post


Link to post
Share on other sites

no i have to take it to the dealer problem im having is i work until 5 every night by time i go home load up and get out to dealer they're closed. ill get it out there eventually. hope its something stupid cause the atv runs like a champ besides the elec problems. Tried starting again lastnight and it wouldnt elec start so we'll see

Share this post


Link to post
Share on other sites

well i feel like a dummy know. decided to clean it up today befor taking it to the dealer. decided to pop the seat off and check out under there... well dumb a$$ me should have checked here in the first place. The spot where the fuses and starter relay are under the seat were completely submerged in water the drain plug was pluged up cause somehow a ton of woodchips and crap got under there and blocked the drain. let the water all drain out and let it dry... SURPRISE it all works again including the elec start. also the negative battery terminal had a lil bit of crud on it again im going to have to put terminal protector on them.... oh well

Share this post


Link to post
Share on other sites


Insert NEWB jokes here lol now only if i had a place to ride right behind my house still... hate moving into suburbia with no place to ride

Share this post


Link to post
Share on other sites

We went to a fed orv place last weekend and there were 4 v

Vinsons including mine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By mikeexplorer
      For those in the Northeast, this weekend is going to be a hot one. This upcoming weekend is the Snow Shoe Rails to Trails Chicken BBQ event which we attend every year. Last year for our Jumping Jack, I made a "Redneck Air conditioner" but I found sticking the hose in the door way got in the way. This year I improved upon it and found a way to have the cold air blow into the front window without cutting or sewing the marine canvas. I didn't want to compromise the canvas in any way so I came up with a way to hold it in place with magnets. Made strips of magnets with duct tape and used clear vinyl to cover the window and attach the duct coming from the air conditioner.  I did replace the hose with one that is a bit longer, found it on Ebay since you can't buy vinyl dryer duct hose anymore.
      We are ready for the hot weekend of riding and camping, and the hose won't get in our way anymore.



    • By Jordan Ritzman
      What causes a rod bearing to overheat and seize 
    • By Jordan Ritzman
      How long between rebuilds 
    • By Jordan Ritzman
      What are some good online vendors for parts
    • By Bud03420
      I just got this bike and not getting any spark I know nothing about it so before I spend any money on it I like to see if it fires dose it have to have a battery to complete a circut and spark cause it dosent have one
  • Similar Tagged Content

    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By colin james
      View File 1996-2000 Polaris Sportsman 335/500 Service Manual
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
      Submitter colin james Submitted 10/19/2018 Category Polaris ATV  
    • By colin james
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
    • By colin james
      This is the factory service manual for the sportsman 500 6x6.
      Download just the chapters you need or can download all chapters to have complete service manual. 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...