Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

craneman

Polaris Sportsman 500 EFi stalling problem

Recommended Posts

After riding my quad for a couple of hours it will shut off. After sitting for a short while, it will start again and run for a short while. It seems the fan is not coming on as it should. Has anyone else experienced this problem with their Polaris? :confused:

Share this post


Link to post
Share on other sites


I have not experienced this problem because I don't own a Polaris, but if the fan isn't coming on, and the machine is getting too hot, there could be a thermal overload switch that shuts the machine off when it gets too hot. Are there any overheat warning lights on the machine? You could try to wire the fan to a switch so it stays on (temporarily) and see if the machine will keep running then. It could also be a problem with one of the secondary ignition components; stator, cdi, coil, regulator/rectifier. Sometimes these parts will begin to malfunction as they get warm.

Share this post


Link to post
Share on other sites

Is it overheating? Is that why you feel the fan is not coming on when it should?

It may very well be your fuel pump, shutting off after getting hot. Whe you run into an issue where it will not run, start testing circuits to see what system is off...fuel or ignition. If it is overheating, I belive it does have a cooolant temp sensor on that machine that could be your issue.

Share this post


Link to post
Share on other sites

craneman, any update on your issue? What year is your machine?

Share this post


Link to post
Share on other sites
After riding my quad for a couple of hours it will shut off. After sitting for a short while, it will start again and run for a short while. It seems the fan is not coming on as it should. Has anyone else experienced this problem with their Polaris? :confused:

I have a 2006 Polaris sportsman 500 efi. I had a problem with my bike getting alittle hot. I found it to be the radiator. there was dirt in the fins from the bottom to the middle of it. Clean the dirt out with a garden hose very gently as the fins will bend easy. underneath the gas tank on the left side you'll see a plug, pull it out while running and see if the fan comes on. if it does your fan is fine. Check this first to see what happens.

Share this post


Link to post
Share on other sites


this happened to me on my popo 450, but i had abit of water in my gas...maybe you should check yours and check your plugs to see if their the right color.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ed Zeppeli
      Hi all,

      I picked up this quad after the previous owner couldn't get it going.

      The issue is that I can't get it to fire at idle or at all.

      I've...

      - replaced plug. Decent blue spark. Also tested with spark tester inline.
      - rebuilt the carb. PO had already bypassed vacuum lines from petcock. There's fuel at the cylinder
      - Checked compression with new gauge. reads 190 psi
      - cleaned all contacts I could access.
      - am currently jumping with car battery. Solenoid jumpered.
      - checked cam timing at TDC and adjusted valve lash
      - put gas directly into cylinder to see if it will fire at least momentarily

      Motor turns over well. Plug gets wet. 

      Motor may fire once or twice but smokes through exhaust a bit as if it's trying to fire or combusting.

      This leads me to suspect timing. As mentioned I checked the flywheel mark versus cam marks. Perhaps someone has been in there before because I can't find a 'T' on the flywheel but there is a very visible paint mark which aligns with TDC position on piston. Possibly a slipped flywheel/woodruff?

      Is it possible that if it had seen previous repairs, that the timing could still be off? I'm reluctant to dig into the flywheel/stator area if there's something else I could have missed but all signs point me to that area. Would a bad CDI cause spark timing to be off?

      Anywhere else to diagnose incorrect spark timing?


      I've scoured these forums and elsewhere but I'm posting just in case there's something I've overlooked up until now.

      Thanks very much for reading!


      Warren
    • By Shawn Hendershot
      Got myself another project. Got it running only to find it has a transmission problem. now I am trying to rebuild it but problem is the bolt that holds on the pull start recoil gear. Any ideas if this is left threaded or right threaded. Left loosy or righty tighty. 
      Thanks.
      Hender
    • By Chad Dickerson
      I am goin nuts here! I have a 04 400 air cooled 4x4 , I'm a atv,car,truck,mower mechanic for yrs,just sayin. Ok it cranks and kinda fires now and again then after 5 min of cranking and stopping itl start if u touch throttle itl did then u start all over! If u let it warm up sumtimes u can throttle it up other times it just does! Just depends on it? When it stays running it runs awesome,no problems except it just does randomly like u shut key off? Sumtimes itl start right back up others itl do the no start thing! IV put new plug,adjusted valves and hot tanked carb? I'm at a loss here guys! Please any other ideas? I don't think it's anything to do with flywheel? It's not the auto it has a hi low reverse lever on left fender and foot shifter? Help please lol
    • By bradken19
      the king quad had sit for about 1 1/2 years. So I rebuilt the carb and now it will not start. Any help will be greatly appreciated.
    • By Brittany Jones
      Yes I just got a 1998 polaris xplorer 400 4x4. Ran fine after hauling then died. Cleaned carb and put new fuel filter, hose, and new battery in. Starts 3 out of 10 times but will only run for a short time. Any suggestions?
  • Similar Tagged Content

    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By colin james
      View File 1996-2000 Polaris Sportsman 335/500 Service Manual
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
      Submitter colin james Submitted 10/19/2018 Category Polaris ATV  
    • By colin james
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
    • By colin james
      View File 2001 Polaris Sportsman 500 6x6 Factory Service Manual
      This is the factory service manual for the sportsman 500 6x6.
      Download just the chapters you need or can download all chapters to have complete service manual. 
      Submitter colin james Submitted 10/18/2018 Category Polaris ATV  
    • By colin james
      This is the factory service manual for the sportsman 500 6x6.
      Download just the chapters you need or can download all chapters to have complete service manual. 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...