Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

josephnbl91

Major problems with 2007 King quad 450

Recommended Posts

id love to see them you have the same wheels?

Read it again, I think some of that might have gone over your head.:wink:

Share this post


Link to post
Share on other sites


sorry for taking so long i have the rims on the four wheeler it looks even better than i imagined. i havn't had much time to take and post pics yet. the bike is really dirty still from the last time i went mudding at redneck yacht club. once i get it cleaned and take pics i will post them asap.

Share this post


Link to post
Share on other sites

okay lol. i need to stop being lazy it is so cold here in florida to us floridians so i dont feel like getting it out just yet.

Share this post


Link to post
Share on other sites


okay lol. i need to stop being lazy it is so cold here in florida to us floridians so i dont feel like getting it out just yet.

I did hear on the news you were going through a cold snap and crops were in danger...

It's much colder here in NY....I would love to be in Florida!!! Disney to be exact.

Share this post


Link to post
Share on other sites

yes we had record lows here for a while usually the temperature never gets any lower than around 44 degrees it got to around 30 in some cases lower especially in north florida im sure they were seeing in the 20's there is lots of crops in north florida. we were gettin some ice in south florida nothing major though but we arent used to this

Share this post


Link to post
Share on other sites

th e fi light will always go on when the engine is not running or stall

with that kind of mileage and with a snorkel kit i would consider the condition of the motor

if you found debri in your intake then shouldn't it have gotten in to your motor

fuel injection is very simple if you under stand it

check compression and leak down readings

check valve adjust ment

also check if choke valve system is siezed/stuck

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By Kristpj
      I know this tooic has been addressed by many, I’ve looked through many forums and pages. I did not find anything like the problem i have.
      I have a 2007 Kingquad 450. I have a new fully charged battery. When i turn the key, the dash flashes and seems to struggle before getting fully lite. We can hear a small relay near the computer clicking, i think it is the fuel pump relay. When i turn off the engine kill switch and press the starting button relays click and all the power shuts off, i turn the key off, engine kill switch then start over, power is there. Atv will start with pull start, but not elextricly. if i try to use my winch, all power cuts and engine dies. 
       
      Can anyone tell me what it may be? or has anyone fsced an issue like this before?
    • By chuckufarlie
      I have a 2018 Kodiak 450 EPS that just this past Sunday I ran through a bit of water.
      After the puddle the belt was slipping, so I pulled over and drained the ultramatic housing and the slipping problem went away. This was all in L and everything seemed to work fine. Later when I got on a road, I put it in H, but it still rode like it was in low... i.e. I had to rev it up a lot just to get to 30mph.
      When at home I pulled the ultramatic cover off to inspect, and it looked okay in there. Not much dirt, belt and everything are clean, but when I rev up the engine (with cage in place, of course), the belt doesn't get to the top of the clutch (maxes out about an inch or 1.5" from top of clutch, so maybe it is normal).. I put it back together but same thing... H seems like L still.
      Do you think the clutch needs to be further dissected for cleaning, or could this be an issue with the gear selector?
       
    • By Steven Alter
      I have a 2018 450 and the digital gause has started flashing on an off while driving. The backlit also goes on and off. It is worse when I hit the gas. The battery died a few weeks ago and I jumped it but its been fine until last night. Called the dealer and showed them a vid and they recommend replacing the gauge and its like 600 bucks. The machine has less than 100 hours on it. I would really hate to have to change it out. also the unit sometimes has trouble starting. Any ideas?
    • By Admin
      View File 2014 Arctic Cat 450 ATV Service Manual
      2014 Arctic Cat 450 ATV Service Manual
      Submitter Admin Submitted 02/08/2019 Category Arctic Cat ATV  
    • By Admin
      2014 Arctic Cat 450 ATV Service Manual
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...