Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
utvboard

Muzzys Congratulates Winners of the 2009 Lucas Oil Off-Road Racing Series

Recommended Posts

Bend, Oregon (November 19, 2009) - Muzzys Performance Products is proud to have supplied the exhaust for the top three finishers in the 2009 Unlimited UTV Lucas Oil Off-Road Racing Series. After 14 races in this inaugural season for Lucas Oil short course racing, #624 Chad George took first place, followed by #664 Robert Vanbeekum and then #694 Tyler Winbury. These racers all drove Kawasaki

More...

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Ed Zeppeli
      So I fired up the quad the other day and let it idle for about 5-10 minutes and it ran great then died.
       
      I go to check it. No lights on dash, nothing.
       
      Check the main fuse and it's blown. Key's off/out. Put in another and it blows immediately.
      Pull out the meter and see that on the non-load side of the fuse holder there's continuity to ground.
      Check all obvious things. Wiring diagram. Connectors. Frayed wires. Bad grounds.
      Battery measures ok at 12.8v.
      I'm dreading taking off the front plastics but I suspect the regulator/rectifier. The wiring diagram shows the red wire (the suspect wire) goes to the ignition switch and the regulator/rectifier.
      Anyone else experience something similar and/or have any troubleshooting tips that may save me the grief of removing the plastics?
       
      Thanks much,
       
      Warren
    • By LMI
      I wanted to share an experience and a fix.
      Headed out was following a pole line, was looking for a cross track that may take me to this speckle trout looking spot on a creek.  All paths and semi paths... failed.  Second objective was to reach a speckle trout lake that has been recently stocked... followed 1 trail to dead end, followed second trail to dead end.... while investigating options on foot and the quad idling it died.
       
      It wouldn't start.  eventually it did... and when it did … it was essentially a pinned idle.  activating the throttle did seem to speed it up but it wouldn't knock out of the racing idle.  couldn't put it in gear at that idle speed.  got towed out.
      when I first got the quad, I ran it off a trail and buried it pretty good in the soft snow... eventually winched out.  It wouldn't start.  eventually did and it was fast idling.  not as fast as this last time. but still fast.  it eventually seemed to settle and I got it in gear and by the time I was back to the truck was acting ok.  chalked it up to the bike being at a bad angle in the snow.
      My investigation last year lead to the throttle position sensor TPS.  how to jumper the diag block to see the sensor position on the display,.  I focused on this nearly sure it was a detuned sensor or broken sensor again this time.
       
      I tore down the front plastic and stuck my head into the TPS area to see what I could see.  What I found was that the throttle body assembly had actually come out of the mounting area (not sure what it is called).  the ring clamp was loose I could move it easily.  Hopeful, I tore down the air intake assembly above it (air filter...etc) removed a sensor clip and a hose.
      I backed off the clamp some more and was able to reseat the throttle body assembly.  put some blue lock tite on the clamp screw.  When I was cleaning off the air intake assembly to ensure I dropped nothing down the intake, I noticed the underside of the air intake "box" also had a clamp.  this screw was completely missing.
      I went to the hardware store, bought a metric replacement (brought clamp with me), seated the assembly, settled the clamp blue lock tite that as well... 
       
      quad fired right up, idled normal, idled up without hesitation and dropped right back off.  Cost of solution $3.87 CND for a pack of 5 metric screws.  moral of my story was don't assume an idle issue is a throttle position sensor problem... there are a number of other factors including air pressure, which I believe was my issue.
       
       
       
    • By utvboard
      Ride Review:
      As the owner of a pretty tricked out 2008 Kawasaki Teryx, I am very familiar with the Teryx. My Teryx did not stay stock long, but I recently spent three days in a bone stock 2008 Teryx on a ride to the Grand Canyon.
      The 2008 Teryx is a great machine, but my biggest complaint was that it came out with carbs instead of fuel injection. In less that a year since the first Teryxs hit dealer floors, Kawasaki dealers are already selling 2009 Teryxs with EFI. The New digital fuel inject on the Teryx is really nice. The engine starts right up and idles smoothly. On acceleration, the 2009 Teryx felt more crisp and seemed to get up to top speed a little quicker. While it is not a night and day difference, I definitely preferred everything about the EFI on the 2009 over the carburetors on the 2008.
      Next up on the list of what's new is a fuel gauge. I know it doesn't seem like something to get that excited about, but I do some long distance rides, and the fuel level display takes the mystery out of "I wonder how much fuel I have left?"
      The Teryx Sport has upgraded aluminum wheels which not only look much better, but are also 2.2 lbs. lighter than the standard steel wheels. Losing unsprung weight not only requires less energy to get the tires spinning, but also helps the suspension work better. And as a little bonus, the aluminum wheels are actually strong that their steel counterpart.
      Suspension is on the 2009 Teryx Sport has a few upgrades as well. The gas-charged Kayaba shocks have reservoirs all the way around to help reduce fade in rough terrain. The preload adjustment is step-less, and they have fully adjustable rebound and compression (high and low speed) damping. Although we did not have any opportunities to jump the new Teryx Sport, we did get into some nasty whoops and hard g-outs.
      I felt the Teryx Sport suspension handled the terrain better than a standard Teryx suspension. The ride through the light chop was a bit smoother than a standard Teryx and when we got into the whoops I felt a little more comfortable as well. Although I was able to bottom out the front shocks on a few hard g-outs, a standard shock would have gone to the stops more often and with more force. Overall, even though I did not spend any time trying to fine tune the adjustments on the new Sport shocks, I think they are a worthy improvement over standard shocks.
      The Lime Green plastic on the Teryx Sport is a great color. Much more sharp than the drab green found on the 2008 Teryx. And with all the UTVs out in the dunes in Glamis, there is no doubt that you are in a Kawasaki when you are driving it.
      The 2009 Kawasaki Teryx 750 FI 4x4 Sport has a MSRP of $11,899.

      A full list of all new 2009 Kawasaki Teryx improvements and photo galleries can be found here.
      Links:

      2009 Kawasaki Teryx Sport Press Intro
      2009 Kawasaki Teryx 750 FI 4x4 Sport Review
      Teryx 750 FI 4x4 Sport - Kawasaki

      More...
    • By Jordan Ritzman
      What are some power mod for 2 stroke 
    • By JacobSlabach
      got 7 atvs off CL recently for a good price.  one of which is a yamaha warrior.  anyone know where the vin is printed on this bike?  Haha good place to start as I do not know year or size yet.  The former owner says needs exhaust ans and clutch work.  he said it ran fine until the clutch cable broke and then I couldn't get the new cable adjusted right and it would grind gears.  things I see:  clutch cable locked up again, no brakes, carb leaking (green with algae around the bowl and has gelled gas stalagtights on it), aftermarket exhaust melted the airbox so I need something different and a new air box.  I would like the use the current exhaust if I can but I have a feeling its a redneck fix as it looks like there is an ace bandage holding it to the exhaust pipe (its an aftermarket slip-on exhaust), so I'm not sure about that- lets get the bike running first.  also, battery (looks brand new, what a shame) is dead, 0 volts.  Otherwise, bike looks to have not been wrecked, and plastics are ok (it sat outside under a 'tarp' for 3+ years since it was run last).  any tips and advise on where to start first would be awesome as this is my first clutched bike (manual).
      the clutch is my main concern- I've never rode a clutched bike so I dont even know what its supposed to feel like.  lol I'm spoiled on my automatic polaris 
  • Similar Tagged Content

    • Guest
      By Guest
      Ok...I'm gettin' me juevos ready to do an oir filter clean....
      Went to my local harley/quad dealer and he had me purchase the No-Toil kit (Cleaner, Air Filter Oil, Rim Grease)
      What I've read is that the No-Toil cleaner will NOT clean
      other oils off air filters....just the No-Toil oil....
      So, I've also read that others have cleaned their air filters
      in the kitchen sink, used gasoline, or used flash solvent....
      Looking for advice as I've mentioned I'm very mechanically
      DECLINED!
      I'm going to wash the air box seal in the sink and give it a good dry....
      One more thing......No-Toil or Bel-Ray for filter oil?
      Thanks!
      -TD
    • By toonces
      Have a 2011 Grizz 700 and for the diff oil the manual calls for SAE 80 API GL-4 hypoid gear oil. I'll be using Mobil 1 synthetic but as it comes in two different weights I'm not sure which one to get....either the 75W-90 or the 75W-140.
      The 75W-90 is listed as GL-5 and is recommended for use in 'high-performance vehicles like SUVs, vans and light duty trucks.' The 75W-140 weight is also GL-5 and is recommended for 'high-performance vehicles including sport utility vehicles, vans and light-duty trucks.'
    • By toonces
      Have a 2011 Grizz 700 and for the diff oil the manual calls for SAE 80 API GL-4 hypoid gear oil. I'll be using Mobil 1 synthetic but as it comes in two different weights I'm not sure which one to get....either the 75W-90 or the 75W-140.
      The 75W-90 is listed as GL-5 and is recommended for use in 'high-performance vehicles like SUVs, vans and light duty trucks.' The 75W-140 weight is also GL-5 and is recommended for 'high-performance vehicles including sport utility vehicles, vans and light-duty trucks.'
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...