Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

johntdunn3rd

2007 sportsman 500x2 Shutting Off loosing all power

Recommended Posts

unit was shutting off at times n at times running well now runs min or two and shuts off n then power comes on n off with unit setting still can send power to yellow power wire feeding ignition switch n jump across started sol n start n run unit as long as u keep power on the yellow wire n soon as u remove power unit shuts off i've replaced bat. check bat conections checked all wiring for rubbin or shorts checked pin drag at control module and power feeding it check main ground removed n cleaned to be sure was good ....ne sugestions??? control module??:realmad:

Edited by johntdunn3rd

Share this post


Link to post
Share on other sites


Get a multimeter and start trying to find the spot where power is lost, probably a relay or switch. Key switch and/or kill switch maybe.

Share this post


Link to post
Share on other sites

Just like DD said..you need to trace the power loss when it is happening. I bet you have a bad connection or relay or switch issue.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By dave3dracing
      Hi, I'm a new member
      Just bought a used 08 350 raptor with about 5 hours on it ( very clean ). Started fine when we got it. Now after a few mods (bumper, skid plates, air filter) Now will not start unless you pull in the clutch. I've checked just about everything and also checked that there is no pinched wires. Anybody have any ideas?:bangheadc: Thanks, Dave
    • By payne
      Have an Bear Tracker 250. Dont have the manual or any literature to help with. Anyhow, starts with pull start in gear, and electric starter doesnt work. Also, neutral light doesnt come on. Where should I begin?? Need some direction on troubleshooting all this. Thanks a million.

    • By Steven Workman
      So I have a Honda Fourtrax 300 year 1988. The ignition doesn’t start it with no sound. The headlights won’t turn on. It has a brand new charged battery, fuses are good, oil is good, gas is good, reverse is rusted, it shifts good, won’t jumpstart but when you try it will turn over, it will start if you jump the solenoid give it gas and spray starter fluid on the breather but it won’t stay on long but will stay on for the little time it does by itself. I don’t know what’s wrong and I need help!
    • By PKR
      Neighbor dropped off his 2010 Ranger 400 HO. Said it was missing and backfiring. I replaced the plug as it was carboned up (kids use the side x side for chores and it is only idled around yard) Unit ran great, sent back home and it ran great for about 5 hours of run time and then it wouldn't start. He brought it back and I changed the plug again and it would start but would not run great. Pull plug and it was really wet. I suspect the carb needs cleaning and that is the direction I plan on going unless someone else knows anything about these units. ( I have never worked on one of these).
      If you know of something else I should check let me know.
      Also I am looking for a service manual for this unit.
      Thanks
      PKR
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...