Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

MoparNut

1990 Suzuki 250 LT 4wd Compression

Recommended Posts



I read online that it is between 142-199 psi. The service limit is 114 psi according to a clymer repair manual.

* Added issue into your thread title.

Share this post


Link to post
Share on other sites

I am looking also for how to check the timing and set the valves as well if anyone could help was not able to find any online manuals.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By shitboxlover
      I have a 2008 loncin desert storm that wont stay running.
      When it ran it ran rough and backfired a lot.
      Now it will only start with throttle and there's a lot of unburned fuel (white smoke), there's also compression comming out the airbox. Is it the carburetor that is broken?
    • By pablo Blake
      Its in pretty rough shape and its gonna be my first atv, I worked on bikes before but nothing to do with quads. Anyways the quad has some problems and im tryna figure out what to focus on first. So the U joints i think are shot. The bike starts first try every time ussually have to give it a lil gas with the throttle and revs right up, idles fine but its running REALLY rich 3 starts and my brand new plug was pitch black

      Bike is L model

      video-1577465068.mp4

      Its using the original mikuni carb but im not the best at fixing the carbs and wondering if there is anywhere online that would be able to either walk me through it or help me with it i didnt see a air mixture screw so it seems like im gonna half to open it up and adjust like the float and a couple other things
    • By Lance Workman
      Guys, had a worn smokey recon 250 to the point it it was fouling plugs. Well pulled the jug looked great and believe my culprit was valve seals. They could not even hold the valve in place. So honed the cylinder for good measure and installed new rings while it was apart. Also lapped valves while it was apart due to little corrosion on the intake valve face, went on and did exhuast while it was apart also. Reinstalled everything, adjusted valves, I cant remember how far out they was but they where out a bit. Well long story short it started up, ran great for about 20 minutes and then randomly died while accelerating. Compression is 60 psi at best.... double checked valve lash and it was way out?? Adjusted it, but you can tell its not right. Still no start, and with rockers arms removed still not compression......? Which making believe ring issue? But why is valve lash  all over the place?! Is there an easy way to check cam to crank timing to make sure it hasn't jump time? Thanks!
    • By Tyler Reed
      Came here for help, If it’s in the wrong place I’ll move. I’ve got a 2000 model Polaris Magnum 500 that runs strong as can be for about 25 mins until warm, then sputters and loses power. Took it to a shop and they say it’s low compression and they will have to swap the entire engine. Seems a bit much and costs more than the entire bike. Was wondering if anyone has seen this and what the fix was. When I hear compression I think of gaskets, not an entire engine. Seems like if it was that bad it wouldn’t have power cold. I’m at a loss. Any help is appreciated greatly. 
  • Similar Tagged Content

    • By Guythis448
      Looking for help on wiring up stock wiring harness specifically for a '88 Honda TRX 300 
      If anyone could drop a link or send me a PM it would be much appreciated 
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By Kyboy
      Iam looking for help seperating the rear brake drum and the cover. Any suggestions would be greatly appreciate
    • By Beb1041
      Looking for a download of a manual
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...