Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

tng6664

Help?? 2002 Kawasaki Prairie 650 Oil Type

Recommended Posts



simply i got 2 different answers from local dealers,,1 says use 4stroke oil for wet clutch,,the other says it dont have wet clutch,but,can use wet clutch oil..the guy i bought it from used regular 20-50 castrol,what oil do i use,,ive asked on 3 forums,thats why i asked if n e one had one so i can find out what they use,,obviously it must work for them

Share this post


Link to post
Share on other sites

You should to use four stroke ATV oil that has additives in it.

p15.png

Valvoline® 4-Stroke ATV Motor Oil

Specially formulated to provide peak ATV performance and protection.

  • Extreme Condition Performance - Thermally stable formula maintains proper lubrication to protect engines under extreme conditions.
  • Wet Clutch Protection - Optimal frictional characteristics for high torque, smooth shifting and proper protection of the wet clutch.
  • Corrosion Resistance - Advanced additives help protect against water, deposits and other corrosive materials to keep engines clean.
  • Maximum Horsepower - Proper additive balance for maximum horsepower.
  • Minimal Wear - Increased anti-wear agents minimize wear from metal-to-metal contact.
  • Shear Stability - Shear stable viscosity improvers better resist oil film breakdown.

* Adjusted your thread title a bit, and added issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Sonders
      It appears that the Service Manual thread at top of forum is dead as all the links no longer work.  I'm actually looking for service manual for a 2000 KVF300 Prairie that I just picked up.  Does anybody have link to one that they can share, or know where I can find one?  Thanks in advance for any help.
    • By Jim Waters
      hi everyone. recently iam get a good vibration that comes and goes while iam riding my praire 4x4. iam afraid something is going to detonate. vibration is felt in the steering and then you will here a noise and this comes and goes. its very noticeable when iam on a blacktop surface. iam worried. i cant get any slop in the drive joints i can grab onto. so any input would be appreciated. i have a manual downloaded and i,ve went through it pretty good. my thought is its from the output shaft to the front drive. let me know if anyone has experianced this.
    • By Spartacus Stroppel
      View File 1999-2002 Kawasaki KVF300 Prairie Service Manual
      1999-2002 Kawasaki KVF300 Prairie Service & Repair Manual
      Submitter Spartacus Stroppel Submitted 08/25/2019 Category Kawasaki ATV  
    • By Richard Fernandez
      Just bought Kawasaki Prairie 650 vtwin 2002 and replaced old carb with new, but the bolts to hold down the air housing are missing. Anyone have any idea what size they are? I apologize for not being very mechanically inclined. Any help would be much appreciated. 
    • By Venom
      Hi All,
      Hoping someone will be able to help.
      I have a 2006 Kawasaki Prairie 700 with twin Keihin Carbs CKVR D32. The Rear Carb is leaking out the side during cranking. it is not the float bowl overflow. It is on the opposite side of the carb from the diaphragm. 
      I got this bike not running and someone had already messed with it. I took the carbs apart , cleaned and rebuilt. Everything went pretty easy.  It looks like it could be missing a small tube between the carbs but I have all of them listed in the service manual installed. See the pic for where it is leaking from...
      Any help would be much appreciated.. Thanks.
       


  • Similar Tagged Content

    • Guest
      By Guest
      Ok...I'm gettin' me juevos ready to do an oir filter clean....
      Went to my local harley/quad dealer and he had me purchase the No-Toil kit (Cleaner, Air Filter Oil, Rim Grease)
      What I've read is that the No-Toil cleaner will NOT clean
      other oils off air filters....just the No-Toil oil....
      So, I've also read that others have cleaned their air filters
      in the kitchen sink, used gasoline, or used flash solvent....
      Looking for advice as I've mentioned I'm very mechanically
      DECLINED!
      I'm going to wash the air box seal in the sink and give it a good dry....
      One more thing......No-Toil or Bel-Ray for filter oil?
      Thanks!
      -TD
    • By Jean de la Chevrotière
      View File Polaris 700 2002 Owner's manual
      Polaris 2002 700 Owner's Safety and maintenance manual
      Submitter Jean de la Chevrotière Submitted 12/01/2018 Category Polaris ATV  
    • By Jean de la Chevrotière
      Polaris 2002 700 Owner's Safety and maintenance manual
    • By priglmeier
      I own a 2002 Can-Am Quest 650.
      It will start if you massage the throttle a bit and it will continue to run. BUT if you let go of the throttle and try to let it idle it will always die warm or cold.
      It has Non-Oxy premium gas, a new gapped NGK plug, a new carb (as of today) and fresh fluids. After installing the new carb it runs exactly the same.
       
      I only have a few things that I have observed since the new carb:
      The choke still doesn't do anything. It has a good cable and it is hooked up. It on fully off. There is a cable in the top, front of the engine that splits into two connectors. The connected side is in the photo. The other side has the yellow banded section and is not connected. I do not see anything in range of this connector so I don't know if this is normal or not??? The original carb wasn't really dirty or clogged. I'll use it as a spare. I don't see this cable and connectors listed in the Can-Am shop manual. Looking for some help. I want to ride!


  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...