Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

waynemags

2006 Suzuki King Quad 700 No Compression

Recommended Posts

im looking at buying an 06 king quad. doesnt run. guy said it stopped on the trail. he got it home, and checked compresion. apparently none. im not sure if it was just low, or actually zero. any ideas what this may be? im hoping to maybe get it cheep and repair it. thanx.

Share this post


Link to post
Share on other sites


could be various issues with it..piston head could of cracked..or the piston itself might need some need rings (but if the compression is at 0 i think its not going to be cheap to fix)...good luck with it...got any more info on it like miles and so on??

Share this post


Link to post
Share on other sites
could be various issues with it..piston head could of cracked..or the piston itself might need some need rings (but if the compression is at 0 i think its not going to be cheap to fix)...good luck with it...got any more info on it like miles and so on??

Exactly...zero compression is an issue...may need a new engine.

* Added issue into thread title.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Hondasher
      I have a 2004 Polaris Trail Boss 330 and I want to eventually fix it up if possible, but the thing is the transmission or Gearbox that allows you to shift into forward and reverse and such isn't connect to the engine at all, it isn't even bolted into the frame. Anyways the Secondary Driven clutch is missing. The ignition was busted so I switched it out and tried to hook up power to it and the lights wouldn't light up and it wouldn't try to let me start it with the electric starter. 
       
      So I bridged the connectors on the starter solenoid and it cranks the motor. I was wondering if anyone knew why the dash lights don't work or any of the buttons. I did find a cable disconnected I have a picture of maybe someone can tell me what it's supposed to be connected to. It has 3 wires going to the connect Green Purple Red. I'll enclose a picture of it and where it is connected on the wiring harness. 
       


    • By Rich1028
      Hitting the Trail in the Morning.
       
      Heading out to Leota Trails 
      It's the Wife's Birthday Weekend,and I asked Her what,or where she wanted to go,she said  she wanted to go riding trails!
       
       
    • By dee004
      Hey all. Anyone have any ideas of fabricating an air snorkel for a 2005 TRX500FM and all venting extensions required as well? Thanks in advance Don
    • By Dwight Williams
      Ok, so I bought this scream of a deal the other day - a 94 King Quad 300 for $40.00.  It's been sitting outside with no carburetor on it for about a year.  Its rusty, missing some parts, wiring is all cut up and spliced etc.  No seat, no racks but the plastic is all there minus the headlight housing.  Anyway, who can pass up a $40.00 quad right?  I get it home and looked at the sight glass for oil level, it's about 1/2 oil and 1/2 water.  I drain it, refill it and turn the motor by hand (recoil starter is missing) and it turns over just fine.  I worked on the wiring for about an hour and got it to turn over with the electric starter and got enough of it sorted out to get a spark.  Did a quick compression test, 70 lbs.  Wet test bumped it up to 90.  Ok, so rings and cylinder washed out with water for a year, not too surprised.  I thought 'what the hell' and sprayed some starting fluid in it and it ran for about 2 seconds - enough to show  it's got life.  Since then the compression has gotten worse, I can't get enough pressure to activate the carb diaphragm, therefore no fuel pump either.  The compression is now around 60.
        Anyway, my question is....is it worth it to try to get this thing going?  I tore the top end down today and the cam and one of the rockers is pretty worn.  I figured a top end job would be about $100 or so, depending on the condition of the cylinder but I'll probably have to put a cam and rockers in it as well.  Doing some research on ebay I figure I'll have to spend about $500-$700 to make the whole machine right again.  Much less just to make it run and use as-is but I won't really like it until it's right.  I don't mind doing the work, I actually enjoy it but I'm concerned about what all that water did to the rest of the internals, I can't really test it all out until I can make it run.
      I know it's a basket case but I'm not into it much at all, even if I do the top end and find something else wrong I'm still not out much.  I'm leaning toward ordering the top end parts and going from there unless you can convince me otherwise - any way to check the rest of the internals without tearing it down?  I plan on flushing the oil cooler before I do another oil change, I've drained it twice now and it gets milky almost immediately just turning the starter - I suspect the oil cooler is polluted badly.
       
      I'll get some pictures today if anyone want to see them.
       
      thanks!
    • By Skhot K
      Hello! I picked up a YFM400 and I would love to talk shop with knowledgeable co-owners, and I'd love input about the machine from anyone here who clearly knows more than I do! Cheers from NY
  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By Kyboy
      Iam looking for help seperating the rear brake drum and the cover. Any suggestions would be greatly appreciate
    • By skgw1
      Feul pump went out. Replaced. At times quad cuts out like its not getting gas. Saw article on new pump needs to be calibrated. Told how to go into a service mode. Does not tell how to calibrate after going into mode. Can anyone shed light on this procedure.
    • By katasha2
      I took apart the carburator to clean out and I can't remember exactly where the springs that are inside the float are supposed to go I've tried to look up schematics but I think I am missing a spring maybe need helpt:confused::confused:
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...