Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

gfischer

need help with 4 mill crank setup banshee

Recommended Posts

I have yamaha banshee 1996 it has a hot rod 4 mill crank with wiseco 513MO6550 prolite piston.It has a ADA Racing 21cc Domes cut 2 mills and no spacer plate under jugs. Jugs are stock ported It is running about 190 psi in each. the squist in ea. is .048. What can I do to bring down the compression to run pump gas? thank you George F.

Share this post


Link to post
Share on other sites


Contact ADA and see if you can get new un-cut domes, that would be the best thing to do. You could call Cometic gasket and have them make you some base gaskets that are 2mm thicker than stock, but that would throw your port timing off quite a bit and might make it run like crap.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Mike Hooper
      Hi everyone! I'm from New Zealand, and doing up a Suzuki Lt50 for the kids. This is the first bike I've ever worked on, and it's currently not running. Hoping that both Google and this forum will get me through! Haha

    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
    • By Eddie Rahm
      Hey fellas...I'm trying to install the rear left axle..there's  a bolt running through the end of the axle that goes in the hole where you slide the axle in...I'm having a hard time getting the bolt started on the threads..I was hoping to start it with my fingers and than finish it with an open ended wrench...its very hard to do because it's such a tight spot..has anyone ever done this job before ? Any help would really be appreciated..thanks Ed
    • By dgk_mike
      It will go into neutral, 1st, 2nd, and reverse but nothing after 2nd gear. The shifter moves freely going up completely nothing but when you shift down it works. I’m not sure if it’s tranny issue worth messing with or if I should just buy a new one.  Overall besides that the thing runs like new.

    • By StolenATV
      Taken from my car port around 0330 and was taken by at least 2 people found footprints pushing the quad all the way to the road (80 yards)
      The post 2012 Yamaha Grizzly 700 EFI 4×4 Stolen appeared first on STOLEN 911.
      View the full article
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...