Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

oldriverharleyman

New Member with 2009 Artic Cat 550 H1 TRV

Recommended Posts

Howdy from Texas! First post. Looking forward to reading more on the forum.

Bought this ATV in Oct 2008....primarily cause GF and I hunt together. Even more, we both like riding together, so this was the perfect setup. Bike's performed flawlessly since day 1....until today.

Went to put it on the trailer to go to the camp....it'd been a while since I'd done more than crank it. Took it down the road to make a short run....make sure everything works ok....and it just died. Will 'crank'...once n a while it'll start....but wont run long...a couple of seconds. The speedo will go blank (flash)....then come back on. Gut feeling is telling me probably the battery is weak...or has a dead cell. Ive got it charging right now.....if it cranks and runs after that.....I feel pretty confident that's the problem.

Any ideas? Comments or suggestions will be greatly appreciated.

Share this post


Link to post
Share on other sites


Sounds like the battery went dead on you are it has a dead cell. After charging it you will know. It is not unusual for a battery to just go. I got lucky with mine as the pod would flash "volt" on it and it was slow cranking. I replaced it with an aftermarket battery and its been great ever since.

Mike

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ryan Geiler
      New to the ATV world, picked up a solid used Kodiak 400.  It appears the former owner did some sort of modification for a saddle bag or something along those lines--and I'd like to match it up and replace it.  Not a big deal by any means but something I thought I would give a shot at finding.
      does anyone recognize what kind of luggage/bag/cargo would go where those white tabs are he drilled through that fuel fender?
       
      Thanks again

    • By benwheeler
      Hi all, 
      Just joined up with premium membership.  I wish to download a service manual or 2 (specifically the Polaris 110 EFI manual).   I paid for the membership, but when I try to download it says it's not available to me.  I know I haven't posted anything until now, but I thought the premium membership gave instant access to downloads.     Not sure what I'm doing wrong?  
      Thanks!
       
      Bill 
    • By Travis Mitchel
      Hello all just recently acquired this atv which as you can see in the pics that it has had an unsheltered life. i did get it running and put some used tires on the front.
      It still needs a bit more well needed maintenance, chains tightened and oiled. needs an airbox or air cleaner and other misc items.


    • By Ryan Lewis
      Went on a great ride on Sunday from the M-33 trail head to the Lupton trailhead in the Huron National Forest.

      More videos from the ride to be uploaded to the channel soon.
       
    • By johncb
      Looking for some answers, my brothers 06 outlander max xt 400 once in a while gets jerky when riding it. Does anyone have any ideas what to start looking at first.
  • Similar Tagged Content

    • By Cobra_GT
      What’s up people I am new to the forum and am glad to be here. I have been into bikes for oh I guess 40+ years or so. I haven’t had one in a while but my 27-year-old son has always wanted a Banshee and he finally got one and the guy he bought it from had two of them. I almost bought the second one but I did not want to spend the next month on the sofa. So he had a LT-Z 400 Suzuki and I picked it up for $800, I could not pass that deal up. We could have bought both Banshee for $7000 as he wanted $7900 for both of them. But He wanted $4200 and was not budging for the one my son bought and $1400 for the Z400 and we got both of them for $5000. He wanted $4200 for the Banshee so I got the Z400 for $800, a steal. Anyway it’s good to be here. Peace.
    • By gregj49
      Blows out black smoke when you rev it up how do you adjust the carb?
    • By Billie
      :confused:need a repair manual or help in what to look for thank you Bill
      for you muddober to make clear to you the neutral light and the gear light
      do not light up win shifting fuses are good Iuse my CAt for hunting im dissable the atv is my leag s thank you
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...