Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Chriswe2009

2008 Sportsman 500 EFI w/ key on, no lights/ won’t start… has new battery? Need help

Recommended Posts

My 2008 sportsman 500 EFI won’t show any signs of starting. I have replaced the battery, when I turn the key on…nothing, just like a dead battery? Any suggestions what could be wrong?

Thanks

Share this post


Link to post
Share on other sites


Check and trace the wires going to your key switch. Check the ground at negative side of the battery. I'm sure more people will have more ideas... Welcome to the site.

Share this post


Link to post
Share on other sites

Electrical switches don't work when the contacts get too dirty. I can't tell you how many times I have fixed someones power windows or lights/blinkers just by taking the switch apart and cleaning the contacts inside. If all the wiring seems ok, and power is getting to the key switch, but not coming out of it, try taking it apart and cleaning it up, or, just replace it. If power is coming out of the switch, check for power on the low current trigger wire at the solenoid. If there is power, the problem lies in the starter or solenoid. If there isn't power, then the problem is in the wire between the solenoid and the key switch. Good luck.

Share this post


Link to post
Share on other sites

I'm not exactly sure but I belive that I read somewhere that the EFI models have a circuit breaker under the seat somewhere. I think it`s also wraped up in rubber or plastic.

Share this post


Link to post
Share on other sites


They could be under the hood too. Sometimes the protective wrapping gets water inside and corrodes the hell out of them. I belive there are three of them, 2 run the electrical system and the third one works the 12 acc plug.

They look like this...

[ATTACH]571[/ATTACH]

20 amp breaker goes to the ignition switch and the other 20 amp breaker to the fan switch.

1000936wj9.jpg.3a41a39d8ed896629a130c6f73cffe15.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By colin james
      View File 2017-2019 sportsman 450/570 with eps factory service manual
      This  is the factory service manual for the 2017-2019 factory service manual for the sportsman 450/570 with electronic power steering 
       
      Submitter colin james Submitted 09/06/2018 Category Polaris ATV  
    • By technofarmer
      Well its finally happened, its time to replace the belt on my 2011 Polaris Sportsman 500 H.O.   Is there anything specific i need to know before getting into it? Is there one brand of belt i should get over another?   I'm still on my first Polaris and plan to keep it at least another 8 years.   
    • By bodon
      I have a 2011 850 Sportsman.  Has been absolutely trouble free except for 1 thing. I am on my 4th. ignition switch. I don't know if it's that they are all chinese junk or what.  It gets to a point  when you turn the key and it will act like the battery is going bad. Cranks real slow or not at all. Put a new switch in and its fine. New one will last 1 1/2 - 2 years and its junk. I've had the Polaris brand and after market. As a matter of fact the original one lasted the lest amount of time.  Other than that it's been a perfect machine . No electrical problems. No battery problems. Just curious if anyone else has had the same issue.
    • By marek porowski
      I was wondering if I can get any tips on maintenance. This is my first quad so I don’t have any experience with them. Is there some kind of a routine that I should keep doing every certain hounded of kilometers ? 
      My Polaris has 1200 km on it and I got it from auction so I have no idea what was done to it. I changed the engine oil And filter so far and I’m planning to change transmission fluid and front and rear differential. 
       
    • By Barry Troxtell
      I have a 2005 Sportsman 500, Instrument cluster will not illuminate, hi/lo beams work though.  Any tips or troubleshooting info is greatly appreciated!
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...