Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

illinois1

2007 Yamaha Rhino dash display not working

Recommended Posts

ele. dash has indiglo ligt working but no digatal read out took it out put it in a friends machine it works fine tried a diffrent cdi box still not working

Share this post


Link to post
Share on other sites


I don't think your CDI box is the problem, I would be more suspect of a loose connection or bad ground wire. Perhaps a fualty sensor. I am moving this to the UTV forum and changing the thread title a bit. Also, what engine size do you have? We would like that to be added to the thread title as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Scott Sirr
      I need to figure out how to clean/fix or replace my neutral switch assembly On my 2008 Yamaha big bear 400 as generally the neutral light doesn’t come on when it is in neutral. To get it to come on I have to wiggle the foot shifter and hold it in just the right spot.
      I have googled it and can’t find much on the 400’s. I can’t find a service manual online and the parts manual is super vague.
      I think it is in the right side engine cover area, but not certain. 
       Any help would be great. thanks
      Scott
    • By Sturgeon
      Hello everyone, did a search and not successful. Purchased new 2017 Sportsman 570 sp and my power steering is not working. Seems to have a mind of it's own. Works then it doesn't. Dealer says there's not a fix. Thought it was just me and it being a brand new machine with 4 hours on it. Dealership said it's this model only ? Not sure what a person in this spot is suppose to do and wondering are your thoughts mite be. Thanks 
    • By Rinconrecker
      RZR 2 for 2
      1st - Dry Pull Suzuki Samuri @ River Ranch


      2nd - Dry Pull Jeep CJ7 @ Rancho


      Who's next? coming for ya!!!

    • By David Terzian
      Hi, Name is Dave, I am new to the site. I have UTV 2018 Textron Stampede... cant get the 4 wheel drive to work.
      I recently had blown out the fuse for the acc... while hooking up my turn signals,,, and ever since then
      4 wheel drive doesn't work, I can lock in the rear,,, while having the key on motor off,, I can hear the clicking
      sound,, which sounds like a relay in the rear... but when I switch to 4 wheel drive, I hear nothing. shows up on
      the dash that its working, anyone can help would be greatly appreciated. All Fuses and relays under hood are
      good, and under rear seat. Thanks  Dave 
    • By Stacy Hanks
      I have  2000 Yamaha bear tracker 250 - igniton relay and starter relay both were replaced also the neutral switch indicator was replaced-- bike will not show light on for neutral or start when button is pushed
       
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...