Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

tbam

Need engine for 500 4x4 2004 model

Recommended Posts



If you are looking for a used engine, I think ebay might be your best bet. Just make sure you only buy from a reputable seller.

Share this post


Link to post
Share on other sites

Artic Cat uses Suzuki engines in alot of their ATV and Snomobiles. You might want to extend your search to include Suzuki Vinson 500 motors. As far as I know, the Vinson auto (LT-A500) uses the same motor as the AC 500 auto, and the Vinson manual (LT-F500) uses the same motor as the AC 500 auto. Do your research to make sure I am right, and check for interchangeability between years.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Mike Iadonixi
      Hi my son's 2005 Honda recon engine is seized any ideas on what or where to get another engine 
      Thanks to you guys i fixed my other son's four wheeler last month
      any help would be greatly appreciated
      Thanks
      Mike
    • By Christopher Middleton
      I was given a "Go-Kart" its an old Carter brothers dlx150 but the engine is not the same that came with this Kart. I am trying to ID it so i can look at getting some parts for it. the pictures attached are of the motor and the only ID marks on it. I am thinking its some sort of 200cc from the 1980's does anyone have a better Idea? I am really trying to get a rebuild kit for the carburetor. on the carburetor is  Keihin 63 AA YKT

    • By weblex
      Problem: The ATV starts and runs at idle perfectly. But as soon as I open the throttle, the engine starts to slow down until it stops. On the attached video you can hear the sound of how it works: see video below
      Prehistory: there is a Polaris Sportsman 500 1998, which for about 1.5 years stood in repair, including also replacing CDI with one taken from the same ATV. Finally, the vehicles were on wheels, traveled several kilometers and overheated - forgot to fill the antifreeze Came back home in small moves. The next trip started well, but after 10 km there was a feeling of a small drop in power (even as the vehicle got warm completely) but still drives. Next trip - the situation is repeated. The next test of ATV through time and a huge loss of power from the very beginning. The engine sneezes, does not want to go more than 5 mph.

      What has been done: the carburetor has been replaced with a new one (inexpensive, $ 40), a new spark plug, a new ignition coil, the engine head has been removed, the piston is in good condition, valves were corrected - but the problem was definitely not in them.

      Ignition control unit is suspected. Who faced similar? Please help in solving the problem.
      Thanks in advance.
       
       
    • By ezduzit
      picking up atv tomorrow, guys says motor is locked up. he thinks, anyway has been sitting for more than three years. Please understand i have not touched it yet but if his description is accurate im looking for suggestions on freeing it up before  having to tear it down. I'm hoping to get some great info from the pros on Quadcrazy.
    • By Eddie Lambert
      So I picked up a Cannibal that has been sitting for many years. I wonder if anyone can tell me where that vacuum port is on the engine. I’ve found the one to the air box, pressure regulator, and ecu but can’t seem to locate the one on the engine. Thanks in advance for any help. 

  • Similar Tagged Content

    • By Trenton
      Hello. I am a new member as of today. I had a quick question to ask. I recently was driving mt HONDA RANCHER 2004 GPSscape 400 and my display stopped working. I was driving the atv and all of a sudden the speedometer and the service lights went out. Also the lights stopped working. I am still able to shift gears, change from 2wd to 4wd, and can still select if I want EPS or Auto. I have checked my fuse box and have changed a few of them around. It did not change anything. I was wondering if anyone had any idea of what had happend. Thank you for your time- Trenton 
    • By LTZ-Zach
      So i was riding the other day and my quad randomly shut off. It started back up and ran completely fine for a little while and then it started idling terribly.
      I cleaned the carb and changed all the jets and everything except the float due to the rebuild kit not coming with one and it actually runs worse then it did before.
      It will run and idle decent now but when I give it gas it dies.
      Does anybody know what could be wrong?
      I also changed the spark plug and air filter along with the oil and oil filter.
       
    • By gregj49
      Blows out black smoke when you rev it up how do you adjust the carb?
    • By M0BJT
      Hi Everyone
      This is my first post and I was wondering if there is anyone who can help me solve a problem I have with my Yamaha Kodiak 400 4x4 Fitted with a Mikuni Carburetor . The year of the quad is around 1998, the reason I am not sure of the date is, there wasn't any paperwork and no details on the frame either.
      The quad had a bad leak from the carb overflow which indicated that the float needle valve was blocked or passing so I replaced this and put everything back together. The quad ran really well until I took it onto some rough ground to have a ride around, a few hours later the engine started to run really rough as if the engine was flooding. I have removed the carb again and cleaned the needle valve out and the whole of the carb just in case there where any dirt behind it. Engine now runs fine again but fuel has started to run out the carb overflow again.
      I have tried everything to try and stop the fuel leaking out the overflow but its still happening. My last thoughts where to adjust the float level and its still happening.
      Has anyone got any thoughts on the problem or could suggest whats causing the fuel leaking out the overflow.
      Thanks for reading
      Kevin
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...