Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

klarson

2005 Suzuki Vinsion 500, stalls when i give it gas

Recommended Posts

My fourwheeler has always ran fine, but the other night when i was using it i shut it off and than started it back up a hour later and it started running terrible as soon as you give it gas. You can feather it along if the choke is on but still not running very good. any ideas????

Share this post


Link to post
Share on other sites


First thing I would try is draining the fuel and starting with fresh gas, you may just have some bad gas. I am assuming that the quad starts and idles fine, but as soon as you give it gas it runs like crap. If none of the other advise has helped, take the top off of the carb and look inside. Make sure that the spring, retainer and needle are all as they should be. I have seen problems with these carbs with the floating slide. The needle retainer breaks and slips up into the spring and doesn't hold the needle down anymore. So when you give it gas, the butterfly valve opens letting air throught the venturi, which lifts the slide valve. Since the needle may not be sitting in the proper position, it may be allowing the main jet to open too early, flooding the engine. If every thing looks ok in the top of the carb, take the float bowl off and make sure there is no debris in the carb pluggin things up.

Share this post


Link to post
Share on other sites

if you are running on reserve then there is a chance that the fuel filter is plugging up in the tank or your tank is actually lower and ther is not enough fuel supply to run the throttle. i agree with DD and drain the fuel system and clean the crap out of the tank, fuel pump, fuel filter. if that does not help then pull the carb out and clean it.

your friendly neighbourhood mechanic.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Flipper Tiffany Roper Jones
      All I have been through everything. Bought brand new.
      Throttle safety switch 
      Cam and rockers
      ECM
      Carborator
      Stator
      Fuel safety switch 
      Battery
      Everything every forum has spoken of I've bought sealed airbox completely tight unplugged black wire on trans. I have literally done everything in the book.Checked oil today full of gas anyone no anything what might b wrong. Next I'm taking head off and making sure valves seat any ideas.
    • By Shook
      Hi I have a 2000 big bear 400 and i just put a new carburetor on it and it idles fine but when you try to accelerate it sounds like it is going to die, so when it sounds like it is going to die I will give it more throttle then it will go just fine.
    • By Lank Firdmont
      I have seen other posts and I'm not ableto download resources.
      I was gifted a Yamaha TerraPro and can find 0 online for help getting this running.
    • By Freezeman
      Thought i would share a fix that I came across. I was working on a 99 scambler 500, The customer complaint was that even with the fuel shut off the tank would slowly drain out onto the ground. First I found the fuel shut off was bad/ leaking/ dripping so I installed a new one thinking that would fix it. Then I ran it and and seen that the overflow was flowing fuel out from the bowl. So I cleaned the needle and seat and changed the float height to lower the fuel level in the bowl. Well... It still overflowed and flooded. So I bench tested the needle and seat with a pop off tester. I found that these newer style needle and seats just utilize an o-ring to install the brass seat into the carb.
      The o-ring for the seat had hardened up allowing fuel into the float bowl from under the seat. New o-ring and problems solved.  
       
        
    • By Steve Howard
      Ran find shut down the quad next day would start and idle when you try to accelerate it would start popping through the carb got a rebuild kit soaked it in chem clean after break down for 12 hours on slow vibrate reassembled and adjusted per manual still the same thing any help would be really appreciated thanks and happy ridding  
  • Similar Tagged Content

    • By oxidized_black
      tag : zukifreak
       
       
       
    • By LMI
      Was using the quad the other day to shuttle wood from my pickup to my wood pile.  When the job was done I turned off the Quad and heard a bit of a racket from the front end.  When I got down underneath the sound seemed to be coming from the fan housing.  fan was moving in spurts and not quickly... much like a computer case fan that's had it's day.  What I know.
      Temp sensor is ok, as the fan tries to activate fan is getting some voltage as it is attempting to spin.  When I first bought it used I tested the fan direct to battery and it was fine. The fan was working ok even not direct wired as I went on a couple of rides and when stopped and idling the fan did run Seems to be free spinning with my finger read up in the manual and they require me to drop the rad.  now I'm not opposed to that as the rad has some damaged areas I want to try and straighten out.  But if I can get the fan working without, I can leave the rad as it is until next year.
      Fan assembly is about 300 bills, any work arounds or alternatives?  I even thought large computer case brushless fan.  smaller ones are about $7 larger ones better quality probably far below the 300.  They run standard 12v DC.
      Anything I should be doing before dropping the rad... other than check for obstructions even though it seems to spin, and trying to hardwire it to the battery again for a test to see if it acts the same?
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By bradleyheathhays
      Life got the best of me this year and to make a long story short my '11 Grizz 700 has a half tank of gas (w/ no stabilizer) and hasn't been started for around 9 or 10 months. I have apologized to it and promised this will never happen again, but in the meantime I'm faced with what to do to remedy the problem. Ideally I suppose I should get the tank off and drain the gas, replacing with non-EtOH gas (which thankfully I just found in my area).
      Any advice on how to get this done (draining the tank) or how difficult it might be?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...