Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

toadman

2005 Suzuki Eiger LT-A400F Repair Manual Needed

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Frank Angerano
      So i took a road trip today to look at a Suzuki Eiger! 2006 in perfect condition other then the fact it starts for 30 seconds and shuts down.  
      Its been sitting for about a year in a shed. 
      It has a plow and a winch included!!!
      Got it for a really good price and all looks good so far.  
       
      Stay tuned.  





    • By Ryan Foster
      I am trying to find a used OEM cylinder for the above mentioned quad. I was told the current cylinder came from Amazon so I suspect its aftermarket china (made from recycled coat hangers and shopping carts.) Anyway, was looking at the parts list and they have 2 cylinders listed..
      11210-19B82-0F0
      MODEL X/Y
      and..
      11210-19B90-0F0
      MODEL K1/K2

      My engine case is stamped K403 230829 Trying to figure out what model I have. I see I have a K in there but....
      I don't know what the differences are between the cylinders (the first one cost more). Anybody know how to decipher this?
      I only have the engine, I don't have the frame to get the actual VIN.  

      Also, are there any marks on an OEM cylinder to differentiate it from aftermarket?
       
    • By Mike Hooper
      Hi everyone! I'm from New Zealand, and doing up a Suzuki Lt50 for the kids. This is the first bike I've ever worked on, and it's currently not running. Hoping that both Google and this forum will get me through! Haha

    • By Amazon Ads
      Where do you buy your ATV parts? Did you know that Amazon has ATV parts in stock for immediate delivery? You'll find all the best ATV parts and for great prices! Check out all the ATV parts available with free 2 day shipping now...
    • By cliffyh
      Hi,
      Have a 2005 grizzly 660. Just recently started backfiring and showing incorrect speed. Lifted seat and messed with wire going to starter relay, it stops for a bit but seems to come back.
      I ended up pulling all the pins out of the connector for the relay and added new pin/connectors for all 4 wires. fixed it for a little bit but came back shortly after. This was a new starter relay i installed a few months ago. Anyone know if a bad starter relay would do this? 
  • Similar Tagged Content

    • By Michael Aiken
      Where can I find a wiring diagram for my 2005 450 Kodiak. Thanks.
    • By Mo Salem
      So my front hub broke, I’d like to put aftermarket on. Hard to find new oe ones. Please help. I’m new to all of this, I have some car knowledge and try to apply it
    • By oxidized_black
      tag : zukifreak
       
       
       
    • By LMI
      Was using the quad the other day to shuttle wood from my pickup to my wood pile.  When the job was done I turned off the Quad and heard a bit of a racket from the front end.  When I got down underneath the sound seemed to be coming from the fan housing.  fan was moving in spurts and not quickly... much like a computer case fan that's had it's day.  What I know.
      Temp sensor is ok, as the fan tries to activate fan is getting some voltage as it is attempting to spin.  When I first bought it used I tested the fan direct to battery and it was fine. The fan was working ok even not direct wired as I went on a couple of rides and when stopped and idling the fan did run Seems to be free spinning with my finger read up in the manual and they require me to drop the rad.  now I'm not opposed to that as the rad has some damaged areas I want to try and straighten out.  But if I can get the fan working without, I can leave the rad as it is until next year.
      Fan assembly is about 300 bills, any work arounds or alternatives?  I even thought large computer case brushless fan.  smaller ones are about $7 larger ones better quality probably far below the 300.  They run standard 12v DC.
      Anything I should be doing before dropping the rad... other than check for obstructions even though it seems to spin, and trying to hardwire it to the battery again for a test to see if it acts the same?
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...