Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Keywil

Hey All! New from Canada

Recommended Posts

Hey all, I'm new here from Ottawa Ontario. I have a 2009 550 Grizzly for hunting and funning. In the last year I've acquired an older Yamaha 225 Moto-4 for the wife and 2 Arctic Cat youth's (2005 - 50 and 2004 - 90 cc) for my daughters.

I've just started looking around to try and find places to ride - especially for families. Are there many ATV families out there?

Share this post


Link to post
Share on other sites


You'll find some folks, don't worry! WELCOME here!

I have several Canadian friends but they're all up BC way...

Share this post


Link to post
Share on other sites


Thanks for the welcome guys.

Polaris - thanks for the round eh! Where's Belle River?

I've been using ATV's for some time for moose and bird hunting. Recently in the past three years or so I have been introducing my daughters to hunting (grouse) and we just have a blast on the bike. Recently my brother gave me his old ATV (the one I moose hunted with for years - Kate is its name) for the wife and I got a good deal on a couple of youth ATV's for the girls. I got a trailer for the 4 bikes and now we're all set... just need some time... lol

We've done a bit of ATV'ing in a public forest south of Ottawa and will continue to explore other public access areas. I'll try to blog and post pics as we explore. May end up joining a local club here in Ontario or in Quebec. More investigation required... Merry Christmas folks.

Share this post


Link to post
Share on other sites

It's great to hear about a family getting into a few differant sports like you and yours. WoW four bikes and girls, damn you must have your hands full! lol

Belle River is in the armpit of Ontario right near Windsor.

Share this post


Link to post
Share on other sites


Hi Keywil from a fellow Canadian and moose hunter. I'm in Penticton B.C.. Good to see you here. I'm a newbie to this site too and the help i've received from the members on this site since i joined back in October is awesome and priceless. I'm sure you'll find whatever you're looking for right here.

Gary

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Stacy Hanks
      I have  2000 Yamaha bear tracker 250 - igniton relay and starter relay both were replaced also the neutral switch indicator was replaced-- bike will not show light on for neutral or start when button is pushed
       
    • By Tahj
      Do I need to remove the balancer driven gear to remove the timing chain.
      If so, how?
      Thanks

    • By Shook
      Hi I have a 2000 big bear 400 and i just put a new carburetor on it and it idles fine but when you try to accelerate it sounds like it is going to die, so when it sounds like it is going to die I will give it more throttle then it will go just fine.
    • By Dimelol
      I have a 2003 Kodiak 450 that i purchased a while back with around 300 hours on it. It has never ran right from the beginning. Initially i thought it was just a carburetor issue because it was all clogged up from sitting for months. It has been cleaned, rebuilt, and taken off probably about 10 times troubleshooting this problem. I have quadruple checked everything including float height ect and it is set correctly, the jets are also brand new, needle and seat have been pressure tested as well. So after all of that I am convinced that the carburetor is not the culprit. I have an issue where the idle is very choppy, almost as if it is misfiring with a rich condition on top of that. I can use a brand new plug and run the machine for just a few minutes and it will be a dry and and coated in black carbon build up. The exhaust also has a strong smell at idle. I had trouble restarting it when hot for a while, but i adjusted the valves and it seemed to solve that issue. They were both way out of tolerance (tight). The weird thing is, outside of idle it seems to run pretty well. 
      So with all that being said I have ruled out the carb/valves/compression and moved on to the ignition and this is where i have a few questions about factory specifications. I guess the main question I have is, how strict are these tolerances? And could them being off by this amount cause the issue I am having? Do all three of these parts really need to be replaced? I would like to know before I spend the money on these new parts, and it not fix my problem. Below I will list what the specs were in the service manual along with the reading i got.  This is my first experience testing ignition components. I just found it odd that all 3 are out of spec according to the service manual.
      Spark plug cap resistance: 10 kΩ at 20 °C (68 °F)
      My Reading: 8.90 kΩ
      Primary coil resistance: 0.18 ~ 0.28 Ω at 20 °C (68 °F)
      My Reading: Fluctuated between 0.4 - 0.5 Ω
      Secondary coil resistance: 6.32 ~ 9.48 kΩ at 20 °C (68 °F)
      Reading was within the specified range.
      Pickup coil resistance: 459 ~ 561 Ω at 20 °C (68 °F)
      Reading was within specified range.
      Rotor rotation direction sensing coil resistance: 0.085 ~ 0.105 Ω at 20 °C (68 °F) 
      My reading was 0.3 Ω
    • By Walter Awe
      I HAVE a 2002 big bear 400 4x4. I have two wires atacking to the front of the carb. What are they for?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...