Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

wbholoch

2008 Kazuma Jaguar 500

Recommended Posts

Hi I'm new to this forum and am searching for help.

I just bought a 2008 Kazuma Jaguar 500 (couldnt pass up the deal for the plow) and when I try to engage the electronic diff lock the ride stalls out flat.

anyone have any ideas? I have not even ran a test light from the switch to the diff yet just brought it home tonight.

thanks

Share this post


Link to post
Share on other sites


The only thing that makes sense to me is that you have a dead short in the wiring that powers the diff lock actuator, and it is grounding out the entire electrical system. I would inspect the wiring for damage or signs of tinkering by an idiot.

I am moving your thread to the Kazuma forum.

Share this post


Link to post
Share on other sites
The only thing that makes sense to me is that you have a dead short in the wiring that powers the diff lock actuator, and it is grounding out the entire electrical system. I would inspect the wiring for damage or signs of tinkering by an idiot.

I am moving your thread to the Kazuma forum.

Yes I'm on the same page here, sounds like a dead short, I had this problem once. I had broken wires to my ignition. Get busy with a test light, process of elimination, takes time but you'll find it.

Share this post


Link to post
Share on other sites

Can you help me with mine and send me a picture of your exhaust port that has hose port and feeds fuel pump, I bought mine and I think Im missing something

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By hornythrony
      Hey I have a 07 king 700 there's lots of times that the quad will stall when the fan turns on also have to bump motor 2 or 3 times before starting to start it (makes fuel pump go on 2/3 times) anyone having or had this issue?
    • By Dee Morris
      I bought my big bear in 2009, never had a bit of problem with it until last year. It quit starting but still would click when I tried to start it. I replaced the solenoid, the cdi module ( it was burned on one corner) and this year replaced the battery. I have all lights but still will not start and I do not have the clicking when I try to start it. Can anyone give me any ideas what to try next? I haven't had any luck finding videos about the 2008 Big Bear. I'm trying to avoid the expense of sending it to the shop. 
    • By Erik Plug
      Hi all,
       
      Picked up my first Brute Force yesterday. What should have been an awesome afternoon of riding turn a bit into a deception. As I was unable to really take it out for a test drive at the shop, I decided to buy it and agreed that I would take the test drive at home. 
      When giving full throttle I noticed that the Brute was choking and lost all of its powers. Faulty fuel pump most likely. 
      Called the shop and the are coming to pick it up and repair it and bring it back. Good service. Nevertheless feels a bit sour in the mouth as I was told it was a 100% good. 
      Need to have some patience I now before I can really start riding. 
      Cheers,
      Erik
    • By Ajmboy
      Got my Yamaha Grizzly buttoned up finally and went for a quick 2 hour ride in the power lines with my neighbor, who has a Yamaha Kodiak. We have access from his yard, which is nice. Was a beautiful day today to get out and will try to go more often. Ran into two other quad riders with a sportsman and I think grizzly. Also ran into a dirt bike rider. 😎




       
    • By Steve Bethany Poston
      I just got an old YFM200DX Moto 4 and upon checking the oil in the rear differential I took out I assume the fill plug and it fished out old nasty oil. I plan on flushing the oil and replacing but was wanting to make sure if you drain bottom plug and just fill up to the check plug. Only thing I can think of someone filled it up by the breather on top? Plan on unhooking the hose and blowing it out tomorrow. I also do not have a service manual yet. Also right now the diff vent hose just goes up under the tank to nothing. Does it plug into back hole in the air box? Thanks 
  • Similar Tagged Content

    • By Alois Specht
      Hi there , have a KAZUMA 500 JAGUAR the rear diff is permanently locked , how can I get it out of lock just about tried everything I think, ?? .  Thank you your help is appreciated.
       
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By colin james
      View File 1996-2000 Polaris Sportsman 335/500 Service Manual
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
      Submitter colin james Submitted 10/19/2018 Category Polaris ATV  
    • By colin james
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...