Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

dirtz564

Bombardier ds 650 electrical problem

Recommended Posts

I have a 2000 ds 650. Sometimes it will start sometimes it wont. when it does start it will only run for about 10 seconds and then it dies just like you hit the kill switch. Even if you hold the throttle at a higher rpm it sounds great till it dies. im sure it has to be electrical can anybody give me some feedback

Share this post


Link to post
Share on other sites


Get a repair manual and start testing ignition components, my best guess would be that you have a bad CDI box, but it could be alot of different things so you would be best off testing everything and checking for bad connections before you start buying parts. Good luck, these types of problems can be tough.

Share this post


Link to post
Share on other sites

thanks josh. I got a shop manual im gonna start going thru all the tests with a voltmeter. it is definatly electrical. It wouldnt even start tonight so I pulled the plugs and it would only spark one time when i hit the start button. Thanks for the feedback. I just wish they didnt make stuff so complicated. Whatever happened to the good ole days when it wouldnt start youd either pull it or coast start it and you was good to go.

Share this post


Link to post
Share on other sites

Check your battery, They have to have a good strong one to run. Don't over charge it no more than 2anp. If it's not that then it could be the voltage reg. Check voltage at the battery. If it's over 14+ it could be over charging.

Share this post


Link to post
Share on other sites

Thanks thebom. Yeah the battery was dead from sitting so long. I took the battery out of my Honda that I ride everyday and put it in. I'll check it though I'll try anything

Share this post


Link to post
Share on other sites


These bikes need a good #15 battery. I've seen them pop ans snap in the mid rpm and up with a low battery. The charging system won't wont run the bike by it's sefl.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Twilight228
      Good Morning All!,
      After a significant amount of reading and tinkering, I'm stumped.  We have a pair of Arctic Cat DVX 90s (4-stroke), and one of them runs very rich at wide open throttle.  I've cleaned the carb (which was installed new  last year), verified the main jet (80) to be per the original spec, installed a new air filter, tried a hotter spark plug (CR6HSA), and adjusted the valves (tightened a modest 0.0005" but improved starting).  The hotter spark plug may have help just a bit, but not appreciably.
      Just for fun, I swapped the CDI between machines, and that didn't help either.
      Fouling plugs very quickly, but not to the point the machine will not run or start.  [black instantly]
      Logically, I assume I'm revving out, but the other machine doesn't "stumble/blubber" anything like this one.
      Should I try a smaller main jet?
      Any ideas you guys may have would be much appreciated.
      Thanks in advance everyone.
    • By dave3dracing
      Hi, I'm a new member
      Just bought a used 08 350 raptor with about 5 hours on it ( very clean ). Started fine when we got it. Now after a few mods (bumper, skid plates, air filter) Now will not start unless you pull in the clutch. I've checked just about everything and also checked that there is no pinched wires. Anybody have any ideas?:bangheadc: Thanks, Dave
    • By payne
      Have an Bear Tracker 250. Dont have the manual or any literature to help with. Anyhow, starts with pull start in gear, and electric starter doesnt work. Also, neutral light doesnt come on. Where should I begin?? Need some direction on troubleshooting all this. Thanks a million.

    • By Steven Workman
      So I have a Honda Fourtrax 300 year 1988. The ignition doesn’t start it with no sound. The headlights won’t turn on. It has a brand new charged battery, fuses are good, oil is good, gas is good, reverse is rusted, it shifts good, won’t jumpstart but when you try it will turn over, it will start if you jump the solenoid give it gas and spray starter fluid on the breather but it won’t stay on long but will stay on for the little time it does by itself. I don’t know what’s wrong and I need help!
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...