Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

noelsherman

1995 Suzuki King Quad 300 Fuel Flooding

Recommended Posts

im having problems with my quad flooding out. i have cleaned the carb,petcok, fuel lines then once its running i can take the vacume line off from the petcok to the carb and it runs 100 times better but as soon as i connect the hose it sucks gas and chokes out the bike can anyone help please.

Share this post


Link to post
Share on other sites


Do you have your vacuum lines connected properly?

* Edited thread title, added issue and manufacturer. Removed other thread as it is a duplicate issue with this one.

Share this post


Link to post
Share on other sites

the small line going to fuel pump is connected to the plastic nipple on the carb, the line off the petcoc is going to the metal nipple on top of the carb

Share this post


Link to post
Share on other sites

Are you saying that fuel is entering the vacuum hose when you hook it up? Sounds like you have a bad petcock. Since you say it runs fine without the vacuum line attatched, it seems like the easiest thing to do would be to install a manual fuel valve in place of the vacuum operated petcock, and block of the vacuum line. Or you could just get a new petcock, but they are expensive. I believe there are models of that machine in the same year that use a regular manual style petcock.

Share this post


Link to post
Share on other sites
Are you saying that fuel is entering the vacuum hose when you hook it up? Sounds like you have a bad petcock. Since you say it runs fine without the vacuum line attatched, it seems like the easiest thing to do would be to install a manual fuel valve in place of the vacuum operated petcock, and block of the vacuum line. Or you could just get a new petcock, but they are expensive. I believe there are models of that machine in the same year that use a regular manual style petcock.

dirtdemon is right:biggrin:. i had this happen to me. the diaphragm breaks inside. just block off the vacuum line, you don't need it. the primary pump is good enough. or when your starting after adding new gas to an empty tank just blow into the tank a little.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Billy Aldrich
      2001 Honda foreman 450s manual shift. i can shift through the gears when the ATV is off, but when I turn it on, I can shift into first, but I cannot shift to second or even back to neutral. Same with reverse. I can get it into reverse but cannot shift out. If i turn it off it will shift back fine, any idea? I just bought this and fear I got screwed over. 
    • By Rich1028
      Leota Quad Trails
      4-5-20
       
       
    • By LOGAN WARNER
      Hello everyone, I’m new to this forum. I have a 98 king quad 300, I cannot get it to run right. It will start up and run for a little bit but then it starts sputtering when you give it throttle. It appears to me that it is getting to much fuel. 
      this is what I have done to it: new carburetor, new fuel filter, adjusted the valves.
    • By Amboyjim
      Having serious problems with quad it completely stopped running on me took carb off and tore apart cleaned everything put back on and it started idled but when driving it had no power at all so took carb back off and noticed their was a puddle of gas and oil in the bottom of the air filter box and also their was gas in the vacuum line HELP
  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By skgw1
      Feul pump went out. Replaced. At times quad cuts out like its not getting gas. Saw article on new pump needs to be calibrated. Told how to go into a service mode. Does not tell how to calibrate after going into mode. Can anyone shed light on this procedure.
    • By katasha2
      I took apart the carburator to clean out and I can't remember exactly where the springs that are inside the float are supposed to go I've tried to look up schematics but I think I am missing a spring maybe need helpt:confused::confused:
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...