Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

crx686

2003 Yamaha Raptor 660 Backfiring

Recommended Posts

Hello

I have a Yahama Raptor 660 2003. I bought from my friend it wasn't working when i bought it. All I did was take the carb out and cleaned it, then took the two bowels out and cleaned that. Once I did that then it started. But when you rev it up it back fires and sounds like it has a hard time keeping up, sounds like its going to die. but it sounds fine when at idling. Kinda of wondering if the carb needs to be rebuilt or if there's something elese wrong. If anyone can help that would be great. Thanks for your time.

Share this post


Link to post
Share on other sites


Also I forgot to mention. The only way to start it is with the choke on, once its warmed up I turn the choke off and the thing dies, also when you rev up it just back fires, sounds like it trying to rev.

Share this post


Link to post
Share on other sites

Sounds like it's fuel starved. Has it ever been jetted before? Some carbs get corroded inside around the float pin needle, causing the float to not operate quick enough. Pull the carb bowl off and tap that float to make sure it moves freely.

* Added year to thread title.

Share this post


Link to post
Share on other sites

I did take both bowels off and cleaned and made sure float was moving, I don't think its been jetted before I think a rebuild might fixs it? Right?

Share this post


Link to post
Share on other sites

It's possible if one of the jets is clogged or something like that.

Share this post


Link to post
Share on other sites


the only thing that will cause a backfire is a to lean issue. to much fuel will flood it. the choke adds fuel to the system. i would completely clean and rebuild the carb. also the fuel pump could be causing a slight issue if it is dirty or dry.

Share this post


Link to post
Share on other sites

if ur parking brake switch is sticking,it can also cause your raptor to back fire and sputter,on will run like crap when you try to ride it

Share this post


Link to post
Share on other sites

I'm going to rebuild the carb to see what happens. On the brakes there is a wire that is broken. Looks like it clips in there I put it back in it doesn't really do anything. I'll let you know what happens after i rebuild the carb Thanks for you help

Share this post


Link to post
Share on other sites

don't rebuild anything if u not sure. make some pictures i didn't see any pictures its too many models and setting for carburetors make pictures ask question which screw to adjust. show what u done then we can solve problems easel e in no time.

Share this post


Link to post
Share on other sites


I already know that everything is is working or it wouldn't start up on the choke. I'm pretty sure it is the carb being gummed up and not adjust right, its been sitting for a at least 8 months. plus the carb is not in a easy place to work on, its kinda of in there. Also I was thinking of rebuilding it myself but ive really never done it. What screws you talking about? the air/fuel mixture? I was just thinking if i got it rebuilt then i know everything is working in the carb.

Edited by crx686

Share this post


Link to post
Share on other sites

before you get dirty picture everything take apart its easy put together is half of way but to adjust for best performance i don't think u have patience to get skills

Share this post


Link to post
Share on other sites

I already took the carb in. I don't have time to take a bunch of pics and mess with it.

Share this post


Link to post
Share on other sites

my parking brake safty switch was my problem ,sounds like what you described. it took me forever to figure it out, after i did it started doing the same thing only to find out if the tank isnt1/2 full my raptor wont run ? still puzzled by this but i fill it up and runs like a champ. i get below 1/2 tank and it fall's off.

Share this post


Link to post
Share on other sites

I got my carb back and I put it back, the thing runs good nice sound. I do have a brake safety switch on order, I learned that mine was missing. which is werid cause I was riding it right after i got the carb then 10 mins later it wouldn't work right. I just want to say thanks for your guys help. you pointed me in the right direction. Thanks again you guys

P.S. redneckyankee your fuel problem could it be the gas cap. Cause like mine its gravity feed in and if it can't breath its going to restricted the flow of gas getting to the carb when the gas gets lower correct?

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By K L Buck Naff
      Trying to replace the carburetor on my 2003 Bear Tracker 250. Two brand new carbs in a row from different suppliers.   Both leak fuel out over flow and intake as soon as I turn the gas on. Any ideas. Am I doing something wrong?
    • By Daryl Mann
      Hey new to the page 
      having an issue with my carb slider jamming ect just replaced the carb with a good pre owned unit and seem to be having a similar issue 
      is there a home fix for this as a posed to buying yet another carb as the quads my daily transport and stuck without it 
      thanks for looking any help great full can also forward video of the problem I’m having if needed 


    • By Rich1028
      Looking at maybe getting A Raptor 700R  in 2020

      Was looking to see of anyone in here has one,had one,can you tell me your likes,dislikes,and so on!
    • By dany desbiens
      Hello i have a Polaris 2003 sportsman 600 Polaris Sportsman OEM Gauge Speedo Speedometer Display Dash Cluster 3280425 the speedo is not working no 4*4 i can find nothing can i put a speedo 2004Speedometer Gauge Speedo
      3280431 04-08 Sportsman if it will work
    • By Venom
      Hi All,
      I did a total restoration on a 2003 Yamaha Raptor 80. Rebuilt the engine and tranny.. Started it up today and it runs great. Took it for a ride and the transmission worked perfectly. Adjusted the carb a little more and went for another ride. It ran awesome, pulled into the workshop shifted into neutral ( Neutral light came on) and shut off the bike. went to roll it and noticed she would not roll. Turned on the key and neutral light was on... After some troubleshooting I found that she is in first gear with the neutral light on and will not shift into neutral... It seems to up shift fine into 2nd and 3rd and then back down to 1st. I am hoping somebody can shed some light on what is happening... Thanks for any help...

  • Similar Tagged Content

    • By Ron Boyd
      I was wondering if the complete headlight assembly from a 06 yfz450 would fit my 05 raptor 660r looking for a quick responses I found a set new for 25 bucks and either way dont want to pass up but was qurious.
    • By Brian Simmons
      I put on a new stater  , How would my Yamaha raptor 350 act if the starter clutch went out ??? Please help !!! There is no metal in oil . Its like when you hit the starter button nothing ? Any ideas ???
       
    • By amelia slabbert
      Hi I have a YAMAHA RAPTOR 660R 2003
      I have taken of my Air filter and sprayed in my air inlet some carberator cleaner while starting it. That causes some problems. It struggles to start now. Please look at my attachedment video. 
      What can I do now.? 
      MOV_1402.mp4 MOV_1401.mp4
    • By orvilleortiz538
      Hey Frank I posted some pictures of my stator from my Raptor660r and I need some help,here are some pics of the numbers I got from the stator the 494 is ok,that's from the white/red & white/green wires but from the white to white I was getting no reading and from the blue and red wires also no reading, so it's most likely done right?


      Sent from my SM-N950U1 using Tapatalk
       
    • By Ankromsathome
      Purchased a 2008 Yamaha Raptor 250 for my son about 1 year ago and have been having problems with the starting system ever since.
      Since owning for one year we have gone thru 2 starters and 2 starter gears. Now its spring 2019 and time for a third replacement. Am starting to think that we may have a more serious issue.
      Upon replacing, the starter and starter gear, its starts fine, then after about 10 starts, you start to hear a bit of grinding. The grinding slowly gets worse until the teeth on the starter and the starter gear become trashed.
      I've heard possible solutions from the starter clutch needing replaced to the casing for the starter gear shaft being out of spec?
      I've also noticed that here is no difference or change if its in gear or not.
      I just replaced the trans clutch as well.
      Any suggestions?
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...