Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Guest swanney

2002 Arctic Cat 300 4x4 CDI Box Needed

Recommended Posts

Guest swanney

I need a CDI box for an A/C, 02,300 4X4.

Share this post


Link to post
Share on other sites


Have you tried sites like ebay and bike bandit?

* Added year, make, model, and issue into thread title. Moved to Arctic Cat forum.

Share this post


Link to post
Share on other sites
Guest swanney

Thanks for the info. couldn't find anything on ebay. I believe this machine has a Suzuki engine,I will get the part # off the box tomorrow and check out bike bandit

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By Jean de la Chevrotière
      View File Polaris 700 2002 Owner's manual
      Polaris 2002 700 Owner's Safety and maintenance manual
      Submitter Jean de la Chevrotière Submitted 12/01/2018 Category Polaris ATV  
    • By Jean de la Chevrotière
      Polaris 2002 700 Owner's Safety and maintenance manual
    • By priglmeier
      I own a 2002 Can-Am Quest 650.
      It will start if you massage the throttle a bit and it will continue to run. BUT if you let go of the throttle and try to let it idle it will always die warm or cold.
      It has Non-Oxy premium gas, a new gapped NGK plug, a new carb (as of today) and fresh fluids. After installing the new carb it runs exactly the same.
       
      I only have a few things that I have observed since the new carb:
      The choke still doesn't do anything. It has a good cable and it is hooked up. It on fully off. There is a cable in the top, front of the engine that splits into two connectors. The connected side is in the photo. The other side has the yellow banded section and is not connected. I do not see anything in range of this connector so I don't know if this is normal or not??? The original carb wasn't really dirty or clogged. I'll use it as a spare. I don't see this cable and connectors listed in the Can-Am shop manual. Looking for some help. I want to ride!


    • By gregj49
      Blows out black smoke when you rev it up how do you adjust the carb?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...