Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Dennisg

1989 Suzuki Quadrunner Ltd 4wd fast idle

Recommended Posts

The engine just got through an overhaul of the top end. Started right up but just running fast. I have tried to adjust the carb but nothing works to slow it down or speed it up. There is only 2 screws on the carb, what else is there?

Thanks

Dennisg

Share this post


Link to post
Share on other sites


Check where your throttle cable is installed into the carb if it had been removed when you had the top end done that it is put back togather right. And check to see if your cable is sticking for some reason. If it's running good and the adjustments screws are not changing the idle that would be a starting point to check and it's free. Look for any binding. I'm sure some others on here will help you to for things to check. Good luck with finding the problem!

Share this post


Link to post
Share on other sites

I also agree to check that.

* Added manufacturer to thread title.

Share this post


Link to post
Share on other sites

I checked the connection of the throttle control valve and the carb and all seems well. It only goes in two ways and the first way the motor will not start. The first way the throttle will not work all of the way. So I believe that I have it in correctly. I also looked at the choke and choke cable connection and i believe that it is also correct. started it up and same thing. What is next as the repair manual does not cover such an incident?

Thanks

dennisg

Share this post


Link to post
Share on other sites


I checked the carburetor completely and I believe it was ok. I removed the carb and now it won't start. I am convinced it is a carburetor problem, but the manual is not clear as to what to do next can anyone help.

Thanks

dennisg

Share this post


Link to post
Share on other sites
Dude. With all do respect it is about time to upgrade to something newer. Like with fuel injection. That takes carb prob away. Just saying buddy

If only they made quads like these with fuel injection

Share this post


Link to post
Share on other sites


I'd be checking the carb boot for cracks/leaks & make sure you don't have a vacuum leak going to the petcock....<-if it's equipped.

Share this post


Link to post
Share on other sites
If only they made quads like these with fuel injection

They kinda do. The king quads are great atvs that's what I ride and you won't believe the quality. I personally like the 700 and 750 over the others but they are all just great examples of suzukis high quality machines!

Share this post


Link to post
Share on other sites
They kinda do. The king quads are great atvs that's what I ride and you won't believe the quality. I personally like the 700 and 750 over the others but they are all just great examples of suzukis high quality machines!

No disrespect but you'll find I'm kinda opinionated :D I'm really friendly though lol. But I hate the 700 king quad... almost with a passion! My buddy has had one since 2008 and first of all the caster problem almost killed me. I can't steer the hulkin beast once I try stopping! Its like a shopping cart with the wheels pointed the wrong way. The steering locks full left or full right and I can't pull it back without going fully the other way. Its dangerous! I'm surprised suzuki doesn't have a lawsuit over it. I've been beggin him to do the caster mod (well known mod) for 4 yrs but he don't want to cut into it because its "new". Caster adjustment Mod! Thanks DemiJohn

And then, its too freaking big! In all directions! We ride together a lot and I ride my little 2 wheel drive 250ex. I'm ALWAYS having to wait on him or run the winch cable for him. He's either pinned between trees or can't climb or descend hills that I can tackle easily on my 250ex. Its laughable. Sometimes I have to get off and ride it for him, but I see his point. The king has such a high center of gravity and its so huge that it is scary. Body english doesn't mean much on that beast. He flipped it over backwards 4 yrs ago and sheared his thumb off. Cost $20,000 to put it back on.

Ok if it isn't a hill or live trees he can't get around, its the ones that have fallen over. I can't drive over them, but I can man-handle the little quad enough to get over. The 700? Gotta stretch the winch cable out and take forever.

But hey he should get better traction in snow and mud right? I haven't seen it. A couple winters ago we went riding with another buddy on his MudPro. As long as the snow wasnt over 6 inches, I actually did better than either one of them did. Once the snow got a foot deep I was screwed. But I guess 4x4 must have some redeeming features lol.

A couple months ago we went camping and he pulled a 500lb trailer thru the mtns. I figured the king should be able to handle that no problem. Which it did going in, but coming out he got stuck on a red clay hill. Now the problem with CVT is evident. Once the tires started to spin, they took off full speed! He couldn't crawl. It was either full blast or nothing. CVT is nice for tooling around, but not good for manuevering technically or the best for traction. And there is a delay waiting for everything to kick in.

And I can't go without mentioning he's sent his clutch off for work 2 or 3 times. And the belt slips.

Its a pretty looking machine and it goes fast and oddles of power, but I wouldn't want one. In the real world trying to get from A to B its almost useless unless there is a nice road cut thru the woods. I guess it is nice to put your feet up on the racks and not worry about shifting. Its nice not to have to worry about a carb. But for me those things aren't nice enough to overcome all the problems it has.

I haven't had the 300 king for long, but I like that its narrow (42 inches), really low center of gravity, has gears with a super low range. Its like a tank or bulldozer. I'm not kiddin! And it won't take off uncontrollably like CVT will. The fastest it will go in super low is 5 mph at 9000 rpm. Actually 5th gear in super low is about the same as 1st gear in high range lol! I love it and it makes any amount of work I have to do to it worth it. Its light enough that I can pick it up somewhat if needed to unpin it from around trees. The 700? Not a chance.

I do wish they made a 300 king with fuel injection, but nothing exists that's even remotely close. The trend is for these huge gigantic machines. Everyone wants to see whose is bigger. If I wanted bigger, I would just drive my truck. The idea is to go smaller ;)

Sorry don't mean to offend. I'm just blunt and that's how I see it :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By cliffyh
      Hi,
      Have a 2005 grizzly 660. Just recently started backfiring and showing incorrect speed. Lifted seat and messed with wire going to starter relay, it stops for a bit but seems to come back.
      I ended up pulling all the pins out of the connector for the relay and added new pin/connectors for all 4 wires. fixed it for a little bit but came back shortly after. This was a new starter relay i installed a few months ago. Anyone know if a bad starter relay would do this? 
    • By David Miller
      Does anyone know how to access the check engine codes on a 2018 450 sportsman. Just changed battery and spark plug . It runs fine but the light is on and I need this to plow snow and need it reliable. Any ideas . Thanks
    • By K L Buck Naff
      Trying to replace the carburetor on my 2003 Bear Tracker 250. Two brand new carbs in a row from different suppliers.   Both leak fuel out over flow and intake as soon as I turn the gas on. Any ideas. Am I doing something wrong?
    • By Daryl Mann
      Hey new to the page 
      having an issue with my carb slider jamming ect just replaced the carb with a good pre owned unit and seem to be having a similar issue 
      is there a home fix for this as a posed to buying yet another carb as the quads my daily transport and stuck without it 
      thanks for looking any help great full can also forward video of the problem I’m having if needed 


    • By Ellery Zandt
      I have no idea where the antifreeze line coming off the thermostat goes too. The carb two nipples in the pic create a vacumme. Can someone help me on this please....!!! my email direct is [email protected]!!!!
  • Similar Tagged Content

    • By Guythis448
      Looking for help on wiring up stock wiring harness specifically for a '88 Honda TRX 300 
      If anyone could drop a link or send me a PM it would be much appreciated 
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By suthernboy60
      Since I am not much of a mechanic simple things confuse me. How do you remove the old brake cable for the pedal brake from the frame? Thought I could just pry it out but no luck and not much room to work. Any help is appreciated.
    • By chevynova
      I have a 1988 Suzuki quadrunner 250 4wd it will run if I pop start it but it will not run if I elec. Start or pull start I repair crab four times I got spark compression is good . When it is running it runs fine but I let the gas go it dies please help thank you
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...