Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

JohnP3

1989 Suzuki LT 4WD Denso CDI

Recommended Posts

I redid the carb and that was not the problem tested the CDI and it failed where do you guys buy parts it is a Denso 070000-1540, or a Suzuki 32900-19B00. I really do not want to pay big dollars for it

Share this post


Link to post
Share on other sites


I went to Bike Bandit and it was just a circle of asking the same questions and no results, Fancy looking site with nothing. Even when I gave them the part number nothing .

Thanks for the thought!

Share this post


Link to post
Share on other sites


I have to go across the boarder to get some building supplies. and parts. I will try again the site may have been down, I just went around in a circle.

"E" bay was a good thought I looked at a lot of pieces but all were used, not really looking for used!

Share this post


Link to post
Share on other sites

I got the CDI and installed it It will KICK but not run, I removed the fuel pump and checked it the diaphragms are stretched, anyone know where to buy just the diaphragm?

Share this post


Link to post
Share on other sites
I got the CDI and installed it It will KICK but not run, I removed the fuel pump and checked it the diaphragms are stretched, anyone know where to buy just the diaphragm?

where did you find the did I'm in need of the same part thanks

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Tanner J Hawley
      Hey so i have a 85 Suzuki lt230s and it runs just fine except for some reason idk but wen i put it in gear and let off the clutch it wont move but the shifter goes threw all gears so idk what or how i would go about fixing it or were to even start?? Any help would b very much appreciated
    • By Dizzy siege
      my brakes do not engage and the right hand lever kills the engine and reverse makes a loud clicking crunch sound i think it wont engage into reverse all of the way. I NEED HELP PLEASE 
    • By Orangejbird
      My Dad's 03 Manual Vinson has milky oil. He changed oil and ran it everyday for a week being sure to keep it running for an hour each time. Fresh oil is getting milky again..
      Thinking it's the water pump seal. Has anyone here successfully changed the seal or even replaced the whole pump assembly?
    • By LOGAN WARNER
      Hello everyone, I’m new to this forum. I have a 98 king quad 300, I cannot get it to run right. It will start up and run for a little bit but then it starts sputtering when you give it throttle. It appears to me that it is getting to much fuel. 
      this is what I have done to it: new carburetor, new fuel filter, adjusted the valves.
  • Similar Tagged Content

    • By Guythis448
      Looking for help on wiring up stock wiring harness specifically for a '88 Honda TRX 300 
      If anyone could drop a link or send me a PM it would be much appreciated 
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By Steve1266
      I went out to ride my quad today. When I started it up it ran for a minute, then died. Since then it will turn over but won't start. I've check the spark plug and get great fire. I have had this quad for about 6 months, and very new to breaking it down. But need help. Thanks
    • By suthernboy60
      Since I am not much of a mechanic simple things confuse me. How do you remove the old brake cable for the pedal brake from the frame? Thought I could just pry it out but no luck and not much room to work. Any help is appreciated.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...