Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Went on a SWEET Sun ride !! Had 9 friends join me :yes:Temps in the mid 40`s sunny all day !!

717ride11-20-11001.jpg

717ride11-20-11006.jpg

717ride11-20-11002.jpg

109_0291.jpg

717ride11-20-11011.jpg

717ride11-20-11008.jpg

717ride11-20-11007.jpg

Here`s Willpop recieving his princess award for the only one to crash and burn

717ride11-20-11013.jpg

717ride11-20-11010.jpg

ate like a king when we got back !! ribs and steak

717ride11-20-11014.jpg

Share this post


Link to post
Share on other sites


Looks like a great time Quadnut guy !! :partyc:

Can't believe you guys don't have more snow ... :shock2:

Where's this at ?? It looks like the country around Woodland when I was stationed at Ft Carson, Colorado Springs .... :woot:

Anyway ... THANKS fer shar'in .... :cheers2c:

...

Share this post


Link to post
Share on other sites
Looks like a great time Quadnut guy !! :partyc:

Can't believe you guys don't have more snow ... :shock2:

Where's this at ?? It looks like the country around Woodland when I was stationed at Ft Carson, Colorado Springs .... :woot:

Anyway ... THANKS fer shar'in .... :cheers2c:

...

Dead on Gunny Woodland park 717 trail system near HY 67 just below rainbowFalls !!

Share this post


Link to post
Share on other sites


Dead on Gunny Woodland park 717 trail system near HY 67 just below rainbowFalls !!

:woot:

I was at Ft Carson in 75-77 :yes:

2003 thru 2004 ....then I was shipped to Ft Bliss, El Paso, TX ... :ack2c: ... :cuss:c

...

Share this post


Link to post
Share on other sites

wish we had mountain trails here ... it looked like a blast ....we have had alot of rain here and most of the areas we ride are under water ...<<<it sucks ...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

  • Similar Topics

    • By Abbeypalm
      While cruising, my 2011 750 king quad suddenly shut down. As it happened, red lights on the display flashed. Any ideas? My head lights suddenly stopped working about a week ago, if that helps. I have no power at all. Thanks 
    • By Susan Makowski-DeGraw
      My quad runs,  it starts up runs for about 10 minutes and then it dies if you let it sit for 10 minutes it’ll start back up ride for another 10 minutes and then die again, trying to figure out why it keeps stalling
       
       
    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
    • By abi
      Hello ladies and gents. Just picked this guy up in October and getting around to doing the required maintenance to make sure everything is right before any long rides or work is done. 
      Some background: I am I believe the 4th owner, (however the 3rd didn't actually ride it). It has unknown hours or odometer due to what appears to be a common issue. 
      I have noticed the fuel gauge doesn't work (just keeps flashing empty),
      I did come across a google search that mentioned these were a common problem but was fixed by replacing the dash (seems like overkill) and another post mentioning someone attempting a fix. 
      Any particular issues on these quads to pay attention to beyond the dash ?
      Going to be replacing the rear tires, oil change, filters and plug. Anything else I should do with an unknown history such as diff flush/change ? 
      I believe there is a service manual here but I need a few more posts. Hopefully this post will drive some answers and more questions I might have. Thanks!

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...