Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

pokerdad911

2007 Suzuki LTR 450 Starts but sputters

Recommended Posts

My 07 Ltr 450 starts but wont stay idleing.My bike had sat for a long time and stupid me did not drain gas out of quad for storage. I took out gas before starting, and put in new gas. Old gas was sticky looking or varnished. Do you think my fuel filter is gunked up and fuel is barely passing thru to the injectors. I hope the crappy gas did not get by filter and gunk up my injectors. I want it to run like a champ like it did before 8 months ago.. HELP.. Any wisdom would help greatly. :no:

Share this post


Link to post
Share on other sites


Go get some Sea Foam. Read how much to use cause you don't want to much. Sea Foam is get for cleaning injector or so I'm told.

Even though you drained the fuel you still had enough that got through and gummed the injectors I'm guessing.

Share this post


Link to post
Share on other sites

Seafoam would be helpful in small amounts until you get things cleaned up in your engine and fuel system.

Once youget everything running well then you would want to use Stabil gas additive regularly to keep it clean and running smooth.

When you go to store it (if you do) you would add Seafoam to the gas and run the motor for several minutes and then shut it down. That will lube the motor and keep the fuel from gelling when it sits for long periods of time.

This will pretty much eliminate sputtering caused by bad, old fuel and or moisture in the fuel.

Edited by AQUAJOE
further explanation

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Jeff Miller
      I'm trying to troubleshoot a starting issue. For a while, maybe a year sometimes I would hit the starter button and I'd hear a single loud click, but the starter wouldn't turn. Usually if I could pull the pull start or roll it in gear it would then start. (now I'm thinking that was coincidence) Now it only clicks. I tried to check what I could, battery is good, solenoid clicks strong, cleaned all connections (which were 80% clean anyway). I started thinking the starter wasn't spinning. I pulled it and it spins freely. The gear that it contacts in the engine-I can wiggle it maybe 1/16th to 1/8th inch back and forth. When I reinstall the starter I feel it jerk when I hit the button. I'm thinking maybe it's the starter clutch? It seems when there's a problem with them they usually just spin freely and don't engage at all. Is it possibly something is causing it to lock? I'm a bit lost now.
    • By Rich1028
      Leota Quad Trails
      4-5-20
       
       
    • By LOGAN WARNER
      Hello everyone, I’m new to this forum. I have a 98 king quad 300, I cannot get it to run right. It will start up and run for a little bit but then it starts sputtering when you give it throttle. It appears to me that it is getting to much fuel. 
      this is what I have done to it: new carburetor, new fuel filter, adjusted the valves.
    • By basmn
      A friend has a 07 trx 400ex..the engine drain bolt housing has a couple of cracks where the drain bolt threads in and is leaking oil...a one had any luck sealing this area with JB weld or something similar ?
  • Similar Tagged Content

    • By Michael Aiken
      Where can I find a wiring diagram for my 2005 450 Kodiak. Thanks.
    • By Kristpj
      I know this tooic has been addressed by many, I’ve looked through many forums and pages. I did not find anything like the problem i have.
      I have a 2007 Kingquad 450. I have a new fully charged battery. When i turn the key, the dash flashes and seems to struggle before getting fully lite. We can hear a small relay near the computer clicking, i think it is the fuel pump relay. When i turn off the engine kill switch and press the starting button relays click and all the power shuts off, i turn the key off, engine kill switch then start over, power is there. Atv will start with pull start, but not elextricly. if i try to use my winch, all power cuts and engine dies. 
       
      Can anyone tell me what it may be? or has anyone fsced an issue like this before?
    • By chuckufarlie
      I have a 2018 Kodiak 450 EPS that just this past Sunday I ran through a bit of water.
      After the puddle the belt was slipping, so I pulled over and drained the ultramatic housing and the slipping problem went away. This was all in L and everything seemed to work fine. Later when I got on a road, I put it in H, but it still rode like it was in low... i.e. I had to rev it up a lot just to get to 30mph.
      When at home I pulled the ultramatic cover off to inspect, and it looked okay in there. Not much dirt, belt and everything are clean, but when I rev up the engine (with cage in place, of course), the belt doesn't get to the top of the clutch (maxes out about an inch or 1.5" from top of clutch, so maybe it is normal).. I put it back together but same thing... H seems like L still.
      Do you think the clutch needs to be further dissected for cleaning, or could this be an issue with the gear selector?
       
    • By Steven Alter
      I have a 2018 450 and the digital gause has started flashing on an off while driving. The backlit also goes on and off. It is worse when I hit the gas. The battery died a few weeks ago and I jumped it but its been fine until last night. Called the dealer and showed them a vid and they recommend replacing the gauge and its like 600 bucks. The machine has less than 100 hours on it. I would really hate to have to change it out. also the unit sometimes has trouble starting. Any ideas?
    • By Admin
      View File 2014 Arctic Cat 450 ATV Service Manual
      2014 Arctic Cat 450 ATV Service Manual
      Submitter Admin Submitted 02/08/2019 Category Arctic Cat ATV  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...