Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

CK1999_400ex

What does your quad weigh ?

Recommended Posts



Well I found specs on my Yamaha Warrior saying dry weight as 397lbs.

Now the question is if I add the oil and about a gallon and a half of gas and and coated it in mud how much would it weigh. I had it stuck in a wash and I picked up the front end and put it up on the ledge of the wash then picked up the rear end and rolled it up on to the ledge of the wash.

Had a sore chest all week cause of that.

Share this post


Link to post
Share on other sites

lol.. i know how that is ... you should tru doing that with a quad over 500 lbs ... its a real chore ... i have put a cheap 1500 lb winch on my Vforce and it really helps with things like that ...

Share this post


Link to post
Share on other sites


my quad stock is 600lbs. i have over size tires, skid plates and bumpers to add more ... i know its one heavy mf if stuck in mud, thank god for diff lock and thank warn for winches!

geez, the big bear 350 i have is 567lbs. dry. thought it would be much lighter than the grizzly...

Edited by oxidized_black

Share this post


Link to post
Share on other sites
some quads are very heavy ... my polaris 500X2 weighs 798 lbs dry ... :huh:

man o man. i didn't think you were serious, so i went online and saw a 2008 500x2 weighed in at 830lbs. dry. is that retarded or what? you sure don't want that beast to roll onto you for sure! sorry i doubted you. hahaha

Share this post


Link to post
Share on other sites

i have rolled it 1 time and it chaced me down a hill i was glad it went away from me that time ... im not going to climb that hill any more an i check the back side of every hill now 2 make shure its not that rough on the other side ...

Share this post


Link to post
Share on other sites
my 400ex is under 400 lbs .... and is easy to throw around

Your right I have to use some body language to get it around tight turns but its easy to throw around trails

Sent from my SGH-T959V using Tapatalk

Share this post


Link to post
Share on other sites




my V force is 520 lbs but has about 67 horse ... wich really makes up for the weight i have several new goodies for it that will bring it up to 75hp that will be put on it this winter

Share this post


Link to post
Share on other sites
my V force is 520 lbs but has about 67 horse ... wich really makes up for the weight i have several new goodies for it that will bring it up to 75hp that will be put on it this winter

I'll race you:biggrin:

Share this post


Link to post
Share on other sites

but what i dont tell or show people is the zex nitrous bottle on it ... its hiding under the plastic ... thats another 50 to 75 hp ... lol..

Share this post


Link to post
Share on other sites


it has twin carbs and i have the jet kit but dont remember what size i put in it .. it was only a couple sizes over stock .. it has an air box mod on it that i fornd on another site ... the nitrous is the little tank like the nos brand they call sneeky pete its only the size of a can of hair spray .. but does the trick ... im puting an after market exhaust on it and a few other things this winter

Share this post


Link to post
Share on other sites

From what i have heard the Sneeky Pete "N2o" adds about 5th and for a few seconds. I thought you said your quad has 67hp? Stock is 35? And you have a stock exhaust?

Share this post


Link to post
Share on other sites

it has the stock pipes and muffler with the baffles cut out ... it has some porting in the heads and stage 2 hot cams with 785 big bore ... i had a muzzys on it but trashed it when i had a wheelie go bad ...lol...the nos bottle will last about 2 to 3 min then its empty

Edited by CK1999_400ex

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By kgard
      I am trying to figure out a way to make my high beam include the 2 front lights that come on in low beam mode. As it sits now I need to use the low beam to see the trail in front of me but can't see far ahead. On high beam I can see ahead but miss most of the trail right in front of me. Does anyone know of a kit that would mate the two front lights to the main headlight on high beam ? 
    • By Ponetay
      I’m am trying to figure out how to set this to tdc so I can set the valves. Anyone know the procedure?
    • By Rushville
      2000 Sportsman 335 lost the speedo functions. Don't need the speedo but need AWD.  Is there a wiring bypass that can be done to activate AWD ? 
    • By jasonlawrence
      Hi, I'm new to this forum and am in desperate need of help. I recently purchased a 05 polaris sportsman 90. The quads motor runs great. The quad will not accelerate forward. If it does its slow and will eventually pick up speed and then runs unbelievable. It has great power and torque in reverse but couldn't go over a twig in forward. I'm lost, any help would be greatly appreciated. The belt is in good condition and the and drained the trans oil and there is no metal shavings
    • By Brandi Nedley
      We just bought a used polaris sawtooth 2006. Any advice on pros and cons or things to look out for. were 1st time owners. basic maintenance?
       
  • Similar Tagged Content

    • By LTZ-Zach
      So i was riding the other day and my quad randomly shut off. It started back up and ran completely fine for a little while and then it started idling terribly.
      I cleaned the carb and changed all the jets and everything except the float due to the rebuild kit not coming with one and it actually runs worse then it did before.
      It will run and idle decent now but when I give it gas it dies.
      Does anybody know what could be wrong?
      I also changed the spark plug and air filter along with the oil and oil filter.
       
    • By johnwayne
      i have a 2000 suzuki king quad lt-f300f that i picked up as a project bike. it didnt run well when it was parked outside 5 years ago. it cranked after putting fresh gas - but would not run below half throttle, i took apart the carb, cleaned debris, and re-assembled. i suspect that the pilot needle is sheared off - it never protrudes into the throttle body through the pinhole. now to get the bike to ALMOST idle, the throttle idle adjustment knob is all the way up/in. the pilot needle is turned almost all the way in/up (if i understand correct, it should nominally be out 2 1/4 turns or so). and like i said, it will ALMOST idle. floods easily, rides rough.
      wanted to hear from those more experienced than me with suzukis - and im self-taught atv repair, so dont laugh too hard if my verbiage/part names is way off. 
      facing the driver's side of the bike [US] there are three hoses on this side of the carb. without a service manual or way of knowing what was messed up before i got it, i think i have them right: front hose as a vacuum to the petcock, middle hose as vacuum to the fuel pump, rear hose as fuel line from the fuel pump. running the bike in prime position results in flooding even while riding. with all hoses disconnected from the carb, fuel slowly drips from the vacuum line connected to the petcock.
      so just my speculation is that the diaphragm in the petcock is split, and the pilot needle is broke off - causing my inability to not quite idle and the rough ride. this suzuki is hoses and cables everywhere compared to the honda ranchers and yamaha warriors i am used to. I would like to have a plan rather than: replace everything at once.
      is my speculation on the right track, or could something else be at play? say, if the compression was non-existent, would that cause non-idling? i am all ears, look forward to the input.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...